summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-27 16:17:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-27 16:17:05 +0000
commit6c8f917fb480050f4b5b93b0c576f9caa3b5a9e0 (patch)
tree1faaa5d59febd26d90530502f7ea895fa74a9b84 /net-analyzer/net-snmp
parentRebase on 1.2_rc1. Thanks Arfrever. (diff)
downloadgentoo-2-6c8f917fb480050f4b5b93b0c576f9caa3b5a9e0.tar.gz
gentoo-2-6c8f917fb480050f4b5b93b0c576f9caa3b5a9e0.tar.bz2
gentoo-2-6c8f917fb480050f4b5b93b0c576f9caa3b5a9e0.zip
Hopefully fix race condition reported in bug #432982 by Luis Ferreira; make sure that there is no automagic dependency over libnl on the stable version.
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/net-snmp')
-rw-r--r--net-analyzer/net-snmp/ChangeLog7
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.7.2_rc1-r1.ebuild12
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild8
3 files changed, 15 insertions, 12 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index cf943e7efe61..385c40fc4852 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.239 2012/08/27 15:28:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.240 2012/08/27 16:17:05 flameeyes Exp $
+
+ 27 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ net-snmp-5.7.2_rc1-r1.ebuild, net-snmp-5.7.2_rc1.ebuild:
+ Hopefully fix race condition reported in bug #432982 by Luis Ferreira; make
+ sure that there is no automagic dependency over libnl on the stable version.
*net-snmp-5.7.2_rc1-r1 (27 Aug 2012)
diff --git a/net-analyzer/net-snmp/net-snmp-5.7.2_rc1-r1.ebuild b/net-analyzer/net-snmp/net-snmp-5.7.2_rc1-r1.ebuild
index ec85b6f337f8..62c825b08d83 100644
--- a/net-analyzer/net-snmp/net-snmp-5.7.2_rc1-r1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.7.2_rc1-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.7.2_rc1-r1.ebuild,v 1.1 2012/08/27 15:28:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.7.2_rc1-r1.ebuild,v 1.2 2012/08/27 16:17:05 flameeyes Exp $
EAPI=4
PYTHON_DEPEND="python? 2"
WANT_AUTOMAKE=none
-PATCHSET=1
+PATCHSET=3
inherit eutils perl-module python autotools
@@ -79,11 +79,6 @@ src_configure() {
use python && export PYTHON_DIR="$(python_get_sitedir)"
- if ! use pci; then
- export ac_cv_header_pci_pci_h=no
- export netsnmp_cv_func_pci_lookup_name_LMIBLIBS=no
- fi
-
econf \
--with-install-prefix="${D}" \
--with-sys-location="Unknown" \
@@ -107,7 +102,8 @@ src_configure() {
$(use_with bzip2) \
$(use_with zlib) \
$(use_with rpm) \
- $(use_with netlink libnl)
+ $(use_with netlink nl) \
+ $(use_with pci)
}
src_compile() {
diff --git a/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild b/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild
index 88ced650b3ef..1838ea2488a4 100644
--- a/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild,v 1.8 2012/08/26 14:14:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.7.2_rc1.ebuild,v 1.9 2012/08/27 16:17:05 flameeyes Exp $
EAPI=4
PYTHON_DEPEND="python? 2"
WANT_AUTOMAKE=none
-PATCHSET=1
+PATCHSET=3
inherit eutils perl-module python autotools
@@ -100,7 +100,9 @@ src_configure() {
$(use_with tcpd libwrap) \
$(use_with bzip2) \
$(use_with zlib) \
- $(use_with rpm)
+ $(use_with rpm) \
+ --without-nl \
+ --with-pci
}
src_compile() {