summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-13 14:43:44 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-13 14:43:44 +0000
commit1fe5f5c97a4518d11ac5b73536a96fab781ecb3a (patch)
tree5875fc61d22c160b949efc049ba8283e9db38980 /net-analyzer/linkchecker
parentMask nautilus[sendto] on arches where gnome-3's nautilus-sendto is not keywor... (diff)
downloadgentoo-2-1fe5f5c97a4518d11ac5b73536a96fab781ecb3a.tar.gz
gentoo-2-1fe5f5c97a4518d11ac5b73536a96fab781ecb3a.tar.bz2
gentoo-2-1fe5f5c97a4518d11ac5b73536a96fab781ecb3a.zip
net-analyzer/linkchecker: Version BUmp
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/linkchecker')
-rw-r--r--net-analyzer/linkchecker/ChangeLog7
-rw-r--r--net-analyzer/linkchecker/linkchecker-7.8.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index 4275d8e12e33..c57f29ae8daf 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.69 2012/04/23 09:46:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.70 2012/05/13 14:43:44 jlec Exp $
+
+*linkchecker-7.8 (13 May 2012)
+
+ 13 May 2012; Justin Lecher <jlec@gentoo.org> +linkchecker-7.8.ebuild:
+ Version BUmp
23 Apr 2012; Justin Lecher <jlec@gentoo.org> -linkchecker-5.2.ebuild,
-linkchecker-7.4.ebuild, -linkchecker-7.5.ebuild:
diff --git a/net-analyzer/linkchecker/linkchecker-7.8.ebuild b/net-analyzer/linkchecker/linkchecker-7.8.ebuild
new file mode 100644
index 000000000000..f6a857f2f982
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-7.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-7.8.ebuild,v 1.1 2012/05/13 14:43:44 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 2.6 3.*"
+PYTHON_MODNAME="linkcheck"
+
+inherit bash-completion-r1 distutils eutils
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://linkchecker.sourceforge.net/ http://pypi.python.org/pypi/linkchecker/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion bookmarks clamav doc geoip gnome login syntax-check X"
+
+RDEPEND="
+ dev-python/dnspython
+ bash-completion? ( dev-python/optcomplete )
+ bookmarks? ( dev-python/pysqlite:2 )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python )
+ gnome? ( dev-python/pygtk:2 )
+ login? ( dev-python/twill )
+ syntax-check? (
+ dev-python/cssutils
+ dev-python/utidylib
+ )
+ X? (
+ dev-python/PyQt4[X,assistant]
+ dev-python/qscintilla-python
+ )"
+DEPEND="
+ doc? ( x11-libs/qt-assistant )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/7.4-missing-files.patch \
+ "${FILESDIR}"/7.0-unbundle.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc/html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ delete_gui() {
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ }
+ python_execute_function -q delete_gui
+ fi
+ if use doc; then
+ dohtml doc/html/*
+ fi
+ use bash-completion && dobashcomp config/linkchecker-completion
+}