summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-03 07:35:02 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-03 07:35:02 +0000
commit7e4bbe412181b843e35b054f24b0913cb94a0864 (patch)
treeb28a3434e5e06ce72abd6b06b6de6a3f8cdc35c0 /net-analyzer/lft/lft-2.5.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-7e4bbe412181b843e35b054f24b0913cb94a0864.tar.gz
gentoo-2-7e4bbe412181b843e35b054f24b0913cb94a0864.tar.bz2
gentoo-2-7e4bbe412181b843e35b054f24b0913cb94a0864.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-analyzer/lft/lft-2.5.ebuild')
-rw-r--r--net-analyzer/lft/lft-2.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/lft/lft-2.5.ebuild b/net-analyzer/lft/lft-2.5.ebuild
new file mode 100644
index 000000000000..b4e69c59e1af
--- /dev/null
+++ b/net-analyzer/lft/lft-2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/lft/lft-2.5.ebuild,v 1.1 2005/09/03 07:35:02 dragonheart Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Layer Four Traceroute: an advanced traceroute implementation"
+HOMEPAGE="http://oppleman.com/lft/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="VOSTROM"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+IUSE=""
+
+DEPEND="virtual/libpcap"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-installpath.patch
+}
+
+src_compile() {
+ # avoid suid related security issues.
+ append-ldflags -Wl,-z,now
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc CHANGELOG README TODO
+}