summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-07-20 07:10:12 +0000
committerPeter Volkov <pva@gentoo.org>2010-07-20 07:10:12 +0000
commitea915b3f249c39a98aa357ddca4840c919a7a34b (patch)
treebffefa2e41af3460fb50e2747faaabe0adf691f9 /net-analyzer/httping
parentCleanup, added upnp USE flag in 9999, thank Nikoli for this job. (diff)
downloadgentoo-2-ea915b3f249c39a98aa357ddca4840c919a7a34b.tar.gz
gentoo-2-ea915b3f249c39a98aa357ddca4840c919a7a34b.tar.bz2
gentoo-2-ea915b3f249c39a98aa357ddca4840c919a7a34b.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/httping-1.4.3.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 0af3db3e5785..c76bbc5a621a 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.59 2010/06/21 18:58:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.60 2010/07/20 07:10:12 pva Exp $
+
+*httping-1.4.3 (20 Jul 2010)
+
+ 20 Jul 2010; Peter Volkov <pva@gentoo.org> +httping-1.4.3.ebuild:
+ Version bump.
21 Jun 2010; Jeroen Roovers <jer@gentoo.org> httping-1.4.1.ebuild:
Stable for HPPA (bug #323579).
diff --git a/net-analyzer/httping/httping-1.4.3.ebuild b/net-analyzer/httping/httping-1.4.3.ebuild
new file mode 100644
index 000000000000..af2c2ebb5154
--- /dev/null
+++ b/net-analyzer/httping/httping-1.4.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.4.3.ebuild,v 1.1 2010/07/20 07:10:12 pva Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl"
+
+RDEPEND=">=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+#src_prepare() {
+# sed 's:^CFLAGS=:CFLAGS+=:' -i Makefile || die
+#}
+
+src_compile() {
+ append-flags -D_GNU_SOURCE
+ emake \
+ CC="$(tc-getCC)" \
+ $(use ssl && echo SSL=yes || echo SSL=no) \
+ $(use debug && echo DEBUG=yes || echo DEBUG=no) \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin httping || die "dobin failed"
+ doman httping.1 || die "doman failed"
+ dodoc readme.txt || die "dodoc failed"
+}