summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-02-01 17:19:46 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-02-01 17:19:46 +0000
commit7c7562c30535fa254a3b36e551eaaf927294fd81 (patch)
tree13af2a809da03e7d78dd1da8b186c54f500623b9 /net-analyzer/fail2ban/fail2ban-0.7.6.ebuild
parentStable on sparc (diff)
downloadgentoo-2-7c7562c30535fa254a3b36e551eaaf927294fd81.tar.gz
gentoo-2-7c7562c30535fa254a3b36e551eaaf927294fd81.tar.bz2
gentoo-2-7c7562c30535fa254a3b36e551eaaf927294fd81.zip
Version bump and cleanup
(Portage version: 2.1.2-r1)
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-0.7.6.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.7.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.7.6.ebuild b/net-analyzer/fail2ban/fail2ban-0.7.6.ebuild
new file mode 100644
index 000000000000..6caf2e0f2b23
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.7.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.7.6.ebuild,v 1.1 2007/02/01 17:19:46 jokey Exp $
+
+inherit distutils
+
+DESCRIPTION="Bans IP that make too many password failures"
+HOMEPAGE="http://fail2ban.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fail2ban/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4"
+RDEPEND=${DEPEND}
+
+src_install() {
+ distutils_src_install
+
+ newinitd files/gentoo-initd fail2ban
+ dodoc CHANGELOG README TODO
+ doman man/*.1
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Configuration files are now in /etc/fail2ban"
+ einfo
+}
+