summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-01-16 19:11:52 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-01-16 19:11:52 +0000
commite42123e2eb8fc9953884e2d534ea42f3f90c30b0 (patch)
treef6ed41d2da5951238dd8a6cec74550af467f4d06 /net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild
parentAdded a patch to fix issues on alpha thanks to Thomas Cort <tcort@cs.ubishops... (diff)
downloadgentoo-2-e42123e2eb8fc9953884e2d534ea42f3f90c30b0.tar.gz
gentoo-2-e42123e2eb8fc9953884e2d534ea42f3f90c30b0.tar.bz2
gentoo-2-e42123e2eb8fc9953884e2d534ea42f3f90c30b0.zip
Abort if perl is compiled with USE=minimal. Fixes bug Bug 98858.
(Portage version: 2.0.54)
Diffstat (limited to 'net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild')
-rw-r--r--net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild b/net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild
index 16f40aca6d8a..b9c42c652124 100644
--- a/net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild,v 1.7 2005/12/13 20:19:18 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.13-r2.ebuild,v 1.8 2006/01/16 19:11:52 vanquirius Exp $
inherit libtool flag-o-matic eutils
@@ -34,6 +34,16 @@ DEPEND="${RDEPEND}
sys-devel/flex
sys-apps/sed"
+pkg_setup() {
+ # bug 119208
+ if built_with_use dev-lang/perl minimal ; then
+ ewarn "ethereal will not build if dev-lang/perl is compiled with"
+ ewarn "USE=minimal. Rebuild dev-lang/perl with USE=-minimal and try again."
+ ebeep 5
+ die "dev-lang/perl compiled with USE=minimal"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"