summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-06-03 13:54:17 +0000
committerRick Farina <zerochaos@gentoo.org>2013-06-03 13:54:17 +0000
commitd0c2e04176205c1f635c6f308130435311482f15 (patch)
tree7f648951fe6d51d0425a91a2e0e705532000de36 /net-analyzer/cloudshark
parentclean description properly (diff)
downloadgentoo-2-d0c2e04176205c1f635c6f308130435311482f15.tar.gz
gentoo-2-d0c2e04176205c1f635c6f308130435311482f15.tar.bz2
gentoo-2-d0c2e04176205c1f635c6f308130435311482f15.zip
adjusting some line lengths down for readability
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-analyzer/cloudshark')
-rw-r--r--net-analyzer/cloudshark/ChangeLog5
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/net-analyzer/cloudshark/ChangeLog b/net-analyzer/cloudshark/ChangeLog
index b27bac6979cf..052602c65c5f 100644
--- a/net-analyzer/cloudshark/ChangeLog
+++ b/net-analyzer/cloudshark/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/cloudshark
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/ChangeLog,v 1.3 2013/06/03 13:37:39 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/ChangeLog,v 1.4 2013/06/03 13:54:17 zerochaos Exp $
+
+ 03 Jun 2013; Rick Farina <zerochaos@gentoo.org> cloudshark-1.0.2.174.ebuild:
+ adjusting some line lengths down for readability
03 Jun 2013; Rick Farina <zerochaos@gentoo.org> cloudshark-1.0.2.174.ebuild:
clean description properly
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
index 9ed55fed2f05..e0eeaa819a94 100644
--- a/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
+++ b/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild,v 1.2 2013/06/03 13:37:39 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild,v 1.3 2013/06/03 13:54:17 zerochaos Exp $
EAPI=5
@@ -22,14 +22,18 @@ PDEPEND="net-analyzer/wireshark:=[lua]
S="${WORKDIR}/${PN}-${SV}"
-get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
+get_PV() {
+ local pv=$(best_version $1)
+ pv=${pv#$1-}; pv=${pv%-r*}
+ pv=${pv//_}; echo ${pv}
+}
src_prepare() {
- #cloudshark isn't meant to be installed systemwide, most of this is caused by that fact
+ #cloudshark isn't meant to be installed systemwide, we fix that
epatch "${FILESDIR}"/cs_log_dir.patch
sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua
- #the echo line seemed a cleaner solution but it causes errors, looks like it expects windows paths only
+ #causes errors, looks like it expects windows paths only
#echo "CLOUDSHARK_CABUNDLE = /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt" >> cloudshark_init.default
sed -i "s#%s/curl-ca-bundle.crt#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt#" cloudshark.lua
@@ -37,10 +41,6 @@ src_prepare() {
#sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default (tshark support doesn't seem to work)
}
-src_test() {
- [ "md5sum install-unix" -ne "405cb4dd526bf5261bbb56714baa67f0 install-unix" ] && die "install instructions have changed"
-}
-
src_install() {
insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
doins cloudshark.lua json.lua version.lua curl-ca-bundle.crt