summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-05 11:27:39 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-05 11:27:39 +0000
commit1137e8de792e014a897692b841f4d08b52bed412 (patch)
treefc074f1a4b1d897c4df5df7423730eab6c927c98 /net-analyzer/cacti
parentif doc .. build examples (Manifest recommit) (diff)
downloadgentoo-2-1137e8de792e014a897692b841f4d08b52bed412.tar.gz
gentoo-2-1137e8de792e014a897692b841f4d08b52bed412.tar.bz2
gentoo-2-1137e8de792e014a897692b841f4d08b52bed412.zip
Added additional install instructions (crontab). Closes #53709; version detection fix
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/cacti-0.8.5a.ebuild23
2 files changed, 19 insertions, 11 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 6dc77676c992..b4f2e5e30e03 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.24 2004/06/24 21:58:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.25 2004/07/05 11:27:39 eldad Exp $
+
+ 05 Jul 2004; Eldad Zack <eldad@gentoo.org> cacti-0.8.5a.ebuild:
+ Added additional install instructions (crontab). Closes #53709. Thanks to
+ Lorinc Czegledi <lorinc.czegledi@mail.cpst.hu>. Also fixed previous version
+ detection.
08 May 2004; Danny van Dyk <kugelfang@gentoo.org> cacti-0.8.5a.ebuild:
Marked ~amd64.
diff --git a/net-analyzer/cacti/cacti-0.8.5a.ebuild b/net-analyzer/cacti/cacti-0.8.5a.ebuild
index ad34ec0fd86c..3a3bfa210de6 100644
--- a/net-analyzer/cacti/cacti-0.8.5a.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.5a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.5a.ebuild,v 1.5 2004/06/24 21:58:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.5a.ebuild,v 1.6 2004/07/05 11:27:39 eldad Exp $
inherit eutils webapp-apache
@@ -38,12 +38,12 @@ src_install() {
dodoc docs/{CHANGELOG,CONTRIB}
dodoc LICENSE
- rm docs/{INSTALL,UPGRADE,INSTALL-WIN32}.htm
+ #rm docs/{INSTALL,UPGRADE,INSTALL-WIN32}.htm
rm docs/{README,CHANGELOG,CONTRIB}
rm LICENSE README
- mv docs/manual .
- rm -fr docs
+ #mv docs/manual .
+ rm -rf docs
rm -rf cactid
edos2unix `find -type f -name '*.php'`
@@ -55,9 +55,8 @@ src_install() {
pkg_postinst() {
# check to see if we have a previous version installed
- minor_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f2)"
- rel_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f3)"
- if [ ${minor_inst}${rel_inst} -lt 81 ]
+ ver_installed="$(ls -d /var/db/pkg/net-analyzer/cacti* | sed 's:.*cacti-::')"
+ if [[ ${ver_installed} != ${PV} ]]
then
einfo
einfo "The cacti has been installed to ${INSTALL_DEST}"
@@ -78,7 +77,9 @@ pkg_postinst() {
einfo " \$database_hostname = \"localhost\";"
einfo " \$database_username = \"cactiuser\";"
einfo " \$database_password = \"cacti\";"
- einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo "6. Add this line to your /etc/crontab file:"
+ einfo " */5 * * * * ${HTTPD_USER} php ${HTTPD_ROOT}${PN}/cmd.php > /dev/null 2>&1"
+ einfo "7. Point your web browser to: http://your-server/cacti/"
einfo " Select \"Upgrade\"."
einfo " Make sure to fill in all of the path variables carefully and"
einfo " correctly on the following screen."
@@ -88,7 +89,7 @@ pkg_postinst() {
einfo " register_argc_argv = On"
einfo
einfo "Test your upgraded installation. When all is fine you can"
- eingo "drop the cacti_old database like so:"
+ einfo "drop the cacti_old database like so:"
einfo " shell> mysqladmin -p drop cacti_old"
einfo
else
@@ -111,7 +112,9 @@ pkg_postinst() {
einfo " \$database_hostname = \"localhost\";"
einfo " \$database_username = \"cactiuser\";"
einfo " \$database_password = \"cacti\";"
- einfo "5. Point your web browser to: http://your-server/cacti/"
+ einfo "5. Add this line to your /etc/crontab file:"
+ einfo " */5 * * * * ${HTTPD_USER} php ${HTTPD_ROOT}${PN}/cmd.php > /dev/null 2>&1"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
einfo " Make sure to fill in all of the path variables carefully and"
einfo " correctly on the following screen."
einfo