summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-11-30 16:01:56 +0000
committerPeter Volkov <pva@gentoo.org>2009-11-30 16:01:56 +0000
commit583d665523f023c72eaea77f164911bace9d4d76 (patch)
treea2191cae0d6339980434efeaee3959e1b290c0dc /net-analyzer/argus
parentAdd ~arm/~ia64/~s390/~sh/~sparc wrt #285952 (diff)
downloadgentoo-2-583d665523f023c72eaea77f164911bace9d4d76.tar.gz
gentoo-2-583d665523f023c72eaea77f164911bace9d4d76.tar.bz2
gentoo-2-583d665523f023c72eaea77f164911bace9d4d76.zip
Version bump, fixes bug #247955 thank Diego E. 'Flameeyes' Pettenò for report.
(Portage version: 2.1.7.9/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus')
-rw-r--r--net-analyzer/argus/ChangeLog9
-rw-r--r--net-analyzer/argus/argus-3.0.2.ebuild70
-rw-r--r--net-analyzer/argus/files/argus-disable-tcp-wrappers-automagic.patch24
3 files changed, 102 insertions, 1 deletions
diff --git a/net-analyzer/argus/ChangeLog b/net-analyzer/argus/ChangeLog
index 110bb71a42e9..8c55f742a878 100644
--- a/net-analyzer/argus/ChangeLog
+++ b/net-analyzer/argus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/argus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.18 2009/09/23 18:17:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.19 2009/11/30 16:01:56 pva Exp $
+
+*argus-3.0.2 (30 Nov 2009)
+
+ 30 Nov 2009; Peter Volkov <pva@gentoo.org> +argus-3.0.2.ebuild,
+ +files/argus-disable-tcp-wrappers-automagic.patch:
+ Version bump, fixes bug #247955 thank Diego E. 'Flameeyes' Pettenò for
+ report.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> argus-2.0.5.ebuild,
argus-2.0.6.ebuild:
diff --git a/net-analyzer/argus/argus-3.0.2.ebuild b/net-analyzer/argus/argus-3.0.2.ebuild
new file mode 100644
index 000000000000..6f78943e67f4
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.2.ebuild,v 1.1 2009/11/30 16:01:56 pva Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug tcpd"
+
+# sasl? ( >=dev-libs/cyrus-sasl-2.1.22 )
+RDEPEND="net-libs/libpcap
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+
+ epatch "${FILESDIR}/${PN}-disable-tcp-wrappers-automagic.patch"
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ # $(use_with sasl) \
+ econf \
+ $(use_with tcpd wrappers)
+}
+
+src_install () {
+ doman man/man5/* man/man8/*
+ dosbin bin/argus{,bug} || die
+
+ dodoc ChangeLog CREDITS README || die
+
+ insinto /etc/argus
+ doins support/Config/argus.conf || die
+
+ newinitd "${FILESDIR}/argus.initd" argus || die
+ dodir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that init script will fail to work."
+}
diff --git a/net-analyzer/argus/files/argus-disable-tcp-wrappers-automagic.patch b/net-analyzer/argus/files/argus-disable-tcp-wrappers-automagic.patch
new file mode 100644
index 000000000000..2117756a2636
--- /dev/null
+++ b/net-analyzer/argus/files/argus-disable-tcp-wrappers-automagic.patch
@@ -0,0 +1,24 @@
+=== modified file 'configure.in'
+--- configure.in 2009-10-16 13:21:02 +0000
++++ configure.in 2009-10-16 13:30:39 +0000
+@@ -279,6 +279,11 @@
+ LIBS="$LIBS $V_PCAPDEP"
+ fi
+
++AC_ARG_WITH(wrappers,
++ [ --with-wrappers build with libwrappers suuport],
++ with_wrappers="$withval",
++ with_wrappers="yes")
++if test "x$with_wrappers" != "xno"; then
+ AC_QOSIENT_TCPWRAP(V_WRAPDEP, V_INCLS)
+ if test ! -z "$V_WRAPDEP"; then
+ if test -f $V_WRAPDEP; then
+@@ -302,6 +307,7 @@
+ AC_DEFINE(HAVE_TCP_WRAPPER)
+ WRAPLIBS="$V_WRAPDEP"
+ fi
++fi
+
+ umask 002
+
+