summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-09-27 18:14:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-09-27 18:14:53 +0000
commitebe79a778ecfe3660c92100d4aef492ca263a415 (patch)
tree2ad069d70260e1f56ecfb79374d3f3858ba2661f /media-video
parentppc/ppc64 stable wrt #382349 (diff)
downloadgentoo-2-ebe79a778ecfe3660c92100d4aef492ca263a415.tar.gz
gentoo-2-ebe79a778ecfe3660c92100d4aef492ca263a415.tar.bz2
gentoo-2-ebe79a778ecfe3660c92100d4aef492ca263a415.zip
add libaacplus support
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild14
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 14 insertions, 7 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 6958e9732434..c02f1da0cb0a 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.460 2011/09/27 15:34:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.461 2011/09/27 18:14:53 aballier Exp $
+
+ 27 Sep 2011; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add libaacplus support
27 Sep 2011; Jeroen Roovers <jer@gentoo.org> ffmpeg-0.7.5.ebuild:
Stable for HPPA (bug #384095).
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 23c426cd42f5..52845649fcae 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.54 2011/09/21 15:21:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.55 2011/09/27 18:14:53 aballier Exp $
EAPI="4"
@@ -29,10 +29,10 @@ if [ "${PV#9999}" = "${PV}" ] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
fi
IUSE="
- aac alsa amr bindist +bzip2 cdio celt cpudetection debug dirac doc +encode
- faac frei0r gsm +hardcoded-tables ieee1394 jack jpeg2k mp3 network openal
- oss pic qt-faststart rtmp schroedinger sdl speex static-libs test theora
- threads truetype v4l v4l2 vaapi vdpau vorbis vpx X x264 xvid +zlib
+ aac aacplus alsa amr bindist +bzip2 cdio celt cpudetection debug dirac doc
+ +encode faac frei0r gsm +hardcoded-tables ieee1394 jack jpeg2k mp3 network
+ openal oss pic qt-faststart rtmp schroedinger sdl speex static-libs test
+ theora threads truetype v4l v4l2 vaapi vdpau vorbis vpx X x264 xvid +zlib
"
# String for CPU features in the useflag[:configure_option] form
@@ -52,6 +52,7 @@ RDEPEND="
dirac? ( media-video/dirac )
encode? (
aac? ( media-libs/vo-aacenc )
+ aacplus? ( media-libs/libaacplus )
amr? ( media-libs/vo-amrwbenc )
faac? ( media-libs/faac )
mp3? ( >=media-sound/lame-3.98.3 )
@@ -93,7 +94,7 @@ DEPEND="${RDEPEND}
v4l2? ( sys-kernel/linux-headers )
"
# faac is license-incompatible with ffmpeg
-REQUIRED_USE="bindist? ( encode? ( !faac ) )"
+REQUIRED_USE="bindist? ( encode? ( !faac !aacplus ) )"
S=${WORKDIR}/${P/_/-}
@@ -126,6 +127,7 @@ src_configure() {
for i in theora vorbis x264 xvid; do
use ${i} && myconf="${myconf} --enable-lib${i}"
done
+ use aacplus && myconf="${myconf} --enable-libaacplus --enable-nonfree"
use faac && myconf="${myconf} --enable-libfaac --enable-nonfree"
else
myconf="${myconf} --disable-encoders"
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index a9c5be50711a..80da8f959fe8 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -11,6 +11,7 @@
instruction set, present in modern AMD CPUs. (Check for
3dnowext in /proc/cpuinfo to know whether your CPU supports it).
</flag>
+ <flag name="aacplus">AAC+ encoding via <pkg>media-libs/libaacplus</pkg>.</flag>
<flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
<flag name="avx">Adds support for Advanced Vector Extensions instructions (Intel Sandy Bridge, AMD Bulldozer and later chips)</flag>
<flag name="cdio">Enables audio CD grabbing with <pkg>dev-libs/libcdio</pkg>.</flag>