summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-13 09:47:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-13 09:47:30 +0000
commitbf26714f3bdd0ef04ec6b3836837a30c7103dbd0 (patch)
tree2c53781daeed159366a6ea37b9e6bda1db57e6b8 /media-video
parentVersion bump (diff)
downloadgentoo-2-bf26714f3bdd0ef04ec6b3836837a30c7103dbd0.tar.gz
gentoo-2-bf26714f3bdd0ef04ec6b3836837a30c7103dbd0.tar.bz2
gentoo-2-bf26714f3bdd0ef04ec6b3836837a30c7103dbd0.zip
version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-1.0.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index 3e35cbcc04b1..31f979c74a47 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.32 2008/08/05 13:28:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.33 2008/08/13 09:47:30 aballier Exp $
+
+*clive-1.0.0 (13 Aug 2008)
+
+ 13 Aug 2008; Alexis Ballier <aballier@gentoo.org> +clive-1.0.0.ebuild:
+ version bump
*clive-0.5.0 (05 Aug 2008)
diff --git a/media-video/clive/clive-1.0.0.ebuild b/media-video/clive/clive-1.0.0.ebuild
new file mode 100644
index 000000000000..9e188b100bad
--- /dev/null
+++ b/media-video/clive/clive-1.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-1.0.0.ebuild,v 1.1 2008/08/13 09:47:30 aballier Exp $
+
+# We inherit distutils to get the pkg_* functions for byte compiling python
+inherit versionator distutils
+
+DESCRIPTION="Command line tool for extracting videos from Youtube, Google Video, Dailymotion, Guba (free) and Stage6 websites"
+HOMEPAGE="http://home.gna.org/clive/"
+SRC_URI="http://dl.gna.org/clive/$(get_version_component_range 1-2 ${PV}).x/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-libs/newt-0.51
+ >=dev-python/urlgrabber-3.1.0
+ >=dev-python/feedparser-4.1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf $(use_with doc)
+ emake || die "emake failed"
+ if use doc; then
+ emake dox || die "failed to create the documentation"
+ fi
+}
+
+src_install() {
+ emake py_compile=true DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS README CHANGES
+ use doc && dohtml dox/html/*
+}