summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-06-30 21:36:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-06-30 21:36:24 +0000
commit868f08b373a133015c85d7d214d514fe7c979ce0 (patch)
tree03082eaaa98a290b3ef2973e5fd3a38183b2c75f /media-video
parentAdd missing subslot operators and dependencies. (diff)
downloadgentoo-2-868f08b373a133015c85d7d214d514fe7c979ce0.tar.gz
gentoo-2-868f08b373a133015c85d7d214d514fe7c979ce0.tar.bz2
gentoo-2-868f08b373a133015c85d7d214d514fe7c979ce0.zip
Apply team policy for configure and update gtk+ dependency per libgd requirements.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/totem/ChangeLog6
-rw-r--r--media-video/totem/totem-3.8.2.ebuild46
2 files changed, 26 insertions, 26 deletions
diff --git a/media-video/totem/ChangeLog b/media-video/totem/ChangeLog
index 9f156e2a7602..3ca70727f5a7 100644
--- a/media-video/totem/ChangeLog
+++ b/media-video/totem/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/totem
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.361 2013/06/02 20:44:56 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.362 2013/06/30 21:36:24 eva Exp $
+
+ 30 Jun 2013; Gilles Dartiguelongue <eva@gentoo.org> totem-3.8.2.ebuild:
+ Apply team policy for configure and update gtk+ dependency per libgd
+ requirements.
02 Jun 2013; Jonathan Callen <abcd@gentoo.org> totem-3.6.3-r1.ebuild,
totem-3.8.0.ebuild, totem-3.8.2.ebuild:
diff --git a/media-video/totem/totem-3.8.2.ebuild b/media-video/totem/totem-3.8.2.ebuild
index f4920c7a4856..f0b4606e1a78 100644
--- a/media-video/totem/totem-3.8.2.ebuild
+++ b/media-video/totem/totem-3.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-3.8.2.ebuild,v 1.2 2013/06/02 20:44:56 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-3.8.2.ebuild,v 1.3 2013/06/30 21:36:24 eva Exp $
EAPI="5"
GCONF_DEBUG="yes"
@@ -34,7 +34,7 @@ REQUIRED_USE="
RDEPEND="
>=dev-libs/glib-2.33:2
>=x11-libs/gdk-pixbuf-2.23.0:2
- >=x11-libs/gtk+-3.5.2:3[introspection?]
+ >=x11-libs/gtk+-3.7.10:3[introspection?]
>=dev-libs/totem-pl-parser-2.32.4[introspection?]
>=dev-libs/libpeas-1.1.0[gtk]
>=x11-themes/gnome-icon-theme-2.16
@@ -107,26 +107,6 @@ src_prepare() {
src_configure() {
use nsplugin && DOCS="${DOCS} browser-plugin/README.browser-plugin"
- #--with-smclient=auto needed to correctly link to libICE and libSM
- G2CONF="${G2CONF}
- --disable-run-in-source-tree
- --disable-static
- --with-smclient=auto
- --enable-easy-codec-installation
- --enable-vala
- $(use_enable flash vegas-plugin)
- $(use_enable introspection)
- $(use_enable nautilus)
- $(use_enable nsplugin browser-plugins)
- $(use_enable python)
- VALAC=$(type -P true)
- BROWSER_PLUGIN_DIR=/usr/$(get_libdir)/nsbrowser/plugins"
-
- # XXX: always set to true otherwise tests fails due to pylint not
- # respecting EPYTHON (wait for python-r1)
- # pylint is checked unconditionally, but is only used for make check
- G2CONF="${G2CONF} PYLINT=$(type -P true)"
-
# Disabled: sample-python, sample-vala
local plugins="apple-trailers,autoload-subtitles,brasero-disc-recorder"
plugins+=",chapters,im-status,gromit,media-player-keys,ontop"
@@ -138,7 +118,23 @@ src_configure() {
use python && plugins+=",dbusservice,pythonconsole,opensubtitles"
use zeitgeist && plugins+=",zeitgeist-dp"
- G2CONF="${G2CONF} --with-plugins=${plugins}"
-
- gnome2_src_configure
+ #--with-smclient=auto needed to correctly link to libICE and libSM
+ # XXX: always set to true otherwise tests fails due to pylint not
+ # respecting EPYTHON (wait for python-r1)
+ # pylint is checked unconditionally, but is only used for make check
+ gnome2_src_configure \
+ PYLINT=$(type -P true)
+ --disable-run-in-source-tree \
+ --disable-static \
+ --with-smclient=auto \
+ --enable-easy-codec-installation \
+ --enable-vala \
+ $(use_enable flash vegas-plugin) \
+ $(use_enable introspection) \
+ $(use_enable nautilus) \
+ $(use_enable nsplugin browser-plugins) \
+ $(use_enable python) \
+ VALAC=$(type -P true) \
+ BROWSER_PLUGIN_DIR=/usr/$(get_libdir)/nsbrowser/plugins \
+ --with-plugins=${plugins}
}