summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-09-27 21:30:21 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-09-27 21:30:21 +0000
commit5f767370bbb71579c5d71df5eef6bc6c3750d9e4 (patch)
tree1e2e0ad7dbc690f222e4e8b3e5a0002731c9e462 /media-video
parentInstall to correct location this time by using package2.xml instead of packag... (diff)
downloadgentoo-2-5f767370bbb71579c5d71df5eef6bc6c3750d9e4.tar.gz
gentoo-2-5f767370bbb71579c5d71df5eef6bc6c3750d9e4.tar.bz2
gentoo-2-5f767370bbb71579c5d71df5eef6bc6c3750d9e4.zip
Version bump closing bug 185863
(Portage version: 2.1.3.9)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/linux-uvc/ChangeLog8
-rw-r--r--media-video/linux-uvc/files/digest-linux-uvc-0.1.0_pre1263
-rw-r--r--media-video/linux-uvc/linux-uvc-0.1.0_pre126.ebuild48
3 files changed, 58 insertions, 1 deletions
diff --git a/media-video/linux-uvc/ChangeLog b/media-video/linux-uvc/ChangeLog
index 671bd7cbc574..2e9a44e254de 100644
--- a/media-video/linux-uvc/ChangeLog
+++ b/media-video/linux-uvc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/linux-uvc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/linux-uvc/ChangeLog,v 1.8 2007/05/15 13:56:23 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/linux-uvc/ChangeLog,v 1.9 2007/09/27 21:30:21 genstef Exp $
+
+*linux-uvc-0.1.0_pre126 (27 Sep 2007)
+
+ 27 Sep 2007; Stefan Schweizer <genstef@gentoo.org>
+ +linux-uvc-0.1.0_pre126.ebuild:
+ Version bump closing bug 185863
15 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/media-video/linux-uvc/files/digest-linux-uvc-0.1.0_pre126 b/media-video/linux-uvc/files/digest-linux-uvc-0.1.0_pre126
new file mode 100644
index 000000000000..a576ba8188c5
--- /dev/null
+++ b/media-video/linux-uvc/files/digest-linux-uvc-0.1.0_pre126
@@ -0,0 +1,3 @@
+MD5 01f024ef4a8167f3e55ab85558561af9 linux-uvc-0.1.0_pre126.tar.bz2 61079
+RMD160 fc7fd8f551726aab7ae17eeee699e5fad076416c linux-uvc-0.1.0_pre126.tar.bz2 61079
+SHA256 f887c41a9f59d4a4976aecbe74a5a1ea30cb89f871885af67782abb6ec0cde08 linux-uvc-0.1.0_pre126.tar.bz2 61079
diff --git a/media-video/linux-uvc/linux-uvc-0.1.0_pre126.ebuild b/media-video/linux-uvc/linux-uvc-0.1.0_pre126.ebuild
new file mode 100644
index 000000000000..14bae5195ecb
--- /dev/null
+++ b/media-video/linux-uvc/linux-uvc-0.1.0_pre126.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/linux-uvc/linux-uvc-0.1.0_pre126.ebuild,v 1.1 2007/09/27 21:30:21 genstef Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Linux driver and user-space tools for USB Video Class devices."
+HOMEPAGE="http://linux-uvc.berlios.de/
+ http://people.freedesktop.org/~rbultje/"
+SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.bz2"
+#ESVN_REPO_URI="http://svn.berlios.de/svnroot/repos/linux-uvc/linux-uvc/trunk/"
+#ESVN_OPTIONS="-r ${PV/*_pre}"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="isight"
+DEPEND=""
+
+MODULE_NAMES="uvcvideo(usb/media:)"
+BUILD_TARGETS=" "
+CONFIG_CHECK="VIDEO_DEV"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ BUILD_PARAMS="KERNEL_DIR=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use isight && epatch patch/isight-base.patch
+ use isight && epatch patch/isight-against-uvcvideo-r126.diff
+}
+
+src_install() {
+ insinto /lib/firmware
+ use isight && doins firmware/AppleUSBVideoSupport
+
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ ewarn "If something is broken, you should get involved, and report"
+ ewarn "back to the mailing list linux-uvc-devel@lists.berlios.de"
+}