summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-21 00:41:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-21 00:41:22 +0000
commit5ee58848d797da1718d780da7b870bd3ead11624 (patch)
tree97f8f0150e01c057c9fb3a8e40db4d46ae119a62 /media-video
parentversion bump (diff)
downloadgentoo-2-5ee58848d797da1718d780da7b870bd3ead11624.tar.gz
gentoo-2-5ee58848d797da1718d780da7b870bd3ead11624.tar.bz2
gentoo-2-5ee58848d797da1718d780da7b870bd3ead11624.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdauthor/ChangeLog7
-rw-r--r--media-video/dvdauthor/dvdauthor-0.7.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/media-video/dvdauthor/ChangeLog b/media-video/dvdauthor/ChangeLog
index 08a014c4aec7..6c7e9707cc8a 100644
--- a/media-video/dvdauthor/ChangeLog
+++ b/media-video/dvdauthor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/dvdauthor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/ChangeLog,v 1.49 2012/07/29 17:12:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/ChangeLog,v 1.50 2012/11/21 00:41:22 aballier Exp $
+
+*dvdauthor-0.7.1 (21 Nov 2012)
+
+ 21 Nov 2012; Alexis Ballier <aballier@gentoo.org> +dvdauthor-0.7.1.ebuild:
+ version bump
29 Jul 2012; Raúl Porcel <armin76@gentoo.org> dvdauthor-0.7.0.ebuild:
sparc stable wrt #418323
diff --git a/media-video/dvdauthor/dvdauthor-0.7.1.ebuild b/media-video/dvdauthor/dvdauthor-0.7.1.ebuild
new file mode 100644
index 000000000000..e6bde9de5419
--- /dev/null
+++ b/media-video/dvdauthor/dvdauthor-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/dvdauthor-0.7.1.ebuild,v 1.1 2012/11/21 00:41:22 aballier Exp $
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tools for generating DVD files to be played on standalone DVD players"
+HOMEPAGE="http://dvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="graphicsmagick"
+
+RDEPEND=">=dev-libs/fribidi-0.19.2
+ dev-libs/libxml2
+ >=media-libs/freetype-2
+ media-libs/libdvdread
+ media-libs/libpng
+ graphicsmagick? ( media-gfx/graphicsmagick )
+ !graphicsmagick? ( >=media-gfx/imagemagick-5.5.7.14 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ use graphicsmagick && \
+ sed -i -e 's:ExportImagePixels:dIsAbLeAuToMaGiC&:' configure
+}
+
+src_configure() {
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags fribidi)" #417041
+ econf
+}