summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-03-31 15:22:59 +0000
committerSamuli Suominen <drac@gentoo.org>2007-03-31 15:22:59 +0000
commit3283c925e2000f9533e778898fe137eb738d6f58 (patch)
tree2c6b5c2d112f67f67e42ebebeae8fd0761124be9 /media-video
parentMasked kde-misc/krusader beta releases. (diff)
downloadgentoo-2-3283c925e2000f9533e778898fe137eb738d6f58.tar.gz
gentoo-2-3283c925e2000f9533e778898fe137eb738d6f58.tar.bz2
gentoo-2-3283c925e2000f9533e778898fe137eb738d6f58.zip
64bit fix from bug 172875, thanks to Markus Rothe for patch.
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog6
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.ebuild10
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1-int.patch11
3 files changed, 25 insertions, 2 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 7d0a5fa5134d..e003b403118b 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.1 2007/03/31 10:14:12 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.2 2007/03/31 15:22:58 drac Exp $
+
+ 31 Mar 2007; Samuli Suominen <drac@gentoo.org>
+ +files/ffmpegthumbnailer-1.1-int.patch, ffmpegthumbnailer-1.1.ebuild:
+ 64bit fix from bug 172875, thanks to Markus Rothe for patch.
*ffmpegthumbnailer-1.1 (31 Mar 2007)
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.ebuild
index 4bd494112e9a..a5baffd7c292 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.ebuild,v 1.1 2007/03/31 10:14:12 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.ebuild,v 1.2 2007/03/31 15:22:58 drac Exp $
+
+inherit eutils
DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer"
@@ -15,6 +17,12 @@ RDEPEND="media-libs/libpng
media-video/ffmpeg"
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-int.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS ChangeLog README TODO
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1-int.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1-int.patch
new file mode 100644
index 000000000000..21d5b182132e
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1-int.patch
@@ -0,0 +1,11 @@
+--- ffmpegthumbnailer-1.1/src/moviedecoder.h.orig 2007-02-24 14:14:47.000000000 +0000
++++ ffmpegthumbnailer-1.1/src/moviedecoder.h 2007-03-31 12:47:57.677823666 +0000
+@@ -1,8 +1,6 @@
+ #ifndef MOVIEDECODER_H
+ #define MOVIEDECODER_H
+
+-#define EMULATE_INTTYPES
+-
+ #include <string>
+ #include <vector>
+ #include <ffmpeg/avcodec.h>