summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-24 15:47:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-24 15:47:25 +0000
commit131340709f6df3001358d23e13a53470ebd49409 (patch)
tree27f1e853f3825f80a4eba63cb496ad04de987879 /media-video
parentpush a new snapshot (diff)
downloadgentoo-2-131340709f6df3001358d23e13a53470ebd49409.tar.gz
gentoo-2-131340709f6df3001358d23e13a53470ebd49409.tar.bz2
gentoo-2-131340709f6df3001358d23e13a53470ebd49409.zip
push a new snapshot
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/x264-encoder/ChangeLog8
-rw-r--r--media-video/x264-encoder/x264-encoder-0.0.20100423.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/media-video/x264-encoder/ChangeLog b/media-video/x264-encoder/ChangeLog
index aac96c58a5c4..fe84b0db1aba 100644
--- a/media-video/x264-encoder/ChangeLog
+++ b/media-video/x264-encoder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/x264-encoder
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.33 2010/02/24 12:33:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.34 2010/04/24 15:47:25 aballier Exp $
+
+*x264-encoder-0.0.20100423 (24 Apr 2010)
+
+ 24 Apr 2010; Alexis Ballier <aballier@gentoo.org>
+ +x264-encoder-0.0.20100423.ebuild:
+ push a new snapshot
24 Feb 2010; Alexis Ballier <aballier@gentoo.org>
-x264-encoder-0.0.20081006.ebuild, -x264-encoder-0.0.20090502.ebuild,
diff --git a/media-video/x264-encoder/x264-encoder-0.0.20100423.ebuild b/media-video/x264-encoder/x264-encoder-0.0.20100423.ebuild
new file mode 100644
index 000000000000..07c312a2bb44
--- /dev/null
+++ b/media-video/x264-encoder/x264-encoder-0.0.20100423.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/x264-encoder-0.0.20100423.ebuild,v 1.1 2010/04/24 15:47:25 aballier Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free commandline encoder for X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ffmpeg +mp4 +threads"
+
+RDEPEND="mp4? ( >=media-video/gpac-0.4.1_pre20060122 )
+ ~media-libs/x264-${PV}
+ ffmpeg? ( media-video/ffmpeg )"
+DEPEND="${RDEPEND}
+ amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( || ( >=dev-lang/yasm-0.6.2 dev-lang/nasm )
+ !<dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nostrip.patch \
+ "${FILESDIR}"/${PN}-nolib-20100118.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-avs-input \
+ $(use_enable ffmpeg lavf-input) \
+ $(use_enable mp4 mp4-output) \
+ $(use_enable threads pthread) \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}