summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-03-23 23:02:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-03-23 23:02:22 +0000
commit00b50c1861ac08901ccf8bf36f9ca8ac811ac020 (patch)
tree11e49a8e1eaeb717922a01c80bfd1fad6bf5237e /media-video
parentamd64 stable wrt bug #214394 (diff)
downloadgentoo-2-00b50c1861ac08901ccf8bf36f9ca8ac811ac020.tar.gz
gentoo-2-00b50c1861ac08901ccf8bf36f9ca8ac811ac020.tar.bz2
gentoo-2-00b50c1861ac08901ccf8bf36f9ca8ac811ac020.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-0.4.7.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index b20c12956abf..d658775b052f 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.10 2008/03/03 17:12:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.11 2008/03/23 23:02:22 aballier Exp $
+
+*clive-0.4.7 (23 Mar 2008)
+
+ 23 Mar 2008; Alexis Ballier <aballier@gentoo.org> +clive-0.4.7.ebuild:
+ version bump
*clive-0.4.6 (03 Mar 2008)
diff --git a/media-video/clive/clive-0.4.7.ebuild b/media-video/clive/clive-0.4.7.ebuild
new file mode 100644
index 000000000000..35ec6b9851ce
--- /dev/null
+++ b/media-video/clive/clive-0.4.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-0.4.7.ebuild,v 1.1 2008/03/23 23:02:22 aballier Exp $
+
+# We inherit distutils to get the pkg_* functions for byte compiling python
+inherit versionator distutils
+
+DESCRIPTION="Command line tool for extracting videos from Youtube, Google Video, Dailymotion, Guba (free) and Stage6 websites"
+HOMEPAGE="http://home.gna.org/clive/"
+SRC_URI="http://dl.gna.org/clive/$(get_version_component_range 1-2 ${PV})/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf $(use_with doc)
+ emake || die "emake failed"
+ if use doc; then
+ emake dox || die "failed to create the documentation"
+ fi
+}
+
+src_test() {
+ ./run-tests.py || die "tests failed"
+}
+
+src_install() {
+ emake py_compile=true DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README
+ use doc && dohtml dox/html/*
+}