summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-08-18 21:49:35 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-08-18 21:49:35 +0000
commitd43cb061aa7fa9c2d7ccb92f3fe981aeca882fde (patch)
treeeebac3fd86ef0b5e88e51254860da3ef84213a54 /media-video/ttcut
parentInitial ebuild as provided by Andrius Štikonas on bug 180818. Thanks, Andriu... (diff)
downloadgentoo-2-d43cb061aa7fa9c2d7ccb92f3fe981aeca882fde.tar.gz
gentoo-2-d43cb061aa7fa9c2d7ccb92f3fe981aeca882fde.tar.bz2
gentoo-2-d43cb061aa7fa9c2d7ccb92f3fe981aeca882fde.zip
Now use eqtmake4 from qt4.eclass
(Portage version: 2.1.3.6)
Diffstat (limited to 'media-video/ttcut')
-rw-r--r--media-video/ttcut/ChangeLog8
-rw-r--r--media-video/ttcut/files/digest-ttcut-0.19.5-r13
-rw-r--r--media-video/ttcut/ttcut-0.19.5-r1.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/media-video/ttcut/ChangeLog b/media-video/ttcut/ChangeLog
index 7a22401a5a78..be0e775cc833 100644
--- a/media-video/ttcut/ChangeLog
+++ b/media-video/ttcut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ttcut
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.7 2007/06/21 19:55:00 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.8 2007/08/18 21:49:35 zzam Exp $
+
+*ttcut-0.19.5-r1 (18 Aug 2007)
+
+ 18 Aug 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +ttcut-0.19.5-r1.ebuild:
+ Now use eqtmake4 from qt4.eclass
*ttcut-0.19.5 (21 Jun 2007)
diff --git a/media-video/ttcut/files/digest-ttcut-0.19.5-r1 b/media-video/ttcut/files/digest-ttcut-0.19.5-r1
new file mode 100644
index 000000000000..2c628d2460bb
--- /dev/null
+++ b/media-video/ttcut/files/digest-ttcut-0.19.5-r1
@@ -0,0 +1,3 @@
+MD5 b73d9927e7e41b33f056dc4d8038fd10 ttcut-0.19.5.tar.gz 378372
+RMD160 bb91b202608d3198619c9fa5c52176c1450f5971 ttcut-0.19.5.tar.gz 378372
+SHA256 9566895816cd4185b9fc9d0887de991b46aa5ea5306da8cafc4db2a48097140a ttcut-0.19.5.tar.gz 378372
diff --git a/media-video/ttcut/ttcut-0.19.5-r1.ebuild b/media-video/ttcut/ttcut-0.19.5-r1.ebuild
new file mode 100644
index 000000000000..38a4383d6715
--- /dev/null
+++ b/media-video/ttcut/ttcut-0.19.5-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ttcut-0.19.5-r1.ebuild,v 1.1 2007/08/18 21:49:35 zzam Exp $
+
+inherit eutils qt4
+
+DESCRIPTION="Tool for removing advertisements from recorded MPEG files"
+HOMEPAGE="http://ttcut.tritime.org/"
+SRC_URI="mirror://berlios/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="$(qt4_min_version 4.1)
+ >=media-libs/libmpeg2-0.4.0
+ virtual/opengl"
+
+RDEPEND="${DEPEND}
+ media-video/mplayer
+ media-video/transcode"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use media-video/transcode mjpeg ; then
+ eerror "In order to have encoding mode working with ttcut"
+ eerror "you need to recompile transcode with mjpeg USE flag enabled."
+ die "Recompile transcode with mjpeg USE flag enabled"
+ fi
+}
+
+src_compile() {
+ eqmake4 ttcut.pro -o Makefile.ttcut
+ emake -f Makefile.ttcut || die "emake failed"
+}
+
+src_install() {
+ dobin ttcut || die "Couldn't install ttcut"
+ make_desktop_entry ttcut TTCut "" "AudioVideo;Video;AudioVideoEditing" || \
+ die "Couldn't make ttcut desktop entry"
+
+ dodoc AUTHORS BUGS CHANGELOG \
+ README.DE README.EN TODO || die "Couldn't install documentation"
+}