summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-06-29 16:51:55 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-06-29 16:51:55 +0000
commit379bc9156538985ec17579a34372ee416bc3c51f (patch)
treea30fb861cbaebde2ff7af9f5ad3be9631a7f4339 /media-video/totem
parentStable on hppa (diff)
downloadgentoo-2-379bc9156538985ec17579a34372ee416bc3c51f.tar.gz
gentoo-2-379bc9156538985ec17579a34372ee416bc3c51f.tar.bz2
gentoo-2-379bc9156538985ec17579a34372ee416bc3c51f.zip
Fix for autoconf 2.60 from bug# 138210
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'media-video/totem')
-rw-r--r--media-video/totem/ChangeLog6
-rw-r--r--media-video/totem/files/totem-1.4.0-autoconf.patch57
-rw-r--r--media-video/totem/totem-1.4.0.ebuild5
3 files changed, 66 insertions, 2 deletions
diff --git a/media-video/totem/ChangeLog b/media-video/totem/ChangeLog
index 741309a1d3e2..8e3cb16608db 100644
--- a/media-video/totem/ChangeLog
+++ b/media-video/totem/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/totem
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.111 2006/05/18 05:39:45 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.112 2006/06/29 16:51:55 dang Exp $
+
+ 29 Jun 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/totem-1.4.0-autoconf.patch, totem-1.4.0.ebuild:
+ Fix for autoconf 2.60 from bug# 138210
18 May 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+files/totem-1.4.0-linguas.patch, totem-1.4.0.ebuild:
diff --git a/media-video/totem/files/totem-1.4.0-autoconf.patch b/media-video/totem/files/totem-1.4.0-autoconf.patch
new file mode 100644
index 000000000000..e4c462013c5f
--- /dev/null
+++ b/media-video/totem/files/totem-1.4.0-autoconf.patch
@@ -0,0 +1,57 @@
+Index: totem-1.4.0/src/totem.c
+===================================================================
+--- totem-1.4.0.orig/src/totem.c
++++ totem-1.4.0/src/totem.c
+@@ -1959,7 +1959,7 @@ on_about1_activate (GtkButton *button, T
+
+ totem->about = g_object_new (GTK_TYPE_ABOUT_DIALOG,
+ "name", _("Totem"),
+- "version", VERSION,
++ "version", PACKAGE_VERSION,
+ "copyright", _("Copyright \xc2\xa9 2002-2005 Bastien Nocera"),
+ "comments", description,
+ "authors", authors,
+@@ -3512,7 +3512,7 @@ main (int argc, char **argv)
+ #ifdef HAVE_GTK_ONLY
+ gtk_init (&argc, &argv);
+ #else
+- gnome_program_init ("totem", VERSION,
++ gnome_program_init ("totem", PACKAGE_VERSION,
+ LIBGNOMEUI_MODULE,
+ argc, argv,
+ GNOME_PARAM_APP_DATADIR, DATADIR,
+Index: totem-1.4.0/src/totem-mozilla-viewer.c
+===================================================================
+--- totem-1.4.0.orig/src/totem-mozilla-viewer.c
++++ totem-1.4.0/src/totem-mozilla-viewer.c
+@@ -272,7 +272,7 @@ on_about1_activate (GtkButton *button, T
+
+ emb->about = g_object_new (GTK_TYPE_ABOUT_DIALOG,
+ "name", _("Totem Mozilla Plugin"),
+- "version", VERSION,
++ "version", PACKAGE_VERSION,
+ "copyright", _("Copyright \xc2\xa9 2002-2005 Bastien Nocera"),
+ "comments", description,
+ "authors", authors,
+Index: totem-1.4.0/src/vanity.c
+===================================================================
+--- totem-1.4.0.orig/src/vanity.c
++++ totem-1.4.0/src/vanity.c
+@@ -257,7 +257,7 @@ on_about1_activate (GtkButton *button, V
+
+ vanity->about = g_object_new (GTK_TYPE_ABOUT_DIALOG,
+ "name", _("Vanity"),
+- "version", VERSION,
++ "version", PACKAGE_VERSION,
+ "copyright", _("Copyright \xc2\xa9 2002-2005 Bastien Nocera"),
+ "comments", description,
+ "authors", authors,
+@@ -654,7 +654,7 @@ main (int argc, char **argv)
+
+ gtk_init (&argc, &argv);
+ #ifndef HAVE_GTK_ONLY
+- gnome_program_init ("vanity", VERSION,
++ gnome_program_init ("vanity", PACKAGE_VERSION,
+ LIBGNOMEUI_MODULE,
+ argc, argv,
+ GNOME_PARAM_APP_DATADIR, DATADIR,
diff --git a/media-video/totem/totem-1.4.0.ebuild b/media-video/totem/totem-1.4.0.ebuild
index 80a235968b31..338c3fab8d63 100644
--- a/media-video/totem/totem-1.4.0.ebuild
+++ b/media-video/totem/totem-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-1.4.0.ebuild,v 1.8 2006/05/18 05:39:45 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-1.4.0.ebuild,v 1.9 2006/06/29 16:51:55 dang Exp $
inherit autotools eutils multilib gnome2
@@ -113,6 +113,9 @@ src_unpack() {
# <alexis.ballier@gmail.com>
epatch ${FILESDIR}/${PN}-1.4.0-linguas.patch
+ # Fix failure with autoconf 2.60, bug #138210
+ epatch ${FILESDIR}/${P}-autoconf.patch
+
eautoreconf
}