summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-26 08:26:56 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-26 08:26:56 +0000
commit1c00b64e88cde6b95b54e54e675e7353d3b75777 (patch)
tree96830b679a597833369a338440c874478214fc4f /media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild
parentremove old (diff)
downloadgentoo-2-1c00b64e88cde6b95b54e54e675e7353d3b75777.tar.gz
gentoo-2-1c00b64e88cde6b95b54e54e675e7353d3b75777.tar.bz2
gentoo-2-1c00b64e88cde6b95b54e54e675e7353d3b75777.zip
Revision bump. Fix .desktop file, bumps EAPI, fixes build with python 3 as active version, respect linguas and correct dependencies by Michael (kensington) <gentoo@scribeofthenile.com>. Fixes bug #372667, bug #367943.
(Portage version: 2.2.0_alpha101/cvs/Linux i686)
Diffstat (limited to 'media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild')
-rw-r--r--media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild b/media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild
new file mode 100644
index 000000000000..9607d817ca04
--- /dev/null
+++ b/media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild,v 1.1 2012/04/26 08:26:56 johu Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+inherit autotools base eutils python
+
+DESCRIPTION="Qt4 interface for RecordMyDesktop"
+HOMEPAGE="http://recordmydesktop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/recordmydesktop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Test is buggy : bug #186752
+# Tries to run intl-toolupdate without it being substituted from
+# configure, make test tries run make check in flumotion/test what
+# makes me think that this file has been copied from flumotion without
+# much care...
+RESTRICT="test"
+
+RDEPEND=">=media-video/recordmydesktop-0.3.8
+ x11-apps/xwininfo"
+DEPEND="${RDEPEND}
+ >=dev-python/PyQt4-4.1[X]"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+PATCHES=(
+ "${FILESDIR}/${P}-check-for-jack.patch"
+ "${FILESDIR}/${P}-desktopfile.patch"
+)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # these deps are required by PyQt4, not this package
+ sed -e '/^PKG_CHECK_MODULES/d' -i configure.ac || die "sed failed"
+ eautoreconf
+
+ python_convert_shebangs 2 src/qt-recordMyDesktop.in
+
+ sed -e 's/@ALL_LINGUAS@//' -i po/Makefile.in.in \
+ || die "respect linguas sed failed"
+ strip-linguas -i po
+ echo ${LINGUAS} | tr ' ' '\n' > po/LINGUAS
+}