summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2003-02-02 03:51:22 +0000
committerJon Nall <nall@gentoo.org>2003-02-02 03:51:22 +0000
commit1a5c0976a7bdb553131c9d9ddcd37442de9e524e (patch)
treeafdfa7d99d91e281db5e4d951d2feb02ecc6173c /media-video/ogle
parentfixed SRC_URI (diff)
downloadgentoo-2-1a5c0976a7bdb553131c9d9ddcd37442de9e524e.tar.gz
gentoo-2-1a5c0976a7bdb553131c9d9ddcd37442de9e524e.tar.bz2
gentoo-2-1a5c0976a7bdb553131c9d9ddcd37442de9e524e.zip
fixed for PPCs that aren't G4s
Diffstat (limited to 'media-video/ogle')
-rw-r--r--media-video/ogle/ChangeLog11
-rw-r--r--media-video/ogle/ogle-0.8.5.ebuild16
2 files changed, 23 insertions, 4 deletions
diff --git a/media-video/ogle/ChangeLog b/media-video/ogle/ChangeLog
index b7549e4ddbfa..5a2e686103c0 100644
--- a/media-video/ogle/ChangeLog
+++ b/media-video/ogle/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for media-video/ogle
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ChangeLog,v 1.9 2002/12/31 15:40:57 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ChangeLog,v 1.10 2003/02/02 03:51:22 nall Exp $
- 31 Dec 2002; Olivier Reisch <doctomoe@gentoo.org> ogle-0.8.5.ebuild :
- Added ppc keyword
*ogle-0.8.5 (21 Sep 2002)
+ 01 Feb 2003; Jon Nall <nall@gentoo.org> ogle-0.8.5.ebuild :
+ don't compile in alitvec support for those who don't want it
+ (!G4s). Fixes gentoo bug #14939
+
+ 31 Dec 2002; Olivier Reisch <doctomoe@gentoo.org> ogle-0.8.5.ebuild :
+ Added ppc keyword
+
21 Sep 2002; Arcady Genkin <agenkin@gentoo.org> ogle-0.8.5.ebuild :
Version bump. Added dependency on media-sound/mad.
diff --git a/media-video/ogle/ogle-0.8.5.ebuild b/media-video/ogle/ogle-0.8.5.ebuild
index d03052505cfa..5643fac1b4b2 100644
--- a/media-video/ogle/ogle-0.8.5.ebuild
+++ b/media-video/ogle/ogle-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.8.5.ebuild,v 1.5 2002/12/31 15:40:57 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.8.5.ebuild,v 1.6 2003/02/02 03:51:22 nall Exp $
IUSE="oss mmx alsa"
@@ -46,6 +46,20 @@ src_compile() {
&& myconf="${myconf} --enable-alsa" \
|| myconf="${myconf} --disable-alsa"
+ if [ "${ARCH}" = "ppc" ]
+ then
+ # if this user doesn't want altivec, don't compile it in
+ # fixes #14939
+ if [ `echo ${CFLAGS} | grep -e "-maltivec" | wc -l` = "0" ]
+ then
+ einfo "Disabling alitvec support"
+ myconf="${myconf} --disable-altivec"
+ else
+ einfo "Enabling altivec support"
+ myconf="${myconf} --enable-altivec"
+ fi
+ fi
+
elibtoolize
# configure needs access to the updated CFLAGS