summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Dawson <pkdawson@gentoo.org>2004-09-29 22:29:36 +0000
committerPatrick Dawson <pkdawson@gentoo.org>2004-09-29 22:29:36 +0000
commit09f4f541e8c7266bb8930dfa9b1755c33fa68755 (patch)
tree085136a27324e661ea027f0e863e251c9d8754c4 /media-video/mpgtx
parentgcc-3.4 fix, take 2 (Manifest recommit) (diff)
downloadgentoo-2-09f4f541e8c7266bb8930dfa9b1755c33fa68755.tar.gz
gentoo-2-09f4f541e8c7266bb8930dfa9b1755c33fa68755.tar.bz2
gentoo-2-09f4f541e8c7266bb8930dfa9b1755c33fa68755.zip
gcc-3.4 fix, take 3, because I'm an idiot
Diffstat (limited to 'media-video/mpgtx')
-rw-r--r--media-video/mpgtx/mpgtx-1.3.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-video/mpgtx/mpgtx-1.3.ebuild b/media-video/mpgtx/mpgtx-1.3.ebuild
index ed42a6a13a1c..4170598b2bcd 100644
--- a/media-video/mpgtx/mpgtx-1.3.ebuild
+++ b/media-video/mpgtx/mpgtx-1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/mpgtx-1.3.ebuild,v 1.8 2004/09/29 22:24:02 pkdawson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpgtx/mpgtx-1.3.ebuild,v 1.9 2004/09/29 22:29:36 pkdawson Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="mpgtx a command line MPEG audio/video/system file toolbox"
SRC_URI="mirror://sourceforge/mpgtx/${P}.tgz"
@@ -22,7 +22,9 @@ src_unpack() {
src_compile() {
./configure --parachute --prefix=/usr
- sed -i "s:-O3:-O3 -fno-unit-at-a-time:" Makefile
+ if [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]; then
+ sed -i "s:-O3:-O3 -fno-unit-at-a-time:" Makefile
+ fi
emake || die "emake failed"
}