summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-01-11 20:28:06 +0000
committerChris White <chriswhite@gentoo.org>2005-01-11 20:28:06 +0000
commitbad0eb902aa69006344a4b4cc2c88bc2b830ca10 (patch)
tree0b0e540efeacd190f23234240bffcaa09db8c725 /media-video/lve/lve-040322.ebuild
parentsparc (Manifest recommit) (diff)
downloadgentoo-2-bad0eb902aa69006344a4b4cc2c88bc2b830ca10.tar.gz
gentoo-2-bad0eb902aa69006344a4b4cc2c88bc2b830ca10.tar.bz2
gentoo-2-bad0eb902aa69006344a4b4cc2c88bc2b830ca10.zip
Fixed lots of broken things as far as CFLAGS and configuration.
Diffstat (limited to 'media-video/lve/lve-040322.ebuild')
-rw-r--r--media-video/lve/lve-040322.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/media-video/lve/lve-040322.ebuild b/media-video/lve/lve-040322.ebuild
index 792d940f8f93..8ab0aa902665 100644
--- a/media-video/lve/lve-040322.ebuild
+++ b/media-video/lve/lve-040322.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lve/lve-040322.ebuild,v 1.8 2004/09/05 18:06:43 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/lve/lve-040322.ebuild,v 1.9 2005/01/11 20:28:06 chriswhite Exp $
inherit eutils gcc
@@ -49,7 +49,17 @@ src_unpack() {
src_compile() {
cd ${WORKDIR}/lve
- make || die
+ make config
+
+ cd src
+ make global_config
+ cd ..
+
+ sed -e "s:CFLAGS.*:CFLAGS = ${CFLAGS}:" \
+ -i src/global_config \
+ || die "Could not patch in CFLAGS"
+
+ make CLFAGS="${CFLAGS}" || die
}
src_install() {