summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2007-06-04 14:21:38 +0000
committerLuca Barbato <lu_zero@gentoo.org>2007-06-04 14:21:38 +0000
commit9be17f5d30adff8cf393087de905dcf9140c636f (patch)
treee961b5f7b3bfeedc6a5b61740ae724af4a2b4a33 /media-video/lives/lives-0.9.8.5.ebuild
parentInstall config file with 600 perms. Bug #180837 by Ortwin Glueck <odi at odi.... (diff)
downloadgentoo-2-9be17f5d30adff8cf393087de905dcf9140c636f.tar.gz
gentoo-2-9be17f5d30adff8cf393087de905dcf9140c636f.tar.bz2
gentoo-2-9be17f5d30adff8cf393087de905dcf9140c636f.zip
New version
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-video/lives/lives-0.9.8.5.ebuild')
-rw-r--r--media-video/lives/lives-0.9.8.5.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-video/lives/lives-0.9.8.5.ebuild b/media-video/lives/lives-0.9.8.5.ebuild
new file mode 100644
index 000000000000..7d71c0b4bf7c
--- /dev/null
+++ b/media-video/lives/lives-0.9.8.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/lives/lives-0.9.8.5.ebuild,v 1.1 2007/06/04 14:21:38 lu_zero Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Linux Video Editing System"
+
+HOMEPAGE="http://lives.sf.net"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE="matroska ogg theora libvisual sox nls" #sdl jack dv"
+
+DEPEND=">=media-video/mplayer-0.90-r2
+ >=media-gfx/imagemagick-5.5.6
+ >=dev-lang/perl-5.8.0-r12
+ >=x11-libs/gtk+-2.2.1
+ media-libs/libsdl
+ >=media-video/ffmpeg-0.4.8
+ >=media-libs/jpeg-6b-r3
+ >=media-sound/sox-12.17.3-r3
+ virtual/cdrtools
+ theora? ( media-libs/libtheora )
+ >=dev-lang/python-2.3.4
+ matroska? ( media-video/mkvtoolnix
+ media-libs/libmatroska )
+ ogg? ( media-sound/ogmtools )
+ >=media-video/mjpegtools-1.6.2
+ libvisual? ( =media-libs/libvisual-0.2* )
+ media-sound/jack-audio-connection-kit
+ sox? ( media-sound/sox )
+ sys-libs/libavc1394"
+
+src_unpack() {
+ unpack ${A}
+ # hardcoding -03 is wrong!
+ sed -i -e "s:-O3::g" \
+ ${S}/{,src,lives-plugins,lives-plugins/plugins/playback/video,lives-plugins/weed-plugins}/Makefile*
+ cd ${S}
+ epatch "${FILESDIR}/${P}-install-paths.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable libvisual) \
+ $(use_enable nls) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS CHANGELOG FEATURES GETTING.STARTED
+}