summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-28 18:11:30 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-28 18:11:30 +0000
commit7901b69b6db87f5a78ebd435aa0d1588b096cc79 (patch)
tree4d33b945f3e34c55c1426fe97d6c044b4f282849 /media-video/istanbul
parent2.1.1_pre4 release. This fixes bugs #37455, #141843, and #141865. (diff)
downloadgentoo-2-7901b69b6db87f5a78ebd435aa0d1588b096cc79.tar.gz
gentoo-2-7901b69b6db87f5a78ebd435aa0d1588b096cc79.tar.bz2
gentoo-2-7901b69b6db87f5a78ebd435aa0d1588b096cc79.zip
version bump
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'media-video/istanbul')
-rw-r--r--media-video/istanbul/ChangeLog8
-rw-r--r--media-video/istanbul/files/digest-istanbul-0.2.13
-rw-r--r--media-video/istanbul/istanbul-0.2.1.ebuild63
3 files changed, 73 insertions, 1 deletions
diff --git a/media-video/istanbul/ChangeLog b/media-video/istanbul/ChangeLog
index a3f2a4f901ce..62588745065e 100644
--- a/media-video/istanbul/ChangeLog
+++ b/media-video/istanbul/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/istanbul
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/ChangeLog,v 1.7 2006/07/25 14:56:19 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/ChangeLog,v 1.8 2006/07/28 18:11:30 zaheerm Exp $
+
+*istanbul-0.2.1 (28 Jul 2006)
+
+ 28 Jul 2006; Zaheer Abbas Merali <zaheerm@gentoo.org>
+ +istanbul-0.2.1.ebuild:
+ version bump
25 Jul 2006; Zaheer Abbas Merali <zaheerm@gentoo.org>
istanbul-0.2.0-r1.ebuild:
diff --git a/media-video/istanbul/files/digest-istanbul-0.2.1 b/media-video/istanbul/files/digest-istanbul-0.2.1
new file mode 100644
index 000000000000..306ad3e08dbe
--- /dev/null
+++ b/media-video/istanbul/files/digest-istanbul-0.2.1
@@ -0,0 +1,3 @@
+MD5 a28cad50f8e29bdce6f8a61af7932539 istanbul-0.2.1.tar.bz2 326122
+RMD160 36924ce5098cf1e0bf8168118a307138c68670f4 istanbul-0.2.1.tar.bz2 326122
+SHA256 50b70f859a835cada34e71576d0ff82dbe2cb7479275377e37812c47938e77fb istanbul-0.2.1.tar.bz2 326122
diff --git a/media-video/istanbul/istanbul-0.2.1.ebuild b/media-video/istanbul/istanbul-0.2.1.ebuild
new file mode 100644
index 000000000000..8597d0bec32f
--- /dev/null
+++ b/media-video/istanbul/istanbul-0.2.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.1.ebuild,v 1.1 2006/07/28 18:11:30 zaheerm Exp $
+
+inherit eutils gnome2 python autotools
+
+KEYWORDS="~x86 ~amd64"
+
+HOMEPAGE="http://live.gnome.org/Istanbul"
+LICENSE="GPL-2"
+SLOT=0
+DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.8
+ dev-lang/python
+ >=dev-python/pygtk-2.6
+ >=dev-python/gnome-python-extras-2.11.3
+ gnome-base/gconf
+ >=dev-python/gst-python-0.10.0
+ =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-theora-0.10*
+ >=media-libs/libtheora-1.0_alpha6
+ =media-plugins/gst-plugins-gconf-0.10*"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0"
+
+SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+ echo "py_compile = /bin/true" > common/python.mk
+
+ intltoolize --force --copy || die
+ AT_M4DIR="common" eautoreconf
+}
+
+src_compile() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ addpredict /root/.gnome2
+ econf
+ emake
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/istanbul
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}