summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-06-07 16:50:11 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-06-07 16:50:11 +0000
commit182e639855f22b4714621cca634ad40272f9ca45 (patch)
tree434beffeced361001afd9c8682a210a8a84f60e7 /media-video/griffith
parentRemove old ebuilds. (diff)
downloadgentoo-2-182e639855f22b4714621cca634ad40272f9ca45.tar.gz
gentoo-2-182e639855f22b4714621cca634ad40272f9ca45.tar.bz2
gentoo-2-182e639855f22b4714621cca634ad40272f9ca45.zip
Finally fixed bug #202484
(Portage version: 2.1.5.4)
Diffstat (limited to 'media-video/griffith')
-rw-r--r--media-video/griffith/ChangeLog9
-rw-r--r--media-video/griffith/files/0.9.6-moving_share_dir.patch11
-rw-r--r--media-video/griffith/griffith-0.9.6-r1.ebuild (renamed from media-video/griffith/griffith-0.9.6.ebuild)18
3 files changed, 31 insertions, 7 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 0ec02cdf341e..fcb5ff7aac1b 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.23 2008/06/07 12:54:13 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.24 2008/06/07 16:50:11 dev-zero Exp $
+
+*griffith-0.9.6-r1 (07 Jun 2008)
+
+ 07 Jun 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/0.9.6-moving_share_dir.patch, -griffith-0.9.6.ebuild,
+ +griffith-0.9.6-r1.ebuild:
+ Finally fixed bug #202484
*griffith-0.9.6 (07 Jun 2008)
diff --git a/media-video/griffith/files/0.9.6-moving_share_dir.patch b/media-video/griffith/files/0.9.6-moving_share_dir.patch
new file mode 100644
index 000000000000..40ce939fb7e0
--- /dev/null
+++ b/media-video/griffith/files/0.9.6-moving_share_dir.patch
@@ -0,0 +1,11 @@
+--- lib/initialize.py.orig 2008-06-07 18:45:17.000000000 +0200
++++ lib/initialize.py 2008-06-07 18:46:13.000000000 +0200
+@@ -78,7 +78,7 @@
+
+ elif os.name == 'posix':
+ locations['home'] = os.path.join(os.path.expanduser('~'), '.griffith').decode(defaultEnc)
+- locations['share'] = os.path.abspath(os.path.join(locations['lib'], '..'))
++ locations['share'] = os.path.abspath(os.path.join(locations['lib'], '../../share/griffith'))
+ locations['glade'] = os.path.join(locations['share'], 'glade')
+ locations['i18n'] = os.path.abspath(os.path.join(locations['share'], '..', 'locale'))
+ if not os.path.isdir(locations['i18n']):
diff --git a/media-video/griffith/griffith-0.9.6.ebuild b/media-video/griffith/griffith-0.9.6-r1.ebuild
index 7baf90a98980..38d3e2f30786 100644
--- a/media-video/griffith/griffith-0.9.6.ebuild
+++ b/media-video/griffith/griffith-0.9.6-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.6.ebuild,v 1.2 2008/06/07 12:55:34 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.6-r1.ebuild,v 1.1 2008/06/07 16:50:11 dev-zero Exp $
EAPI="1"
-inherit python
+inherit eutils python multilib
ARTWORK_PV="0.9.4"
@@ -12,7 +12,6 @@ DESCRIPTION="Movie collection manager"
HOMEPAGE="http://griffith.berlios.de/"
SRC_URI="mirror://berlios/griffith/${P/_/-}.tar.gz
mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
-
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -41,6 +40,8 @@ src_unpack() {
sed -i \
-e 's/ISO-8859-1/UTF-8/' \
lib/gconsole.py || die "sed failed"
+
+ epatch "${FILESDIR}/${PV}-moving_share_dir.patch"
}
src_compile() {
@@ -51,7 +52,10 @@ src_compile() {
src_install() {
use doc || sed -i -e '/docs/d' Makefile
- emake DESTDIR="${D}" install || die "emake install failed"
+ python_version
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README TODO NEWS TRANSLATORS
cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
@@ -59,9 +63,11 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize /usr/share/${PN}/lib
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/${PN}
}
pkg_postrm() {
- python_mod_cleanup /usr/share/${PN}/lib
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
}