summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2010-07-18 06:06:50 +0000
committerDaniel Black <dragonheart@gentoo.org>2010-07-18 06:06:50 +0000
commit0f582ce516dbee8b07be49fb3ceb40a6d1eaeee4 (patch)
tree8b99052ce748eb06875f07037d32b4027c87b839 /media-video/dvdstyler
parentmask app-admin/kedpm for removal (diff)
downloadgentoo-2-0f582ce516dbee8b07be49fb3ceb40a6d1eaeee4.tar.gz
gentoo-2-0f582ce516dbee8b07be49fb3ceb40a6d1eaeee4.tar.bz2
gentoo-2-0f582ce516dbee8b07be49fb3ceb40a6d1eaeee4.zip
version bump as per bug #327289.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/dvdstyler')
-rw-r--r--media-video/dvdstyler/ChangeLog8
-rw-r--r--media-video/dvdstyler/dvdstyler-1.8.1.ebuild54
-rw-r--r--media-video/dvdstyler/files/dvdstyler-1.8.1-cast.patch11
3 files changed, 72 insertions, 1 deletions
diff --git a/media-video/dvdstyler/ChangeLog b/media-video/dvdstyler/ChangeLog
index a641b6df5c37..fed22d8fc1e3 100644
--- a/media-video/dvdstyler/ChangeLog
+++ b/media-video/dvdstyler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/dvdstyler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.41 2010/04/28 19:00:21 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.42 2010/07/18 06:06:50 dragonheart Exp $
+
+*dvdstyler-1.8.1 (18 Jul 2010)
+
+ 18 Jul 2010; Daniel Black <dragonheart@gentoo.org>
+ +dvdstyler-1.8.1.ebuild, +files/dvdstyler-1.8.1-cast.patch:
+ version bump as per bug #327289.
*dvdstyler-1.8.1_beta1 (28 Apr 2010)
diff --git a/media-video/dvdstyler/dvdstyler-1.8.1.ebuild b/media-video/dvdstyler/dvdstyler-1.8.1.ebuild
new file mode 100644
index 000000000000..8926953dc138
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-1.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.8.1.ebuild,v 1.1 2010/07/18 06:06:50 dragonheart Exp $
+
+EAPI=2
+inherit wxwidgets
+
+MY_P=${PN/dvds/DVDS}-${PV/_beta/b}
+
+DESCRIPTION="DVDStyler is a cross-platform DVD authoring System"
+HOMEPAGE="http://www.dvdstyler.de"
+SRC_URI="mirror://sourceforge/dvdstyler/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug gnome"
+
+COMMON_DEPEND=">=media-video/ffmpeg-0.5[encode]
+ >=media-video/xine-ui-0.99.1
+ x11-libs/wxGTK:2.8[X]
+ || ( >=media-libs/wxsvg-1.0.2 >=media-libs/wxsvg-1[ffmpeg] )
+ >=media-libs/libexif-0.6.16
+ gnome? ( >=gnome-base/libgnomeui-2 )
+ virtual/cdrtools
+ >=media-video/dvdauthor-0.6.14
+ >=app-cdr/dvd+rw-tools-7.1"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ app-text/xmlto
+ >=sys-devel/gettext-0.17
+ app-arch/zip"
+PDEPEND=">=app-cdr/dvdisaster-0.71.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/dvdstyler-1.8.1-cast.patch
+}
+
+src_configure() {
+ export WX_GTK_VER="2.8"
+ need-wxwidgets gtk2
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ --with-wx-config="${WX_CONFIG}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/media-video/dvdstyler/files/dvdstyler-1.8.1-cast.patch b/media-video/dvdstyler/files/dvdstyler-1.8.1-cast.patch
new file mode 100644
index 000000000000..fb4bf90a6e34
--- /dev/null
+++ b/media-video/dvdstyler/files/dvdstyler-1.8.1-cast.patch
@@ -0,0 +1,11 @@
+--- /tmp/imagjpg.cpp 2010-07-18 15:46:11.000000000 +1000
++++ ./wxVillaLib/imagjpg.cpp 2010-07-18 15:46:29.000000000 +1000
+@@ -226,7 +226,7 @@
+
+ bool wxJPGHandler::LoadFile( wxImage *image, wxInputStream& stream, bool verbose, int WXUNUSED(index) )
+ {
+- wxCHECK_MSG( image, false, "NULL image pointer" );
++ wxCHECK_MSG( image, false, wxT("NULL image pointer") );
+
+ struct jpeg_decompress_struct cinfo;
+ wx_error_mgr jerr;