summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-10-14 07:16:50 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-10-14 07:16:50 +0000
commit01277e00b722c2e5d7fc0e7fe19879ab439718e9 (patch)
treef006b2bb48bceeb1a9bdaf972b33a27b915d2573 /media-video/dvdstyler
parentVersion bump. Remove old. Per bug #288793. Moved from overlay. Thx to reavertm. (diff)
downloadgentoo-2-01277e00b722c2e5d7fc0e7fe19879ab439718e9.tar.gz
gentoo-2-01277e00b722c2e5d7fc0e7fe19879ab439718e9.tar.bz2
gentoo-2-01277e00b722c2e5d7fc0e7fe19879ab439718e9.zip
add missing xmlto dependency as was noticed on irc #gentoo (by I forget who). Added version bump
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'media-video/dvdstyler')
-rw-r--r--media-video/dvdstyler/ChangeLog10
-rw-r--r--media-video/dvdstyler/dvdstyler-1.7.4.ebuild56
-rw-r--r--media-video/dvdstyler/dvdstyler-1.7.4_rc1.ebuild3
-rw-r--r--media-video/dvdstyler/files/dvdstyler-1.7.4-autoconf.patch77
4 files changed, 144 insertions, 2 deletions
diff --git a/media-video/dvdstyler/ChangeLog b/media-video/dvdstyler/ChangeLog
index 3338213d038f..bec46178c2a4 100644
--- a/media-video/dvdstyler/ChangeLog
+++ b/media-video/dvdstyler/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/dvdstyler
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.38 2009/09/16 11:14:51 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.39 2009/10/14 07:16:49 dragonheart Exp $
+
+*dvdstyler-1.7.4 (14 Oct 2009)
+
+ 14 Oct 2009; Daniel Black <dragonheart@gentoo.org>
+ dvdstyler-1.7.4_rc1.ebuild, +dvdstyler-1.7.4.ebuild,
+ +files/dvdstyler-1.7.4-autoconf.patch:
+ add missing xmlto dependency as was noticed on irc #gentoo (by I forget
+ who). Added version bump
*dvdstyler-1.7.4_rc1 (16 Sep 2009)
diff --git a/media-video/dvdstyler/dvdstyler-1.7.4.ebuild b/media-video/dvdstyler/dvdstyler-1.7.4.ebuild
new file mode 100644
index 000000000000..552ca4299221
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-1.7.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.4.ebuild,v 1.1 2009/10/14 07:16:49 dragonheart Exp $
+
+EAPI=2
+inherit autotools wxwidgets eutils
+
+MY_P=${PN/dvds/DVDS}-${PV/_}
+
+DESCRIPTION="DVDStyler is a cross-platform DVD authoring System"
+HOMEPAGE="http://www.dvdstyler.de"
+SRC_URI="mirror://sourceforge/dvdstyler/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug gnome"
+
+COMMON_DEPEND=">=media-video/ffmpeg-0.5[encode]
+ >=media-video/xine-ui-0.99.1
+ x11-libs/wxGTK:2.8
+ >=media-libs/wxsvg-1[ffmpeg]
+ >=media-libs/libexif-0.6.16
+ gnome? ( >=gnome-base/libgnomeui-2 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/cdrtools
+ >=media-video/dvdauthor-0.6.14
+ >=app-cdr/dvd+rw-tools-7.1"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ app-text/xmlto
+ >=sys-devel/gettext-0.17"
+PDEPEND=">=app-cdr/dvdisaster-0.71.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autoconf.patch
+ eautoreconf
+}
+
+src_configure() {
+ export WX_GTK_VER="2.8"
+ need-wxwidgets gtk2
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ --with-wx-config="${WX_CONFIG}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ #rm -rf "${D}"/usr/share/doc/${PN}
+ #dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/media-video/dvdstyler/dvdstyler-1.7.4_rc1.ebuild b/media-video/dvdstyler/dvdstyler-1.7.4_rc1.ebuild
index 667a25cb2119..ca4ab63881e1 100644
--- a/media-video/dvdstyler/dvdstyler-1.7.4_rc1.ebuild
+++ b/media-video/dvdstyler/dvdstyler-1.7.4_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.4_rc1.ebuild,v 1.1 2009/09/16 11:14:51 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.4_rc1.ebuild,v 1.2 2009/10/14 07:16:49 dragonheart Exp $
EAPI=2
inherit autotools wxwidgets
@@ -28,6 +28,7 @@ RDEPEND="${COMMON_DEPEND}
>=app-cdr/dvd+rw-tools-7.1"
DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
+ app-text/xmlto
>=sys-devel/gettext-0.17"
PDEPEND=">=app-cdr/dvdisaster-0.71.0"
diff --git a/media-video/dvdstyler/files/dvdstyler-1.7.4-autoconf.patch b/media-video/dvdstyler/files/dvdstyler-1.7.4-autoconf.patch
new file mode 100644
index 000000000000..a9d6a2b278eb
--- /dev/null
+++ b/media-video/dvdstyler/files/dvdstyler-1.7.4-autoconf.patch
@@ -0,0 +1,77 @@
+--- /tmp/DVDStyler-1.7.4/./src/Makefile.am 2009-09-04 15:49:32.000000000 +1000
++++ ./src/Makefile.am 2009-10-14 15:34:46.000000000 +1100
+@@ -7,7 +7,7 @@
+ VobListBox.cpp TitlePropDlg.cpp TitlesetManager.cpp\
+ BurnDlg.cpp ProgressDlg.cpp DirCtrl.cpp StatusBar.cpp MainWin.cpp dvdstyler.cpp
+
+-CXXFLAGS = @CXXFLAGS@ -I..
++AM_CXXFLAGS = @CXXFLAGS@ -I..
+ LDADD = ../wxVillaLib/libwxvilla.a
+
+ SUBDIRS = rc
+--- /tmp/DVDStyler-1.7.4/./Makefile.am 2008-07-15 07:58:46.000000000 +1000
++++ ./Makefile.am 2009-10-14 15:23:26.000000000 +1100
+@@ -1,6 +1,5 @@
+ SUBDIRS = wxVillaLib src locale backgrounds buttons objects data docs
+ ACLOCAL_AMFLAGS=-I.
+-pkgdatadir=@datadir@/doc/@PACKAGE@
+-pkgdata_DATA = AUTHORS COPYING INSTALL README ChangeLog
++doc_DATA = AUTHORS COPYING INSTALL README ChangeLog
+ run: all
+ $(MAKE) -C src run
+--- /tmp/DVDStyler-1.7.4/./wxVillaLib/Makefile.am 2007-12-31 09:51:35.000000000 +1100
++++ ./wxVillaLib/Makefile.am 2009-10-14 15:35:32.000000000 +1100
+@@ -3,4 +3,4 @@
+ PipeExecute.cpp PropDlg.cpp SConv.cpp\
+ Thumbnails.cpp ThumbnailFactory.cpp\
+ utils.cpp VerticalToolbar.cpp
+-CXXFLAGS = @CXXFLAGS@ @GNOMEUI2_CFLAGS@ @LIBEXIF_CFLAGS@ -DWX_SVG
++AM_CXXFLAGS = @CXXFLAGS@ @GNOMEUI2_CFLAGS@ @LIBEXIF_CFLAGS@ -DWX_SVG
+--- /tmp/DVDStyler-1.7.4/locale/Makefile.in 2009-09-19 18:46:38.000000000 +1000
++++ locale/Makefile.in 2009-10-14 15:46:49.000000000 +1100
+@@ -4,8 +4,10 @@
+ # building lang.mo files from the translated lang.po catalogs.
+
+ PROGNAME=dvdstyler
+-LINGUAS=cs da de el es eu fr hu it ko mk nl pl pt pt_BR ru sk sl sr sv vi zh_TW
+-LINGUAS_ALL=ca cs da de el es eu fr hu it ja ko mk nl pl pt pt_BR ru sk sl sr sv vi zh_TW
++# ls *.po | cut -f1 -d . | xargs echo >> Makefile.in
++LINGUAS=cs da de el es fr it ko mk pl pt pt_BR ru sl sr vi zh_TW
++LINGUAS_ALL=cs da de el es fr it ko mk pl pt pt_BR ru sl sr vi zh_TW
++
+
+ prefix=@prefix@
+ datarootdir=@datarootdir@
+--- /tmp/DVDStyler-1.7.4/docs/Makefile.am 2009-08-30 00:30:10.000000000 +1000
++++ docs/Makefile.am 2009-10-14 16:08:10.000000000 +1100
+@@ -1,22 +1,19 @@
+-pkgdatadir=@datadir@/man/man1
+-pkgdata_DATA = dvdstyler.1
++dist_man_MANS = dvdstyler.1
+
+ LINGUAS=en de
+-docdir=@datadir@/@PACKAGE@/docs
+ doc_DATA = $(LINGUAS:%=help_%.zip)
+
+ help%.zip: DVDStylerGuide%.xml
+- mkdir temp
+- (cd temp && $(XMLTO) --skip-validation htmlhelp ../DVDStylerGuide$*.xml && rm -f *.hh* && $(ZIP) ../help$*.zip *.html)
+- rm -f temp/*.html
+- rmdir temp
++ t=`mktemp -d tempXXXXXXX`; \
++ (cd "$$t" && $(XMLTO) --skip-validation htmlhelp ../DVDStylerGuide$*.xml && rm -f *.hh* && $(ZIP) ../help$*.zip *.html) ; \
++ rm -f "$$t"/*.html ; \
++ rmdir "$$t"
+ $(ZIP) help$*.zip htmlhelp.hhp toc.hhc images/*.png
+
+ html: $(LINGUAS:%=html_%)
+
+ html%: DVDStylerGuide%.xml
+- rm -rf html$*
+- mkdir html$*
+- (cd html$* && $(XMLTO) --skip-validation htmlhelp ../DVDStylerGuide$*.xml && rm -f *.hh*)
+- mkdir html$*/images
++ t=`mktemp -d htmlXXXXXX` ; \
++ (cd "$$t" && $(XMLTO) --skip-validation htmlhelp ../DVDStylerGuide$*.xml && rm -f *.hh*) ; \
++ mkdir "$$t"/images
+ cp images/*.png html$*/images/