summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-20 15:00:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-20 15:00:49 +0000
commit8543d344c140df45a8934c465dc564e946d33020 (patch)
treefb74f31582a4bb924092b18e6d2cc974ae089399 /media-video/cinelerra
parentFixed building with new setuptools, bug #308199 (diff)
downloadgentoo-2-8543d344c140df45a8934c465dc564e946d33020.tar.gz
gentoo-2-8543d344c140df45a8934c465dc564e946d33020.tar.bz2
gentoo-2-8543d344c140df45a8934c465dc564e946d33020.zip
Snapshot from cinelerra-cv git with libpng14 patch from Arch Linux.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/cinelerra')
-rw-r--r--media-video/cinelerra/ChangeLog9
-rw-r--r--media-video/cinelerra/cinelerra-20100320.ebuild85
-rw-r--r--media-video/cinelerra/files/cinelerra-20100320-libpng14.patch41
-rw-r--r--media-video/cinelerra/files/cinelerra-20100320-pkgconfig-x264.patch16
4 files changed, 150 insertions, 1 deletions
diff --git a/media-video/cinelerra/ChangeLog b/media-video/cinelerra/ChangeLog
index 2aacacad3343..4532711edeb4 100644
--- a/media-video/cinelerra/ChangeLog
+++ b/media-video/cinelerra/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/cinelerra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/ChangeLog,v 1.39 2010/01/30 14:37:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/ChangeLog,v 1.40 2010/03/20 15:00:49 ssuominen Exp $
+
+*cinelerra-20100320 (20 Mar 2010)
+
+ 20 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +cinelerra-20100320.ebuild, +files/cinelerra-20100320-libpng14.patch,
+ +files/cinelerra-20100320-pkgconfig-x264.patch:
+ Snapshot from cinelerra-cv git with libpng14 patch from Arch Linux.
*cinelerra-20090210-r1 (30 Jan 2010)
diff --git a/media-video/cinelerra/cinelerra-20100320.ebuild b/media-video/cinelerra/cinelerra-20100320.ebuild
new file mode 100644
index 000000000000..3438b696c9de
--- /dev/null
+++ b/media-video/cinelerra/cinelerra-20100320.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/cinelerra-20100320.ebuild,v 1.1 2010/03/20 15:00:49 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils multilib
+
+DESCRIPTION="Cinelerra - Professional Video Editor - Unofficial CVS-version"
+HOMEPAGE="http://www.cinelerra.org/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="3dnow alsa altivec css ieee1394 mmx opengl oss"
+
+RDEPEND="media-libs/libpng
+ >=media-libs/libdv-1.0.0
+ media-libs/faad2
+ media-libs/faac
+ media-libs/a52dec
+ media-libs/libsndfile
+ media-libs/tiff
+ media-video/ffmpeg
+ media-sound/lame
+ >=sci-libs/fftw-3.0.1
+ media-libs/x264
+ media-video/mjpegtools
+ >=media-libs/freetype-2.1.10
+ >=media-libs/openexr-1.2.2
+ >=media-libs/libvorbis-1.2.3
+ >=media-libs/libogg-1.1.4
+ >=media-libs/libtheora-1.1.1
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ x11-libs/libXext
+ x11-libs/libXvMC
+ x11-libs/libXft
+ alsa? ( media-libs/alsa-lib )
+ ieee1394? ( media-libs/libiec61883
+ >=sys-libs/libraw1394-1.2.0
+ >=sys-libs/libavc1394-0.5.0 )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ mmx? ( dev-lang/nasm )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-libavutil50.patch \
+ "${FILESDIR}"/${P}-pkgconfig-x264.patch \
+ "${FILESDIR}"/${PN}-x264.patch \
+ "${FILESDIR}"/${PN}-jpeg-7.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ --disable-esd \
+ $(use_enable ieee1394 firewire) \
+ $(use_enable css) \
+ $(use_enable mmx) \
+ $(use_enable 3dnow) \
+ $(use_enable altivec) \
+ $(use_enable opengl) \
+ --with-plugindir=/usr/$(get_libdir)/cinelerra \
+ --with-buildinfo=cust/"Gentoo - ${PV}" \
+ --with-external-ffmpeg
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dohtml -a png,html,texi,sdw -r doc/*
+ # workaround
+ rm -rf "${D}"/usr/include
+ mv -v "${D}"/usr/bin/mpeg3cat "${D}"/usr/bin/mpeg3cat.hv
+ mv -v "${D}"/usr/bin/mpeg3dump "${D}"/usr/bin/mpeg3dump.hv
+ mv -v "${D}"/usr/bin/mpeg3toc "${D}"/usr/bin/mpeg3toc.hv
+ dosym /usr/bin/mpeg2enc /usr/$(get_libdir)/cinelerra/mpeg2enc.plugin
+}
diff --git a/media-video/cinelerra/files/cinelerra-20100320-libpng14.patch b/media-video/cinelerra/files/cinelerra-20100320-libpng14.patch
new file mode 100644
index 000000000000..f3a0b854f741
--- /dev/null
+++ b/media-video/cinelerra/files/cinelerra-20100320-libpng14.patch
@@ -0,0 +1,41 @@
+http://repos.archlinux.org/wsvn/community/cinelerra-cv/trunk/libpng14.patch
+
+--- cinelerra/cinelerra/filepng.C
++++ cinelerra/cinelerra/filepng.C
+@@ -56,7 +56,7 @@
+ fread(test, 16, 1, stream);
+ fclose(stream);
+
+- if(png_check_sig((unsigned char*)test, 8))
++ if(png_sig_cmp((unsigned char*)test, 0, 8) == 0)
+ {
+ //printf("FilePNG::check_sig 1\n");
+ return 1;
+--- cinelerra/plugins/shapewipe/shapewipe.C
++++ cinelerra/plugins/shapewipe/shapewipe.C
+@@ -386,7 +386,7 @@
+ }
+
+ png_ptr = png_create_read_struct(PNG_LIBPNG_VER_STRING,
+- png_voidp_NULL, png_error_ptr_NULL, png_error_ptr_NULL);
++ NULL, NULL, NULL);
+
+ if (!png_ptr)
+ {
+@@ -399,14 +399,14 @@
+ info_ptr = png_create_info_struct(png_ptr);
+ if (!info_ptr)
+ {
+- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return 1;
+ }
+
+ end_info = png_create_info_struct(png_ptr);
+ if (!end_info)
+ {
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return 1;
+ }
+
diff --git a/media-video/cinelerra/files/cinelerra-20100320-pkgconfig-x264.patch b/media-video/cinelerra/files/cinelerra-20100320-pkgconfig-x264.patch
new file mode 100644
index 000000000000..4a2a51e1b65f
--- /dev/null
+++ b/media-video/cinelerra/files/cinelerra-20100320-pkgconfig-x264.patch
@@ -0,0 +1,16 @@
+--- configure.in
++++ configure.in
+@@ -269,12 +269,7 @@
+
+ ############## libx264
+ LIBX264_LIBS=""
+-AC_CHECK_LIB(x264, x264_encoder_close,
+- [libx264=yes LIBX264_LIBS=-lx264],,-lpthread -lm)
+-if test "x$with_pic" = "xyes"; then
+- AC_CHECK_LIB(x264_pic, x264_encoder_open,
+- [libx264=yes LIBX264_LIBS=-lx264_pic],,-lpthread -lm)
+-fi
++PKG_CHECK_MODULES([LIBX264], [x264], [libx264=yes], [libx264=no])
+ AC_CHECK_HEADER(x264.h, [libx264h=yes])
+ AC_SUBST(LIBX264_LIBS)
+ ##############