summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2006-10-20 21:31:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2006-10-20 21:31:51 +0000
commit45acdf1451c4734b33e7cececdaeeb5701a09a7f (patch)
tree7f507f3ba8126cb939534eecd36e81d55daa0dd2 /media-video/cinelerra-cvs
parentMark 1.0.0 stable on ia64 (diff)
downloadgentoo-2-45acdf1451c4734b33e7cececdaeeb5701a09a7f.tar.gz
gentoo-2-45acdf1451c4734b33e7cececdaeeb5701a09a7f.tar.bz2
gentoo-2-45acdf1451c4734b33e7cececdaeeb5701a09a7f.zip
Version bump, bug #147597 and #143596
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'media-video/cinelerra-cvs')
-rw-r--r--media-video/cinelerra-cvs/ChangeLog8
-rw-r--r--media-video/cinelerra-cvs/cinelerra-cvs-20061020.ebuild92
-rw-r--r--media-video/cinelerra-cvs/files/digest-cinelerra-cvs-200610203
3 files changed, 102 insertions, 1 deletions
diff --git a/media-video/cinelerra-cvs/ChangeLog b/media-video/cinelerra-cvs/ChangeLog
index 21bc79914675..2769053bff55 100644
--- a/media-video/cinelerra-cvs/ChangeLog
+++ b/media-video/cinelerra-cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/cinelerra-cvs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/ChangeLog,v 1.20 2006/10/08 17:38:32 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/ChangeLog,v 1.21 2006/10/20 21:31:51 aballier Exp $
+
+*cinelerra-cvs-20061020 (20 Oct 2006)
+
+ 20 Oct 2006; Alexis Ballier <aballier@gentoo.org>
+ +cinelerra-cvs-20061020.ebuild:
+ Version bump, bug #147597 and #143596
08 Oct 2006; <malc@gentoo.org> cinelerra-cvs-20060619.ebuild:
Make plugin path respect $(get_libdir) to fix QA checks on x86_64 platforms - bug #145027
diff --git a/media-video/cinelerra-cvs/cinelerra-cvs-20061020.ebuild b/media-video/cinelerra-cvs/cinelerra-cvs-20061020.ebuild
new file mode 100644
index 000000000000..3c6a9ce443ef
--- /dev/null
+++ b/media-video/cinelerra-cvs/cinelerra-cvs-20061020.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/cinelerra-cvs-20061020.ebuild,v 1.1 2006/10/20 21:31:51 aballier Exp $
+
+inherit toolchain-funcs eutils flag-o-matic
+
+#filter-flags "-fPIC -fforce-addr"
+
+RESTRICT="nostrip"
+
+DESCRIPTION="Cinelerra - Professional Video Editor - Unofficial CVS-version"
+HOMEPAGE="http://cvs.cinelerra.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="3dnow alsa esd mmx oss static freetype2 ieee1394 css altivec opengl"
+RDEPEND="media-libs/libpng
+ >=media-libs/libdv-1.0.0
+ media-libs/faad2
+ media-libs/faac
+ media-libs/a52dec
+ media-video/ffmpeg
+ >=sci-libs/fftw-3.0.1
+ >=media-libs/x264-svn-20060302
+ ieee1394? ( media-libs/libiec61883 >=sys-libs/libraw1394-1.2.0 \
+ >=sys-libs/libavc1394-0.5.0 )
+ media-video/mjpegtools
+ esd? ( >=media-sound/esound-0.2.34 )
+ freetype2? ( >=media-libs/freetype-2.1.10 )
+ opengl? ( virtual/opengl )
+ >=media-libs/openexr-1.2.2
+ >=media-libs/libvorbis-1.1.0
+ >=media-libs/libogg-1.1
+ >=media-libs/libtheora-1.0_alpha4-r1
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ x11-libs/libXext
+ x11-libs/libXvMC
+ x11-libs/libXft
+ ) virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+pkg_setup() {
+ if [[ "$(gcc-major-version)" -lt "3" ]]; then
+ die "You must use gcc 3 or better."
+ fi
+}
+
+src_compile() {
+ export WANT_AUTOMAKE=1.7
+ export WANT_AUTOCONF=2.5
+ ./autogen.sh
+ econf \
+ `use_enable static` \
+ `use_enable alsa` \
+ `use_enable esd` \
+ `use_enable oss` \
+ `use_enable mmx` \
+ `use_enable 3dnow` \
+ --with-plugindir=/usr/$(get_libdir)/cinelerra \
+ `use_enable freetype2` \
+ `use_enable ieee1394 firewire` \
+ `use_enable css` \
+ `use_enable opengl` \
+ `use_enable altivec` \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dohtml -a png,html,texi,sdw -r doc/*
+ # workaround
+ rm -fR ${D}/usr/include
+ mv ${D}/usr/bin/mpeg3cat ${D}/usr/bin/mpeg3cat.hv
+ mv ${D}/usr/bin/mpeg3dump ${D}/usr/bin/mpeg3dump.hv
+ mv ${D}/usr/bin/mpeg3toc ${D}/usr/bin/mpeg3toc.hv
+ ln -s /usr/bin/mpeg2enc ${D}/usr/lib/cinelerra/mpeg2enc.plugin
+}
+
+pkg_postinst () {
+
+einfo "Please note that this is unofficial and somewhat experimental code."
+einfo "See cvs.cinelerra.org for a list of changes to the official cinelerra"
+einfo "release."
+}
diff --git a/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20061020 b/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20061020
new file mode 100644
index 000000000000..55c468b2788d
--- /dev/null
+++ b/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20061020
@@ -0,0 +1,3 @@
+MD5 9ffe6aae83d43881e518691db17877b2 cinelerra-cvs-20061020.tar.bz2 32673794
+RMD160 f799cec3292a87a523a8cba2d95dadba6e9d380d cinelerra-cvs-20061020.tar.bz2 32673794
+SHA256 fb3e1d461c751e203deb463ca4960b237660eca516fef71efa21b09961a9a0ee cinelerra-cvs-20061020.tar.bz2 32673794