summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-05-22 19:15:16 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-05-22 19:15:16 +0000
commitdecdcdcc42a24fa4801f12ca2941d5e9f965af54 (patch)
tree8fbdbf8fa436b454457f7b024fe091b1ebddd666 /media-video/avifile
parentVersion bumped (diff)
downloadgentoo-2-decdcdcc42a24fa4801f12ca2941d5e9f965af54.tar.gz
gentoo-2-decdcdcc42a24fa4801f12ca2941d5e9f965af54.tar.bz2
gentoo-2-decdcdcc42a24fa4801f12ca2941d5e9f965af54.zip
Version bumped
Diffstat (limited to 'media-video/avifile')
-rw-r--r--media-video/avifile/ChangeLog8
-rw-r--r--media-video/avifile/Manifest4
-rw-r--r--media-video/avifile/avifile-0.7.37.20030522.ebuild161
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.37.200305221
4 files changed, 171 insertions, 3 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index d6f0dd196b5a..684aaa951d16 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/avifile
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.47 2003/04/21 23:58:22 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.48 2003/05/22 19:15:00 mholzer Exp $
+
+*avifile-0.7.37.20030522 (22 May 2003)
+
+ 22 May 2003; Martin Holzer <mholzer@gentoo.org>
+ avifile-0.7.37.20030522.ebuild:
+ Version bumped.
*avifile-0.7.34.20030319 (22 Apr 2003)
diff --git a/media-video/avifile/Manifest b/media-video/avifile/Manifest
index 67c39c1a87e1..e46035744e84 100644
--- a/media-video/avifile/Manifest
+++ b/media-video/avifile/Manifest
@@ -1,6 +1,6 @@
-MD5 ab1966c1b66437f5423e98d5942a7586 ChangeLog 8706
+MD5 802e771b86dbc351d1848d6d34b86b8d ChangeLog 8849
MD5 57d49dcece64d038049874257f89f20c avifile-0.7.15.20020816-r1.ebuild 2226
-MD5 d9772dc03b4c683f5bc34b32c3047e62 avifile-0.7.37.20030522.ebuild 4174
+MD5 966e015cb69db62b3cbc70b58133896c avifile-0.7.37.20030522.ebuild 4174
MD5 6ced5e3f190d3b31cb9e15f9214c7553 avifile-0.7.29.20030204.ebuild 4100
MD5 232af89cb62a54d98be0b94837100253 avifile-0.7.32.20030219.ebuild 4099
MD5 237a782f5bb313f0bab18346ddf5d6de avifile-0.7.34.20030319.ebuild 4178
diff --git a/media-video/avifile/avifile-0.7.37.20030522.ebuild b/media-video/avifile/avifile-0.7.37.20030522.ebuild
new file mode 100644
index 000000000000..266466f3a753
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.37.20030522.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.37.20030522.ebuild,v 1.1 2003/05/22 19:15:00 mholzer Exp $
+
+IUSE="static truetype xv sdl dvd mmx sse 3dnow zlib oggvorbis X qt alsa esd"
+
+MAJ_PV=${PV:0:3}
+MIN_PV=${PV:3:3}
+MY_P="${P/.200/-200}"
+MY_S="${PN}${MAJ_PV}-${MAJ_PV}${MIN_PV}"
+S="${WORKDIR}/${MY_S}"
+
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+HOMEPAGE="http://avifile.sourceforge.net/"
+
+SLOT="0.7"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND=">=media-libs/jpeg-6b
+ x86? ( >=media-libs/divx4linux-20020418
+ >=media-libs/win32codecs-0.90 )
+ >=media-video/ffmpeg-0.4
+ >=media-sound/mad-0.14
+ >=media-libs/xvid-0.9.0
+ >=media-sound/lame-3.90
+ >=media-libs/audiofile-0.2.3
+ truetype? ( >=media-libs/freetype-2.1 )
+ xv? ( >=x11-base/xfree-4.2.1 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ dvd? ( >=media-libs/a52dec-0.7 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ X? ( >=x11-base/xfree-4.2.0 virtual/xft )
+ qt? ( >=x11-libs/qt-3.0.3 )
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc2 )
+ esd? ( >=media-sound/esound-0.2.28 )"
+
+src_compile() {
+ local myconf="--enable-oss"
+ local kdepre=""
+
+ use static \
+ && myconf="${myconf} --enable-static" \
+ || myconf="${myconf} --disable-static"
+
+ use freetype \
+ && myconf="${myconf} --enable-freetype2" \
+ || myconf="${myconf} --disable-freetype2"
+
+ use xv \
+ && myconf="${myconf} --enable-xv" \
+ || myconf="${myconf} --disable-xv"
+
+ if [ "$XINERAMA" = "NO" ]; then
+ myconf="${myconf} --disable-xinerama"
+ fi
+
+ if [ "$DPMS" = "NO" ]; then
+ myconf="${myconf} --disable-dpms"
+ fi
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ if [ "$V4L" = "NO" ]; then
+ myconf="${myconf} --disable-v4l"
+ fi
+
+ if [ "$SUN" = "NO" ]; then
+ myconf="${myconf} --disable-sunaudio"
+ fi
+
+ use dvd \
+ && myconf="${myconf} --enable-a52 --enable-ffmpeg-a52" \
+ || myconf="${myconf} --disable-a52 --disable-ffmpeg-a52"
+
+ if [ "$SBLIVE" = "NO" ]; then
+ myconf="${myconf} --disable-ac3passthrough"
+ fi
+
+ if [ "$RUNTIME_LAME" = "YES" ]; then
+ myconf="${myconf} --enable-lame-bin"
+ fi
+
+ if [ ! -z $DEBUGBUILD ]; then
+ myconf="${myconf} --enable-loader-out"
+ else
+ myconf="${myconf} --enable-quiet"
+ fi
+
+ ( use mmx || use sse || use 3dnow ) && myconf="${myconf} --enable-x86opt"
+
+ use zlib \
+ && myconf="${myconf} --enable-libz" \
+ || myconf="${myconf} --disable-libz"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ if [ "$MGA" = "NO" ]; then
+ myconf="${myconf} --disable-mga"
+ fi
+
+ if [ "$DMALLOC" = "YES" ]; then
+ myconf="${myconf} --with-dmallocth"
+ fi
+
+ use X \
+ && myconf="${myconf} --with-x --enable-xft" \
+ || myconf="${myconf} --without-x --disable-xft"
+
+ use qt \
+ && myconf="${myconf} --with-qt-prefix=${QTDIR}" \
+ || myconf="${myconf} --without-qt"
+
+ # Rather not use custom ones here .. build should set as high as
+ # safe by itself.
+ unset CFLAGS CXXFLAGS LDFLAGS CC CXX
+
+ # Make sure we include freetype2 headers before freetype1 headers, else Xft2
+ # borks, bug #11941.
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+
+ # Fix qt detection
+ cp configure configure.orig
+ sed -e "s:extern \"C\" void exit(int);:/* extern \"C\" void exit(int); */:" \
+ < configure.orig > configure
+
+ econf \
+ --enable-samples \
+ --disable-vidix \
+ --with-fpic \
+ --with-gnu-ld \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ einstall || die
+
+ cd ${S}
+ dodoc COPYING README INSTALL
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS KNOWN_BUGS
+}
+
+pkg_postinst() {
+ einfo "In order to use certain video modes, you must be root"
+ einfo "chmod +s /usr/bin/aviplay to suid root"
+ einfo "As this is considered a security risk on multiuser"
+ einfo "systems, this is not done by default"
+}
diff --git a/media-video/avifile/files/digest-avifile-0.7.37.20030522 b/media-video/avifile/files/digest-avifile-0.7.37.20030522
new file mode 100644
index 000000000000..decb06dd70e4
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.37.20030522
@@ -0,0 +1 @@
+MD5 074bd003318128e433dd96a64c80b776 avifile-0.7.37-20030522.tgz 2862210