summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-23 18:55:53 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-23 18:55:53 +0000
commitc67cc63fdb84bd04a69337f62ad9cc08b1eebd81 (patch)
treeb543ece83ac15e4501f36c0ab1272299f735f00f /media-video/avifile
parentadd *virtual/bootloader (diff)
downloadgentoo-2-c67cc63fdb84bd04a69337f62ad9cc08b1eebd81.tar.gz
gentoo-2-c67cc63fdb84bd04a69337f62ad9cc08b1eebd81.tar.bz2
gentoo-2-c67cc63fdb84bd04a69337f62ad9cc08b1eebd81.zip
Another version bump. Removed automake depend.
Diffstat (limited to 'media-video/avifile')
-rw-r--r--media-video/avifile/ChangeLog9
-rw-r--r--media-video/avifile/avifile-0.7.27.20030122.ebuild164
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.27.200301221
3 files changed, 173 insertions, 1 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index 965a382159b2..47c5211d4f6d 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.30 2003/01/23 11:25:17 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.31 2003/01/23 18:55:52 raker Exp $
+
+*avifile-0.7.27.20030122 (23 jan 2003)
+
+ 23 Jan 2003; Nick Hadaway <raker@gentoo.org> avifile-0.7.27.20030122.ebuild,
+ files/digest-/avifile-0.7.27.20030122 :
+ Version bump. Removed automake dependancy. This has a fix for avi
+ movies over ~4200 seconds.
*avifile-0.7.26.20030117 (23 Jan 2003)
diff --git a/media-video/avifile/avifile-0.7.27.20030122.ebuild b/media-video/avifile/avifile-0.7.27.20030122.ebuild
new file mode 100644
index 000000000000..835d1451171d
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.27.20030122.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.27.20030122.ebuild,v 1.1 2003/01/23 18:55:52 raker Exp $
+
+IUSE="static freetype xv sdl oss dvd mmx sse 3dnow zlib oggvorbis X qt"
+
+inherit libtool
+
+MY_P="${P/.200/-200}"
+MY_S="${PN}0.7-0.7.27"
+S="${WORKDIR}/${MY_S}"
+
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="http://avifile.sourceforge.net/${MY_P}.tgz"
+HOMEPAGE="http://avifile.sourceforge.net/"
+
+DEPEND=">=media-libs/divx4linux-20020418
+ >=media-libs/jpeg-6b
+ >=media-libs/win32codecs-0.90
+ >=media-video/ffmpeg-0.4
+ >=media-sound/mad-0.14
+ >=media-libs/xvid-0.9.0
+ >=media-sound/lame-3.90
+ freetype? ( >=media-libs/freetype-2.1 )
+ xv? ( >=x11-base/xfree-4.2.1 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ dvd? ( >=media-libs/a52dec-0.7 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ X? ( >=x11-base/xfree-4.2.0 >=x11-libs/xft-2.0.1 )
+ qt? ( >=x11-libs/qt-3.0.3 )"
+
+SLOT="0.7"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+
+ elibtoolize
+
+ local myconf=""
+ local kdepre=""
+
+ use static \
+ && myconf="${myconf} --enable-static" \
+ || myconf="${myconf} --disable-static"
+
+ use freetype \
+ && myconf="${myconf} --enable-freetype2" \
+ || myconf="${myconf} --disable-freetype2"
+
+ use xv \
+ && myconf="${myconf} --enable-xv" \
+ || myconf="${myconf} --disable-xv"
+
+ if [ "$XINERAMA" = "NO" ]; then
+ myconf="${myconf} --disable-xinerama"
+ fi
+
+ if [ "$DPMS" = "NO" ]; then
+ myconf="${myconf} --disable-dpms"
+ fi
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ if [ "$V4L" = "NO" ]; then
+ myconf="${myconf} --disable-v4l"
+ fi
+
+ use oss \
+ && myconf="${myconf} --enable-oss" \
+ || myconf="${myconf} --disable-oss"
+
+ if [ "$SUN" = "NO" ]; then
+ myconf="${myconf} --disable-sunaudio"
+ fi
+
+ use dvd \
+ && myconf="${myconf} --enable-a52 --enable-ffmpeg-a52" \
+ || myconf="${myconf} --disable-a52 --disable-ffmpeg-a52"
+
+ if [ "$SBLIVE" = "NO" ]; then
+ myconf="${myconf} --disable-ac3passthrough"
+ fi
+
+ if [ "$RUNTIME_LAME" = "YES" ]; then
+ myconf="${myconf} --enable-lame-bin"
+ fi
+
+ if [ ! -z $DEBUGBUILD ]; then
+ myconf="${myconf} --enable-loader-out --enable-timing"
+ else
+ myconf="${myconf} --enable-quiet"
+ fi
+
+ ( use mmx || use sse || use 3dnow ) && myconf="${myconf} --enable-x86opt"
+
+ use zlib \
+ && myconf="${myconf} --enable-libz" \
+ || myconf="${myconf} --disable-libz"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ if [ "$MGA" = "NO" ]; then
+ myconf="${myconf} --disable-mga"
+ fi
+
+ if [ "$DMALLOC" = "YES" ]; then
+ myconf="${myconf} --with-dmallocth"
+ fi
+
+ use X \
+ && myconf="${myconf} --with-x --enable-xft" \
+ || myconf="${myconf} --without-x --disable-xft"
+
+ use qt \
+ && myconf="${myconf} --with-qt-dir=${QTDIR}" \
+ || myconf="${myconf} --without-qt"
+
+ # Rather not use custom ones here .. build should set as high as
+ # safe by itself.
+ unset CFLAGS CXXFLAGS LDFLAGS CC CXX
+
+ # Make sure we include freetype2 headers before freetype1 headers, else Xft2
+ # borks, bug #11941.
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+
+ # Fix qt detection
+ cp configure configure.orig
+ sed -e "s:extern \"C\" void exit(int);:/* extern \"C\" void exit(int); */:" \
+ < configure.orig > configure
+
+ econf \
+ --enable-samples \
+ --disable-vidix \
+ --with-fpic \
+ --with-gnu-ld \
+ ${myconf} || die
+
+ export CC="gcc"
+ export CXX="g++"
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ einstall || die
+
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
+
diff --git a/media-video/avifile/files/digest-avifile-0.7.27.20030122 b/media-video/avifile/files/digest-avifile-0.7.27.20030122
new file mode 100644
index 000000000000..f351dfb7f404
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.27.20030122
@@ -0,0 +1 @@
+MD5 e8431bc88e0f49059077ac7138e7e47d avifile-0.7.27-20030122.tgz 2632461