summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-01-11 05:15:47 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-01-11 05:15:47 +0000
commit72b343491dd54feee485825903011db44b85b86c (patch)
tree6beec6280b4f7e16a16ec6b1c4281646d1854021 /media-tv
parentStable on x86; bug #118407 (diff)
downloadgentoo-2-72b343491dd54feee485825903011db44b85b86c.tar.gz
gentoo-2-72b343491dd54feee485825903011db44b85b86c.tar.bz2
gentoo-2-72b343491dd54feee485825903011db44b85b86c.zip
added some patches that I sent upstream
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog7
-rw-r--r--media-tv/mythtv/files/mythtv-0.19_pre8554-chanutil-schar.patch21
-rw-r--r--media-tv/mythtv/files/mythtv-0.19_pre8554-freetype.patch33
-rw-r--r--media-tv/mythtv/mythtv-0.19_pre8554.ebuild4
4 files changed, 63 insertions, 2 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 93837d3d2bda..b5e3f1540716 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.80 2006/01/11 04:01:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.81 2006/01/11 05:15:47 cardoe Exp $
+
+ 11 Jan 2006; Doug Goldstein <cardoe@gentoo.org>
+ +files/mythtv-0.19_pre8554-chanutil-schar.patch,
+ +files/mythtv-0.19_pre8554-freetype.patch, mythtv-0.19_pre8554.ebuild:
+ added some patches that I sent upstream
*mythtv-0.19_pre8554 (11 Jan 2006)
diff --git a/media-tv/mythtv/files/mythtv-0.19_pre8554-chanutil-schar.patch b/media-tv/mythtv/files/mythtv-0.19_pre8554-chanutil-schar.patch
new file mode 100644
index 000000000000..bfdb011ec768
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-0.19_pre8554-chanutil-schar.patch
@@ -0,0 +1,21 @@
+Index: libs/libmythtv/channelutil.cpp
+===================================================================
+--- libs/libmythtv/channelutil.cpp (revision 8554)
++++ libs/libmythtv/channelutil.cpp (working copy)
+@@ -11,11 +11,11 @@
+ // DVB specific
+ int transport_id, int network_id,
+ bool set_odfm_info,
+- int symbol_rate, char bandwidth,
+- char polarity, char inversion,
+- char trans_mode,
++ int symbol_rate, signed char bandwidth,
++ signed char polarity, signed char inversion,
++ signed char trans_mode,
+ QString inner_FEC, QString constellation,
+- char hierarchy, QString hp_code_rate,
++ signed char hierarchy, QString hp_code_rate,
+ QString lp_code_rate, QString guard_interval)
+ {
+ MSqlQuery query(MSqlQuery::InitCon());
+
diff --git a/media-tv/mythtv/files/mythtv-0.19_pre8554-freetype.patch b/media-tv/mythtv/files/mythtv-0.19_pre8554-freetype.patch
new file mode 100644
index 000000000000..98f1a922293a
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-0.19_pre8554-freetype.patch
@@ -0,0 +1,33 @@
+Index: configure
+===================================================================
+--- configure (revision 8554)
++++ configure (working copy)
+@@ -2383,6 +2383,8 @@
+ fi
+ if test "$freetype2" = "yes" ; then
+ echo "HAVE_FREETYPE2=yes" >> $MYTH_CONFIG_MAK
++ echo "FREETYPE_CFLAGS=`freetype-config --cflags`" >> $MYTH_CONFIG_MAK
++ echo "FREETYPE_LIBS=`freetype-config --libs`" >> $MYTH_CONFIG_MAK
+ fi
+ if test "$sunmlib" = "yes" ; then
+ echo "HAVE_MLIB=yes" >> $MYTH_CONFIG_MAK
+Index: libs/libmythtv/libmythtv.pro
+===================================================================
+--- libs/libmythtv/libmythtv.pro (revision 8554)
++++ libs/libmythtv/libmythtv.pro (working copy)
+@@ -33,10 +33,11 @@
+ TARGETDEPS += ../libmythmpeg2/libmythmpeg2-$${LIBVERSION}.$${QMAKE_EXTENSION_LIB}
+
+ DEFINES += _LARGEFILE_SOURCE
+-QMAKE_CXXFLAGS_RELEASE += `freetype-config --cflags`
+-QMAKE_CXXFLAGS_DEBUG += `freetype-config --cflags`
+-QMAKE_LFLAGS_SHLIB += `freetype-config --libs`
+
++QMAKE_CXXFLAGS_RELEASE += $${FREETYPE_CFLAGS}
++QMAKE_CXXFLAGS_DEBUG += $${FREETYPE_CFLAGS}
++QMAKE_LFLAGS_SHLIB += $${FREETYPE_LIBS}
++
+ macx {
+ # Mac OS X Frameworks
+ FWKS = ApplicationServices Carbon QuickTime
+
diff --git a/media-tv/mythtv/mythtv-0.19_pre8554.ebuild b/media-tv/mythtv/mythtv-0.19_pre8554.ebuild
index 38d09dc70be7..f410713cc3be 100644
--- a/media-tv/mythtv/mythtv-0.19_pre8554.ebuild
+++ b/media-tv/mythtv/mythtv-0.19_pre8554.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.19_pre8554.ebuild,v 1.1 2006/01/11 04:01:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.19_pre8554.ebuild,v 1.2 2006/01/11 05:15:47 cardoe Exp $
inherit flag-o-matic eutils debug qt3
@@ -80,6 +80,8 @@ src_unpack() {
cd ${S}
epatch "${FILESDIR}"/${P}-xrandr.patch
+ epatch "${FILESDIR}"/${P}-chanutil-schar.patch
+ epatch "${FILESDIR}"/${P}-freetype.patch
if [ $(get_libdir) != "lib" ] ; then
sed -i -e "s:\$\${PREFIX}/lib/:\$\${PREFIX}/$(get_libdir)/:g" \