summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-03-15 18:31:12 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-03-15 18:31:12 +0000
commit27debdc68b26be15103e6bf63e6178b65458abb2 (patch)
tree52ce24dc09b13b41d4de92f6c0b7c356bb1abd75 /media-tv
parentAdded gnome-extras/yelp dependency for documentation when gtk is set (diff)
downloadgentoo-2-27debdc68b26be15103e6bf63e6178b65458abb2.tar.gz
gentoo-2-27debdc68b26be15103e6bf63e6178b65458abb2.tar.bz2
gentoo-2-27debdc68b26be15103e6bf63e6178b65458abb2.zip
Non-maintainer commit. Version bump to next rc which fixes serious regression. Check for py2 in pkg_setup as py3 is borked. No other factical changes.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xbmc/ChangeLog9
-rw-r--r--media-tv/xbmc/xbmc-11.0_rc2.ebuild (renamed from media-tv/xbmc/xbmc-11.0_rc1.ebuild)10
-rw-r--r--media-tv/xbmc/xbmc-9999.ebuild11
3 files changed, 27 insertions, 3 deletions
diff --git a/media-tv/xbmc/ChangeLog b/media-tv/xbmc/ChangeLog
index 55272308665b..1797123fa47d 100644
--- a/media-tv/xbmc/ChangeLog
+++ b/media-tv/xbmc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/xbmc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/ChangeLog,v 1.118 2012/03/01 05:14:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/ChangeLog,v 1.119 2012/03/15 18:31:12 scarabeus Exp $
+
+*xbmc-11.0_rc2 (15 Mar 2012)
+
+ 15 Mar 2012; Tomáš Chvátal <scarabeus@gentoo.org> +xbmc-11.0_rc2.ebuild,
+ -xbmc-11.0_rc1.ebuild, xbmc-9999.ebuild:
+ Non-maintainer commit. Version bump to next rc which fixes serious regression.
+ Check for py2 in pkg_setup as py3 is borked. No other factical changes.
*xbmc-11.0_rc1 (01 Mar 2012)
diff --git a/media-tv/xbmc/xbmc-11.0_rc1.ebuild b/media-tv/xbmc/xbmc-11.0_rc2.ebuild
index 0e831d783e82..9d484febad26 100644
--- a/media-tv/xbmc/xbmc-11.0_rc1.ebuild
+++ b/media-tv/xbmc/xbmc-11.0_rc2.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-11.0_rc1.ebuild,v 1.1 2012/03/01 05:14:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-11.0_rc2.ebuild,v 1.1 2012/03/15 18:31:12 scarabeus Exp $
EAPI="4"
+# Does not work with py3 here
+# It might work with py:2.5 but I didn't test that
+PYTHON_DEPEND="2:2.6"
inherit eutils python
EGIT_REPO_URI="git://github.com/xbmc/xbmc.git"
@@ -96,6 +99,11 @@ DEPEND="${COMMON_DEPEND}
dev-util/cmake
x86? ( dev-lang/nasm )"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-2_src_unpack
diff --git a/media-tv/xbmc/xbmc-9999.ebuild b/media-tv/xbmc/xbmc-9999.ebuild
index 2dd9e902f0fa..0e6ce754a87b 100644
--- a/media-tv/xbmc/xbmc-9999.ebuild
+++ b/media-tv/xbmc/xbmc-9999.ebuild
@@ -1,9 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9999.ebuild,v 1.102 2012/03/01 05:12:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xbmc/xbmc-9999.ebuild,v 1.103 2012/03/15 18:31:12 scarabeus Exp $
EAPI="4"
+# Does not work with py3 here
+# It might work with py:2.5 but I didn't test that
+PYTHON_DEPEND="2:2.6"
+
inherit eutils python
EGIT_REPO_URI="git://github.com/xbmc/xbmc.git"
@@ -96,6 +100,11 @@ DEPEND="${COMMON_DEPEND}
dev-util/cmake
x86? ( dev-lang/nasm )"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-2_src_unpack