summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-08-12 07:22:04 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-08-12 07:22:04 +0000
commit077ed062c5f8ea08f3b8f6a732d48fe674b6029d (patch)
treed776a5206e197208320d047f998cb7ecc7f40372 /media-tv
parent1.1 stable on x86. (diff)
downloadgentoo-2-077ed062c5f8ea08f3b8f6a732d48fe674b6029d.tar.gz
gentoo-2-077ed062c5f8ea08f3b8f6a732d48fe674b6029d.tar.bz2
gentoo-2-077ed062c5f8ea08f3b8f6a732d48fe674b6029d.zip
Fix up CPU types. bug #94696.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog6
-rw-r--r--media-tv/mythtv/files/mythtv-0.18.1-cc-on-mute.patch20
-rw-r--r--media-tv/mythtv/mythtv-0.18.1-r2.ebuild10
3 files changed, 32 insertions, 4 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index cd41ce6d96d7..702349562449 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.75 2005/07/28 14:23:31 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.76 2005/08/12 07:22:04 cardoe Exp $
+
+ 12 Aug 2005; Doug Goldstein <cardoe@gentoo.org>
+ +files/mythtv-0.18.1-cc-on-mute.patch, mythtv-0.18.1-r2.ebuild:
+ Fix up CPU types. bug #94696.
28 Jul 2005; Caleb Tennis <caleb@gentoo.org> mythtv-0.18.1-r1.ebuild,
mythtv-0.18.1-r2.ebuild:
diff --git a/media-tv/mythtv/files/mythtv-0.18.1-cc-on-mute.patch b/media-tv/mythtv/files/mythtv-0.18.1-cc-on-mute.patch
new file mode 100644
index 000000000000..1f35845486ca
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-0.18.1-cc-on-mute.patch
@@ -0,0 +1,20 @@
+--- tv_play.cpp.old 2005-04-24 23:54:37.000000000 -0400
++++ tv_play.cpp 2005-08-12 02:07:30.000000000 -0400
+@@ -1780,7 +1780,16 @@
+ else if (action == "VOLUMEUP")
+ ChangeVolume(true);
+ else if (action == "MUTE")
+- ToggleMute();
++ {
++ bool valid = false;
++ int page = QueuedChannel().toInt(&valid, 16) << 16;
++ if (!valid)
++ page = 0;
++ ChannelClear();
++ DoToggleCC(page);
++
++ ToggleMute();
++ }
+ else if (action == "STRETCHINC")
+ ChangeTimeStretch(1);
+ else if (action == "STRETCHDEC")
diff --git a/media-tv/mythtv/mythtv-0.18.1-r2.ebuild b/media-tv/mythtv/mythtv-0.18.1-r2.ebuild
index 56a9f4d0732a..5ad85d6eefa2 100644
--- a/media-tv/mythtv/mythtv-0.18.1-r2.ebuild
+++ b/media-tv/mythtv/mythtv-0.18.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r2.ebuild,v 1.8 2005/07/28 14:23:31 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.1-r2.ebuild,v 1.9 2005/08/12 07:22:04 cardoe Exp $
inherit flag-o-matic eutils debug
@@ -69,8 +69,12 @@ src_unpack() {
epatch ${FILESDIR}/${P}-opengl-fix.patch
- # Add support for amd64 --arch options, bug 94664
- epatch ${FILESDIR}/${P}-x86_64-configure.patch
+ # Add support for --arch options, bug 94696
+ epatch ${FILESDIR}/${P}-cputypes-configure.patch
+
+ # Turn on CC on Mute patch
+# cd ${S}/libs/libmythtv
+# epatch ${FILESDIR}/${P}-cc-on-mute.patch
if [ $(get_libdir) != "lib" ] ; then
sed -i -e "s:\$\${PREFIX}/lib/:\$\${PREFIX}/$(get_libdir)/:g" \