summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-13 03:19:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-13 03:19:04 +0000
commit7fb24f22ebac7ad6ba1f8cba22c516bde998223a (patch)
tree1239151879604e2233df004aa2a194319593cbc1 /media-tv/tvtime
parentFix some int/long mismatches. Fixes bug #105709 (diff)
downloadgentoo-2-7fb24f22ebac7ad6ba1f8cba22c516bde998223a.tar.gz
gentoo-2-7fb24f22ebac7ad6ba1f8cba22c516bde998223a.tar.bz2
gentoo-2-7fb24f22ebac7ad6ba1f8cba22c516bde998223a.zip
remove invalid USE=pic #101049
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-tv/tvtime')
-rw-r--r--media-tv/tvtime/files/tvtime-pic.patch5
-rw-r--r--media-tv/tvtime/tvtime-0.99.ebuild33
2 files changed, 14 insertions, 24 deletions
diff --git a/media-tv/tvtime/files/tvtime-pic.patch b/media-tv/tvtime/files/tvtime-pic.patch
index 81f65088f195..ec3779a87bbf 100644
--- a/media-tv/tvtime/files/tvtime-pic.patch
+++ b/media-tv/tvtime/files/tvtime-pic.patch
@@ -1,6 +1,5 @@
-diff -ur tvtime-0.9.15/src/cpu_accel.c tvtime-0.9.15-patched/src/cpu_accel.c
---- tvtime-0.9.15/src/cpu_accel.c 2004-06-20 12:30:11.000000000 +0800
-+++ tvtime-0.9.15-patched/src/cpu_accel.c 2005-02-24 16:01:46.665413504 +0800
+--- tvtime/src/cpu_accel.c
++++ tvtime/src/cpu_accel.c
@@ -35,7 +35,7 @@
int AMD;
uint32_t caps;
diff --git a/media-tv/tvtime/tvtime-0.99.ebuild b/media-tv/tvtime/tvtime-0.99.ebuild
index 7362037d9cae..607c00699c9d 100644
--- a/media-tv/tvtime/tvtime-0.99.ebuild
+++ b/media-tv/tvtime/tvtime-0.99.ebuild
@@ -1,56 +1,48 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-0.99.ebuild,v 1.2 2005/07/10 12:14:48 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-0.99.ebuild,v 1.3 2005/09/13 03:19:04 vapier Exp $
inherit eutils
-DESCRIPTION="High quality television application for use with video capture cards."
+DESCRIPTION="High quality television application for use with video capture cards"
HOMEPAGE="http://tvtime.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-RESTRICT="nomirror"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="pic nls"
+IUSE="nls"
RDEPEND="virtual/x11
>=media-libs/freetype-2
>=sys-libs/zlib-1.1.4
>=media-libs/libpng-1.2
>=dev-libs/libxml2-2.5.11"
-
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_unpack() {
-
unpack ${A}
+ cd "${S}"
+
# use 'tvtime' for the application icon see bug #66293
- sed -i -e "s/tvtime.png/tvtime/" ${S}/docs/net-tvtime.desktop
- # patch to adapt to PIC or __PIC__ for pic support
- # see bug #74227
- cd ${S}
- epatch ${FILESDIR}/${PN}-pic.patch
+ sed -i -e "s/tvtime.png/tvtime/" docs/net-tvtime.desktop
+ # patch to adapt to PIC or __PIC__ for pic support
+ epatch "${FILESDIR}"/${PN}-pic.patch #74227
}
src_compile() {
-
- econf `use_enable nls` \
- `use_with pic` || die "econf failed"
-
+ econf $(use_enable nls) || die "econf failed"
emake || die "compile problem"
}
-src_install () {
-
- make DESTDIR=${D} install || die "make install failed"
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
dohtml docs/html/*
- dodoc ChangeLog AUTHORS NEWS README COPYING data/COPYING.*
-
+ dodoc ChangeLog AUTHORS NEWS README
}
pkg_postinst() {
@@ -62,4 +54,3 @@ pkg_postinst() {
einfo "found at ${HOMEPAGE}help.html"
echo
}
-