summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-08-17 15:38:22 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-08-17 15:38:22 +0000
commitd249c94d488ed7bba7152a4d1ea1d8afe73d6403 (patch)
treee3384d37e130e1f97bb49dd659a6139e99365bea /media-tv/nxtvepg
parentAdjust default wrapper config (diff)
downloadgentoo-2-d249c94d488ed7bba7152a4d1ea1d8afe73d6403.tar.gz
gentoo-2-d249c94d488ed7bba7152a4d1ea1d8afe73d6403.tar.bz2
gentoo-2-d249c94d488ed7bba7152a4d1ea1d8afe73d6403.zip
version bump for bug 241700
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-tv/nxtvepg')
-rw-r--r--media-tv/nxtvepg/ChangeLog8
-rw-r--r--media-tv/nxtvepg/nxtvepg-2.8.1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/media-tv/nxtvepg/ChangeLog b/media-tv/nxtvepg/ChangeLog
index 02aa1b893d13..9255372c5613 100644
--- a/media-tv/nxtvepg/ChangeLog
+++ b/media-tv/nxtvepg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/nxtvepg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/ChangeLog,v 1.21 2009/08/17 15:34:49 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/ChangeLog,v 1.22 2009/08/17 15:38:22 fauli Exp $
+
+*nxtvepg-2.8.1 (17 Aug 2009)
+
+ 17 Aug 2009; Christian Faulhammer <fauli@gentoo.org>
+ +nxtvepg-2.8.1.ebuild:
+ version bump for bug 241700
17 Aug 2009; Christian Faulhammer <fauli@gentoo.org> nxtvepg-2.8.0.ebuild:
install man pages in the correct location, fixes bug 246660
diff --git a/media-tv/nxtvepg/nxtvepg-2.8.1.ebuild b/media-tv/nxtvepg/nxtvepg-2.8.1.ebuild
new file mode 100644
index 000000000000..959f84cb606e
--- /dev/null
+++ b/media-tv/nxtvepg/nxtvepg-2.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.8.1.ebuild,v 1.1 2009/08/17 15:38:22 fauli Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="receive and browse free TV programme listings via bttv for tv networks in Europe"
+HOMEPAGE="http://nxtvepg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X unicode"
+
+RDEPEND="X? ( >=dev-lang/tcl-8.5
+ >=dev-lang/tk-8.5
+ x11-libs/libX11
+ x11-libs/libXmu )"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-kernel/linux-headers
+ X? ( x11-proto/xproto )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/nxtvepg-db.patch" || die "db patch failed"
+ epatch "${FILESDIR}/nxtvepg-daemon-install.patch" || die "daemon patch failed"
+ epatch "${FILESDIR}/nxtvepg-tcl8.5.patch" || die "tcl-8.5 patch failed"
+ use unicode && epatch "${FILESDIR}/nxtvepg-unicode.patch"
+}
+
+src_compile() {
+ if use X; then
+ emake -j1 CC=$(tc-getCC) prefix="/usr" mandir="/usr/share/man/man1"|| die "emake failed"
+ else
+ emake -j1 CC=$(tc-getCC) prefix="/usr" mandir="/usr/share/man/man1" daemon || die "emake failed"
+ fi
+}
+
+src_install() {
+ if use X; then
+ emake ROOT="${D}" prefix="/usr" mandir="${D}/usr/share/man/man1" install || die "emake install failed"
+ else
+ emake ROOT="${D}" prefix="/usr" mandir="${D}/usr/share/man/man1" install-daemon || die "emake install failed"
+ fi
+ dodoc README CHANGES TODO
+ dohtml manual*.html
+}