summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-06-01 17:08:25 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-06-01 17:08:25 +0000
commit2cd8bfb95316a608f906fad1cf6fcc8e32a27f4d (patch)
tree5d4c71686e1366cfa2e4212c080977c9e6a40a00 /media-tv/mythtv/mythtv-0.15.1.ebuild
parent (Manifest recommit) (diff)
downloadgentoo-2-2cd8bfb95316a608f906fad1cf6fcc8e32a27f4d.tar.gz
gentoo-2-2cd8bfb95316a608f906fad1cf6fcc8e32a27f4d.tar.bz2
gentoo-2-2cd8bfb95316a608f906fad1cf6fcc8e32a27f4d.zip
Version bump and cleanup.
Diffstat (limited to 'media-tv/mythtv/mythtv-0.15.1.ebuild')
-rw-r--r--media-tv/mythtv/mythtv-0.15.1.ebuild175
1 files changed, 175 insertions, 0 deletions
diff --git a/media-tv/mythtv/mythtv-0.15.1.ebuild b/media-tv/mythtv/mythtv-0.15.1.ebuild
new file mode 100644
index 000000000000..517834f0e35d
--- /dev/null
+++ b/media-tv/mythtv/mythtv-0.15.1.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.15.1.ebuild,v 1.1 2004/06/01 17:08:24 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Homebrew PVR project."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="alsa arts dvb directfb lcd lirc nvidia cle266 opengl"
+
+DEPEND=">=media-libs/freetype-2.0
+ >=media-sound/lame-3.93.1
+ >=x11-libs/qt-3.1
+ dev-db/mysql
+ >=media-tv/xmltv-0.5.34
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ >=sys-apps/sed-4
+ arts? ( kde-base/arts )
+ directfb? ( dev-libs/DirectFB )
+ dvb? ( media-libs/libdvb )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )
+ cle266? ( media-libs/libddmpeg )"
+
+RDEPEND="${DEPEND}
+ !media-tv/mythfrontend"
+
+pkg_setup() {
+ local qt_use="$(</var/db/pkg/`best_version x11-libs/qt`/USE)"
+ if [ ! "`has mysql ${qt_use}`" ] ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs MySQL support"
+ fi
+
+ return 0
+}
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ # Fix bugs 40964 and 42943.
+ filter-flags -fforce-addr -fPIC
+
+ if [ "${ARCH}" == "amd64" ]; then
+ sed -e "s:-march=pentiumpro::" -e "/DEFINES += MMX/d" -i settings.pro
+ else
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+ fi
+
+ if [ "`use alsa`" ] ; then
+ sed -e 's:#CONFIG += using_alsa:CONFIG += using_alsa:' \
+ -e 's:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:' \
+ -i 'settings.pro' || die "enable alsa sed failed"
+ fi
+ if [ "`use arts`" ] ; then
+ sed -e 's:artsc/artsc.h:artsc.h:' \
+ -i "libs/libmyth/audiooutputarts.h" || die "sed failed"
+ sed -e 's:#CONFIG += using_arts:CONFIG += using_arts:' \
+ -e 's:#ARTS_LIBS = .*:ARTS_LIBS = `artsc-config --libs`:' \
+ -e 's:#EXTRA_LIBS += -L/opt/.*:EXTRA_LIBS += `artsc-config --libs`:' \
+ -e 's:#INCLUDEPATH += /opt/.*:QMAKE_CXXFLAGS += `artsc-config --cflags`:' \
+ -i 'settings.pro' || die "enable arts sed failed"
+ fi
+ if [ "`use directfb`" ] ; then
+ sed -e 's:#CONFIG += using_directfb:CONFIG += using_directfb:' \
+ -e 's:#EXTRA_LIBS += `directfb:EXTRA_LIBS += `directfb:' \
+ -e 's:#QMAKE_CXXFLAGS += `directfb:QMAKE_CXXFLAGS += `directfb:' \
+ -i 'settings.pro' || die "enable arts sed failed"
+ fi
+ if [ "`use dvb`" ] ; then
+ sed -e 's:#CONFIG += using_dvb:CONFIG += using_dvb:' \
+ -e 's:#DEFINES += USING_DVB:DEFINES += USING_DVB:' \
+ -e 's:#INCLUDEPATH += /usr/src/.*:INCLUDEPATH += /usr/include:' \
+ -i 'settings.pro' || die "enable dvb sed failed"
+ fi
+ if [ "`use lcd`" ] ; then
+ sed -e 's:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:' \
+ -i 'settings.pro' || die "enable lcd sed failed"
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e 's:#CONFIG += using_lirc:CONFIG += using_lirc:' \
+ -e 's:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:' \
+ -i 'settings.pro' || die "enable lirc sed failed"
+ fi
+ if [ "`use nvidia`" ] ; then
+ sed -e 's:#CONFIG += using_xvmc:CONFIG += using_xvmc:' \
+ -e 's:#DEFINES += USING_XVMC:DEFINES += USING_XVMC:' \
+ -e 's:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:' \
+ -i 'settings.pro' || die "enable xvmc sed failed"
+ fi
+ if [ "`use cle266`" ] ; then
+ sed -e 's:#CONFIG += using_viahwslice:CONFIG += using_viahwslice:' \
+ -e 's:#DEFINES += USING_VIASLICE:DEFINES += USING_VIASLICE:' \
+ -e 's:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:' \
+ -i 'settings.pro' || die "enable lirc sed failed"
+ fi
+ if [ "`use opengl`" ] ; then
+ sed -e 's:#DEFINES += USING_OPENGL_VSYNC:DEFINES += USING_OPENGL_VSYNC:' \
+ -e 's:#EXTRA_LIBS += -lGL -lGLU:EXTRA_LIBS += -lGL -lGLU:' \
+ -i 'settings.pro' || die "enable opgenl sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ econf || die "econf failed"
+ emake -j1 || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ newbin "setup/setup" "mythsetup"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ insinto /usr/share/mythtv/database
+ doins database/*
+
+ exeinto /usr/share/mythtv
+ doexe "${FILESDIR}/mythfilldatabase.cron"
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/mythbackend.rc6" mythbackend
+ insinto /etc/conf.d
+ newins "${FILESDIR}/mythbackend.conf" mythbackend
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.{txt,pdf}
+ dohtml docs/*.html
+
+ keepdir /var/{log,run}/mythtv
+}
+
+pkg_postinst() {
+ ewarn "Please note that /usr/share/mythtv/setup has been moved"
+ ewarn "to /usr/bin/mythsetup"
+ echo
+
+ einfo "If this is the first time you install MythTV,"
+ einfo "you need to add /usr/share/mythtv/database/mc.sql"
+ einfo "to your mysql database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/mc.sql'"
+ einfo
+ einfo "Next, you need to run the mythsetup program."
+ einfo "It will ask you some questions about your hardware, and"
+ einfo "then run XMLTV's grabber to configure your channels."
+ einfo
+ einfo "Once you have configured your database, you can run"
+ einfo "/usr/bin/mythfilldatabase to populate the schedule"
+ einfo "or copy /usr/share/mythtv/mythfilldatabase.cron to"
+ einfo "/etc/cron.daily for this to happen automatically."
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ echo
+}