summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-06-28 16:54:01 +0000
committerDaniel Goller <morfic@gentoo.org>2004-06-28 16:54:01 +0000
commitd460804fd2a82dc2b6d3ff1627c6f60fb2db4649 (patch)
treebf17c7bb3883507bb349094ddbf5f8b05ce2c721 /media-tv/mythfrontend
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-d460804fd2a82dc2b6d3ff1627c6f60fb2db4649.tar.gz
gentoo-2-d460804fd2a82dc2b6d3ff1627c6f60fb2db4649.tar.bz2
gentoo-2-d460804fd2a82dc2b6d3ff1627c6f60fb2db4649.zip
Added patches to allow compiling with gcc-3.4
Diffstat (limited to 'media-tv/mythfrontend')
-rw-r--r--media-tv/mythfrontend/ChangeLog7
-rw-r--r--media-tv/mythfrontend/files/gcc-3.4-fix.patch39
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.15.1.ebuild11
3 files changed, 54 insertions, 3 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index aec2ba5adc2c..0d87891ca24c 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.18 2004/06/25 00:32:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.19 2004/06/28 16:54:01 morfic Exp $
+
+ 28 Jun 2004; Daniel Goller <morfic@gentoo.org> mythfrontend-0.15.1.ebuild:
+ Applied patch to allow compiling with gcc-3.4 conditionally
+ Patch thanks to Herbie Hopkins
+ This closes bug #52819
07 Jun 2004; Aron Griffis <agriffis@gentoo.org> mythfrontend-0.13.ebuild,
mythfrontend-0.14-r1.ebuild, mythfrontend-0.15.1.ebuild:
diff --git a/media-tv/mythfrontend/files/gcc-3.4-fix.patch b/media-tv/mythfrontend/files/gcc-3.4-fix.patch
new file mode 100644
index 000000000000..097177687318
--- /dev/null
+++ b/media-tv/mythfrontend/files/gcc-3.4-fix.patch
@@ -0,0 +1,39 @@
+diff -ur mythtv-0.15.1.orig/libs/libmythtv/fifowriter.cpp mythtv-0.15.1/libs/libmythtv/fifowriter.cpp
+--- mythtv-0.15.1.orig/libs/libmythtv/fifowriter.cpp 2004-06-02 21:06:54.427866608 +0100
++++ mythtv-0.15.1/libs/libmythtv/fifowriter.cpp 2004-06-02 21:08:37.942130048 +0100
+@@ -21,9 +21,9 @@
+ maxblksize = new long[count];
+ killwr = new int[count];
+ fbcount = new int[count];
+- fifo_buf = new (struct fifo_buf *)[count];
+- fb_inptr = new (struct fifo_buf *)[count];
+- fb_outptr = new (struct fifo_buf *)[count];
++ fifo_buf = new fifo_ptr[count];
++ fb_inptr = new fifo_ptr[count];
++ fb_outptr = new fifo_ptr[count];
+ fifothrds = new pthread_t[count];
+ fifo_lock = new pthread_mutex_t [count];
+ empty_cond = new pthread_cond_t[count];
+diff -ur mythtv-0.15.1.orig/libs/libmythtv/fifowriter.h mythtv-0.15.1/libs/libmythtv/fifowriter.h
+--- mythtv-0.15.1.orig/libs/libmythtv/fifowriter.h 2004-06-02 21:06:54.423867216 +0100
++++ mythtv-0.15.1/libs/libmythtv/fifowriter.h 2004-06-02 21:08:03.708334376 +0100
+@@ -29,6 +29,7 @@
+ long blksize;
+ } **fifo_buf, **fb_inptr, **fb_outptr;
+
++ typedef struct fifo_buf* fifo_ptr;
+ pthread_t *fifothrds;
+ pthread_mutex_t *fifo_lock;
+ pthread_cond_t *full_cond, *empty_cond;
+diff -ur mythtv-0.15.1.orig/settings.pro mythtv-0.15.1/settings.pro
+--- mythtv-0.15.1.orig/settings.pro 2004-06-02 21:06:54.474859464 +0100
++++ mythtv-0.15.1/settings.pro 2004-06-02 21:07:07.013953232 +0100
+@@ -14,7 +14,7 @@
+
+ release {
+ DEFINES += MMX
+- QMAKE_CXXFLAGS_RELEASE = -O3 -march=pentiumpro -fomit-frame-pointer
++ QMAKE_CXXFLAGS_RELEASE = -O3 -march=pentiumpro -fomit-frame-pointer -fpermissive
+ QMAKE_CFLAGS_RELEASE = $${QMAKE_CXXFLAGS_RELEASE}
+ }
+
diff --git a/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild b/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
index d10eb7ff3dd9..e7652f8610d2 100644
--- a/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild,v 1.4 2004/06/25 00:32:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.15.1.ebuild,v 1.5 2004/06/28 16:54:01 morfic Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils gcc
DESCRIPTION="Homebrew PVR project frontend."
HOMEPAGE="http://www.mythtv.org/"
@@ -63,6 +63,13 @@ src_unpack() {
done
use directfb && epatch ${FILESDIR}/mythtv-0.15-directfb.patch
+
+ #Applies patch for gcc-3.4.0 closing bug #52819
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/gcc-3.4-fix.patch
+ fi
+
}
src_compile() {