summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-10-16 19:32:55 +0000
committerSteve Dibb <beandog@gentoo.org>2007-10-16 19:32:55 +0000
commitbe9760bdd5706399b6d7e22e14dc82a382d5a79a (patch)
tree6fe040df07d959a6af903d3eadf7599c0a2c3e21 /media-tv/ivtv
parentAdded app-text poppler dependency (see #189203). (diff)
downloadgentoo-2-be9760bdd5706399b6d7e22e14dc82a382d5a79a.tar.gz
gentoo-2-be9760bdd5706399b6d7e22e14dc82a382d5a79a.tar.bz2
gentoo-2-be9760bdd5706399b6d7e22e14dc82a382d5a79a.zip
Version bump, add KMOD to kernel check
(Portage version: 2.1.3.12)
Diffstat (limited to 'media-tv/ivtv')
-rw-r--r--media-tv/ivtv/ChangeLog8
-rw-r--r--media-tv/ivtv/files/digest-ivtv-1.0.33
-rw-r--r--media-tv/ivtv/ivtv-1.0.1.ebuild8
-rw-r--r--media-tv/ivtv/ivtv-1.0.2.ebuild8
-rw-r--r--media-tv/ivtv/ivtv-1.0.3.ebuild138
5 files changed, 156 insertions, 9 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index 10373acce21b..caa28b2dd5de 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.94 2007/10/16 03:22:24 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.95 2007/10/16 19:32:54 beandog Exp $
+
+*ivtv-1.0.3 (16 Oct 2007)
+
+ 16 Oct 2007; Steve Dibb <beandog@gentoo.org> ivtv-1.0.1.ebuild,
+ ivtv-1.0.2.ebuild, +ivtv-1.0.3.ebuild:
+ Version bump, add KMOD to kernel check
*ivtv-0.10.6 (16 Oct 2007)
diff --git a/media-tv/ivtv/files/digest-ivtv-1.0.3 b/media-tv/ivtv/files/digest-ivtv-1.0.3
new file mode 100644
index 000000000000..1789b5d9c273
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-1.0.3
@@ -0,0 +1,3 @@
+MD5 2c0e04a861cb7409ea82a2935b1e0050 ivtv-1.0.3.tar.gz 290171
+RMD160 8893b2c33b2b870c7e9c5969dcf3e6346c9e5692 ivtv-1.0.3.tar.gz 290171
+SHA256 925083406a5bb6bb676e643b0c229eda722f5a1c36baf5526d7ee1c915e29e8d ivtv-1.0.3.tar.gz 290171
diff --git a/media-tv/ivtv/ivtv-1.0.1.ebuild b/media-tv/ivtv/ivtv-1.0.1.ebuild
index ecd73ec49b5f..7d2b234c6e32 100644
--- a/media-tv/ivtv/ivtv-1.0.1.ebuild
+++ b/media-tv/ivtv/ivtv-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.0.1.ebuild,v 1.6 2007/08/31 14:14:49 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.0.1.ebuild,v 1.7 2007/10/16 19:32:54 beandog Exp $
inherit eutils linux-mod
@@ -19,9 +19,9 @@ pkg_setup() {
MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
BUILD_TARGETS="all"
- CONFIG_CHECK="EXPERIMENTAL HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT VIDEO_DEV
- VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2 !VIDEO_HELPER_CHIPS_AUTO
- VIDEO_IVTV"
+ CONFIG_CHECK="EXPERIMENTAL KMOD HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
+ VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2
+ !VIDEO_HELPER_CHIPS_AUTO VIDEO_IVTV"
if use fbcon; then
MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
diff --git a/media-tv/ivtv/ivtv-1.0.2.ebuild b/media-tv/ivtv/ivtv-1.0.2.ebuild
index 2ff7fde5ae1f..82652fadc532 100644
--- a/media-tv/ivtv/ivtv-1.0.2.ebuild
+++ b/media-tv/ivtv/ivtv-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.0.2.ebuild,v 1.7 2007/09/12 20:26:00 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.0.2.ebuild,v 1.8 2007/10/16 19:32:54 beandog Exp $
inherit eutils linux-mod
@@ -19,9 +19,9 @@ pkg_setup() {
MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
BUILD_TARGETS="all"
- CONFIG_CHECK="EXPERIMENTAL HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT VIDEO_DEV
- VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2 !VIDEO_HELPER_CHIPS_AUTO
- VIDEO_IVTV"
+ CONFIG_CHECK="EXPERIMENTAL KMOD HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
+ VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2
+ !VIDEO_HELPER_CHIPS_AUTO VIDEO_IVTV"
if use fbcon; then
MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
diff --git a/media-tv/ivtv/ivtv-1.0.3.ebuild b/media-tv/ivtv/ivtv-1.0.3.ebuild
new file mode 100644
index 000000000000..78a26e0c7013
--- /dev/null
+++ b/media-tv/ivtv/ivtv-1.0.3.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.0.3.ebuild,v 1.1 2007/10/16 19:32:54 beandog Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org"
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.0.x/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="fbcon"
+RDEPEND="|| ( >=sys-fs/udev-103 sys-apps/hotplug )"
+DEPEND="app-arch/unzip"
+PDEPEND="=media-tv/pvr-firmware-20070217"
+
+pkg_setup() {
+
+ MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
+ BUILD_TARGETS="all"
+ CONFIG_CHECK="EXPERIMENTAL KMOD HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
+ VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2
+ !VIDEO_HELPER_CHIPS_AUTO VIDEO_IVTV"
+
+ if use fbcon; then
+ MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
+ CONFIG_CHECK="${CONFIG_CHECK} FB FB_TRIDENT FRAMEBUFFER_CONSOLE FONTS"
+ fi
+
+ if ! ( kernel_is 2 6 22 || kernel_is 2 6 23 ); then
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different ivtv driver"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
+ die "This only works on 2.6.22 and greater kernels"
+ fi
+
+ if use fbcon; then
+ ewarn ""
+ ewarn "From the README regarding framebuffer support:"
+ ewarn ""
+ ewarn "ivtv-fb now requires that you enable the following kernel config"
+ ewarn "options: Go to 'Device drivers -> Graphics support'. Enable"
+ ewarn "'Support for frame buffer devices'. Enable 'Trident support'"
+ ewarn "(the Trident module itself is not required)."
+ ewarn ""
+ ewarn "To get working console output, keep going to 'Console display"
+ ewarn "driver support', and enable 'Framebuffer Console support'."
+ ewarn "Enable 'Select compiled-in fonts' & once that's done, you should"
+ ewarn "have a list of fonts. Choose one. With the default OSD size,"
+ ewarn "'VGA 8x16' gives 80x30(PAL) 80x25(NTSC)."
+ ewarn ""
+ ewarn "This ebuild checks for all the correct kernel config options for"
+ ewarn "framebuffer use with the exception of choosing a font. Be sure"
+ ewarn "to pick one yourself!"
+ ewarn ""
+ fi
+
+ ewarn ""
+ ewarn "Make sure that your I2C and V4L kernel drivers are loaded as"
+ ewarn "modules, and not compiled into the kernel, or IVTV will not"
+ ewarn "work."
+ ewarn ""
+
+ linux-mod_pkg_setup
+
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_compile() {
+
+ cd "${S}/driver"
+ linux-mod_src_compile || die "failed to build driver"
+
+ cd "${S}/utils"
+ emake INCDIR="${KV_DIR}/include" || die "failed to build utils "
+}
+
+src_install() {
+ cd "${S}/utils"
+ make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install utils"
+ dobin perl/*.pl
+
+ cd "${S}"
+ dodoc README* doc/* utils/README.X11 ChangeLog* utils/perl/README.ptune
+
+ cd "${S}/driver"
+ linux-mod_src_install || die "failed to install modules"
+}
+
+pkg_postinst() {
+
+ linux-mod_pkg_postinst
+
+ elog ""
+ elog "This version of the IVTV driver supports the following hardware:"
+ elog "Hauppauge WinTV PVR-250"
+ elog "Hauppauge WinTV PVR-350"
+ elog "Hauppauge WinTV PVR-150"
+ elog "Hauppauge WinTV PVR-500"
+ elog "AVerMedia M179"
+ elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
+ elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
+ elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
+ elog "Adaptec AVC-2410"
+ elog "Adaptec AVC-2010"
+ elog "Nagase Transgear 5000TV"
+ elog "AOpen VA2000MAX-STN6"
+ elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
+ elog "I/O Data GV-MVP/RX"
+ elog "I/O Data GV-MVP/RX2E"
+ elog "Gotview PCI DVD (preliminary support only)"
+ elog "Gotview PCI DVD2 Deluxe"
+ elog "Yuan MPC622"
+ elog ""
+ ewarn ""
+ ewarn "IMPORTANT: In case of problems first read this page:"
+ ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
+ ewarn ""
+ ewarn "If any of these conditions match your setup, you may want to look at the"
+ ewarn "README in /usr/share/doc/${PF}/"
+ ewarn ""
+ ewarn " - Using MythTV, a PVR-350 and the ivtv-fb module"
+ ewarn " - Using the ivtv X driver and the ivtv-fb module"
+ ewarn " - You want to manually build ivtv against v4l-dvb"
+ ewarn ""
+ ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
+ ewarn "proper use and debugging utilities."
+ ewarn "They are also located in /usr/share/doc/${PF}/"
+ ewarn ""
+ ewarn "For more information, see the IVTV driver homepage at:"
+ ewarn "http://www.ivtvdriver.org/"
+}