summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2006-11-28 03:30:17 +0000
committerSteve Dibb <beandog@gentoo.org>2006-11-28 03:30:17 +0000
commitb21b0573ea3d59b346d09aacd096fb394c31eb21 (patch)
treee9db687d933866c344bdaef10d3aacda2122faff /media-tv/ivtv
parentVersion bump. (diff)
downloadgentoo-2-b21b0573ea3d59b346d09aacd096fb394c31eb21.tar.gz
gentoo-2-b21b0573ea3d59b346d09aacd096fb394c31eb21.tar.bz2
gentoo-2-b21b0573ea3d59b346d09aacd096fb394c31eb21.zip
Add some documentation
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-tv/ivtv')
-rw-r--r--media-tv/ivtv/ChangeLog8
-rw-r--r--media-tv/ivtv/ivtv-0.4.5.ebuild18
-rw-r--r--media-tv/ivtv/ivtv-0.4.7.ebuild17
-rw-r--r--media-tv/ivtv/ivtv-0.6.3.ebuild17
-rw-r--r--media-tv/ivtv/ivtv-0.6.4.ebuild16
-rw-r--r--media-tv/ivtv/ivtv-0.7.0.ebuild16
-rw-r--r--media-tv/ivtv/ivtv-0.7.1.ebuild16
-rw-r--r--media-tv/ivtv/ivtv-0.8.0.ebuild16
-rw-r--r--media-tv/ivtv/ivtv-0.8.1.ebuild16
-rw-r--r--media-tv/ivtv/metadata.xml4
10 files changed, 135 insertions, 9 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index c4c5b06eb9a6..735f40bab5ef 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.58 2006/11/20 04:44:34 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.59 2006/11/28 03:30:17 beandog Exp $
+
+ 28 Nov 2006; Steve Dibb <beandog@gentoo.org> metadata.xml,
+ ivtv-0.4.5.ebuild, ivtv-0.4.7.ebuild, ivtv-0.6.3.ebuild,
+ ivtv-0.6.4.ebuild, ivtv-0.7.0.ebuild, ivtv-0.7.1.ebuild,
+ ivtv-0.8.0.ebuild, ivtv-0.8.1.ebuild:
+ Add some documentation
*ivtv-0.8.1 (20 Nov 2006)
diff --git a/media-tv/ivtv/ivtv-0.4.5.ebuild b/media-tv/ivtv/ivtv-0.4.5.ebuild
index fd5c4ff41db4..576c9681b484 100644
--- a/media-tv/ivtv/ivtv-0.4.5.ebuild
+++ b/media-tv/ivtv/ivtv-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.4.5.ebuild,v 1.4 2006/07/08 04:23:51 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.4.5.ebuild,v 1.5 2006/11/28 03:30:17 beandog Exp $
inherit eutils linux-mod
@@ -36,6 +36,22 @@ pkg_setup() {
ewarn "You must use 0.6.x with a 2.6.16 kernel. However the kernel is broken"
ewarn "with IVTV for a great number of people. Including the maintainer of"
ewarn "IVTV in Gentoo. Your best bet is to use a 2.6.15 kernel"
+ echo ""
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
+ echo ""
die "This does not work with kernel versions higher then 2.6.15"
fi
diff --git a/media-tv/ivtv/ivtv-0.4.7.ebuild b/media-tv/ivtv/ivtv-0.4.7.ebuild
index bba926070ee7..429fb46c69e9 100644
--- a/media-tv/ivtv/ivtv-0.4.7.ebuild
+++ b/media-tv/ivtv/ivtv-0.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.4.7.ebuild,v 1.2 2006/10/19 23:34:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.4.7.ebuild,v 1.3 2006/11/28 03:30:17 beandog Exp $
inherit eutils linux-mod
@@ -24,6 +24,21 @@ pkg_setup() {
MODULE_NAMES="ivtv(extra:${S}/driver)"
if kernel_is gt 2 6 15; then
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
+ echo ""
ewarn "You must use 0.6.x with a 2.6.16 kernel."
die "This does not work with kernel versions higher then 2.6.15"
fi
diff --git a/media-tv/ivtv/ivtv-0.6.3.ebuild b/media-tv/ivtv/ivtv-0.6.3.ebuild
index 89134e575c73..783bf32967e1 100644
--- a/media-tv/ivtv/ivtv-0.6.3.ebuild
+++ b/media-tv/ivtv/ivtv-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.6.3.ebuild,v 1.2 2006/07/08 04:23:51 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.6.3.ebuild,v 1.3 2006/11/28 03:30:17 beandog Exp $
inherit eutils linux-mod
@@ -36,6 +36,21 @@ pkg_setup() {
if kernel_is 2 6 16; then
CONFIG_CHECK="${CONFIG_CHECK} VIDEO_DECODER VIDEO_AUDIO_DECODER VIDEO_BT848"
else
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
+ echo ""
die "This only works on 2.6.16 kernels"
fi
diff --git a/media-tv/ivtv/ivtv-0.6.4.ebuild b/media-tv/ivtv/ivtv-0.6.4.ebuild
index 8c57ce66bd50..2953e1497f62 100644
--- a/media-tv/ivtv/ivtv-0.6.4.ebuild
+++ b/media-tv/ivtv/ivtv-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.6.4.ebuild,v 1.2 2006/10/19 23:34:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.6.4.ebuild,v 1.3 2006/11/28 03:30:17 beandog Exp $
inherit eutils linux-mod
@@ -27,6 +27,20 @@ pkg_setup() {
if kernel_is 2 6 16; then
CONFIG_CHECK="${CONFIG_CHECK} VIDEO_DECODER VIDEO_AUDIO_DECODER VIDEO_BT848"
else
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
die "This only works on 2.6.16 kernels"
fi
diff --git a/media-tv/ivtv/ivtv-0.7.0.ebuild b/media-tv/ivtv/ivtv-0.7.0.ebuild
index 02301cb9bb05..70c4637c16e5 100644
--- a/media-tv/ivtv/ivtv-0.7.0.ebuild
+++ b/media-tv/ivtv/ivtv-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.7.0.ebuild,v 1.4 2006/07/22 22:44:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.7.0.ebuild,v 1.5 2006/11/28 03:30:17 beandog Exp $
inherit eutils linux-mod
@@ -38,6 +38,20 @@ pkg_setup() {
CONFIG_CHECK="${CONFIG_CHECK} VIDEO_WM8775 VIDEO_MSP3400 VIDEO_CX25840 VIDEO_TUNER"
CONFIG_CHECK="${CONFIG_CHECK} VIDEO_SAA711X VIDEO_SAA7127 VIDEO_TVEEPROM"
else
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
die "This only works on 2.6.17 kernels"
fi
diff --git a/media-tv/ivtv/ivtv-0.7.1.ebuild b/media-tv/ivtv/ivtv-0.7.1.ebuild
index e8fcc21bc0ef..48070ce1a903 100644
--- a/media-tv/ivtv/ivtv-0.7.1.ebuild
+++ b/media-tv/ivtv/ivtv-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.7.1.ebuild,v 1.2 2006/11/07 01:21:57 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.7.1.ebuild,v 1.3 2006/11/28 03:30:17 beandog Exp $
inherit eutils linux-mod
@@ -29,6 +29,20 @@ pkg_setup() {
CONFIG_CHECK="${CONFIG_CHECK} VIDEO_WM8775 VIDEO_MSP3400 VIDEO_CX25840 VIDEO_TUNER"
CONFIG_CHECK="${CONFIG_CHECK} VIDEO_SAA711X VIDEO_SAA7127 VIDEO_TVEEPROM"
else
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
die "This only works on 2.6.17 kernels"
fi
diff --git a/media-tv/ivtv/ivtv-0.8.0.ebuild b/media-tv/ivtv/ivtv-0.8.0.ebuild
index a8f432e4ee2f..119ca85d3fc5 100644
--- a/media-tv/ivtv/ivtv-0.8.0.ebuild
+++ b/media-tv/ivtv/ivtv-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.8.0.ebuild,v 1.4 2006/11/11 20:20:33 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.8.0.ebuild,v 1.5 2006/11/28 03:30:17 beandog Exp $
inherit eutils linux-mod
@@ -28,6 +28,20 @@ pkg_setup() {
linux-mod_pkg_setup
if ! kernel_is 2 6 18; then
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
die "This only works on 2.6.18 kernels"
fi
diff --git a/media-tv/ivtv/ivtv-0.8.1.ebuild b/media-tv/ivtv/ivtv-0.8.1.ebuild
index bd503102342f..e39bfb803495 100644
--- a/media-tv/ivtv/ivtv-0.8.1.ebuild
+++ b/media-tv/ivtv/ivtv-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.8.1.ebuild,v 1.1 2006/11/20 04:44:34 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.8.1.ebuild,v 1.2 2006/11/28 03:30:17 beandog Exp $
inherit eutils linux-mod
@@ -28,6 +28,20 @@ pkg_setup() {
linux-mod_pkg_setup
if ! kernel_is 2 6 18; then
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
die "This only works on 2.6.18 kernels"
fi
diff --git a/media-tv/ivtv/metadata.xml b/media-tv/ivtv/metadata.xml
index db375cd34450..f455b51a8685 100644
--- a/media-tv/ivtv/metadata.xml
+++ b/media-tv/ivtv/metadata.xml
@@ -7,6 +7,10 @@
<email>cardoe@gentoo.org</email>
<name>Doug Goldstein</name>
</maintainer>
+ <maintainer>
+ <email>beandog@gentoo.org</email>
+ <name>Steve Dibb</name>
+ </maintainer>
<longdescription>
Driver for ivtv based tv tuner cards, currently supports Hauppauge
PVR-[23]50 cards