summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-22 10:52:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-22 10:52:39 +0000
commitfed5ede3b9f6470047d9f6075d4fba00f4dcf192 (patch)
treedcfce150d3ae11bc1ba46a9f3707cdfa52af5d26 /media-sound
parent* bump (diff)
downloadgentoo-2-fed5ede3b9f6470047d9f6075d4fba00f4dcf192.tar.gz
gentoo-2-fed5ede3b9f6470047d9f6075d4fba00f4dcf192.tar.bz2
gentoo-2-fed5ede3b9f6470047d9f6075d4fba00f4dcf192.zip
Resume with the doubled ebuild for pulseaudio: -r0 to -r49 will keep the ebuilds without systemwide support, -r50 to -r99 will have it. The reason for this is that the systemwide support requires OpenRC, which we won't have stable anytime soon. Still, it requires libtool 2.2, so...
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio/ChangeLog13
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.15-r1.ebuild153
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.15-r50.ebuild (renamed from media-sound/pulseaudio/pulseaudio-0.9.15.ebuild)2
3 files changed, 166 insertions, 2 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index d01d710432d6..032c97b6209f 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.130 2009/06/19 20:33:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.131 2009/06/22 10:52:39 flameeyes Exp $
+
+*pulseaudio-0.9.15-r50 (22 Jun 2009)
+*pulseaudio-0.9.15-r1 (22 Jun 2009)
+
+ 22 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ -pulseaudio-0.9.15.ebuild, +pulseaudio-0.9.15-r1.ebuild,
+ +pulseaudio-0.9.15-r50.ebuild:
+ Resume with the doubled ebuild for pulseaudio: -r0 to -r49 will keep the
+ ebuilds without systemwide support, -r50 to -r99 will have it. The reason
+ for this is that the systemwide support requires OpenRC, which we won't
+ have stable anytime soon. Still, it requires libtool 2.2, so...
19 Jun 2009; Alexis Ballier <aballier@gentoo.org>
pulseaudio-0.9.15.ebuild, +files/pulseaudio-0.9.15-bsd.patch:
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.15-r1.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.15-r1.ebuild
new file mode 100644
index 000000000000..f43f6698fe74
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-0.9.15-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.15-r1.ebuild,v 1.1 2009/06/22 10:52:39 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils libtool flag-o-matic
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="http://www.pulseaudio.org/"
+if [[ ${PV/_rc/} == ${PV} ]]; then
+ SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+else
+ SRC_URI="http://0pointer.de/public/${P/_rc/-test}.tar.gz"
+fi
+
+S="${WORKDIR}/${P/_rc/-test}"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="alsa avahi caps jack lirc oss tcpd X hal dbus libsamplerate gnome bluetooth policykit asyncns +glib test"
+
+RDEPEND="X? ( x11-libs/libX11 x11-libs/libSM x11-libs/libICE x11-libs/libXtst )
+ caps? ( sys-libs/libcap )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.1-r1 )
+ alsa? ( >=media-libs/alsa-lib-1.0.19 )
+ glib? ( >=dev-libs/glib-2.4.0 )
+ avahi? ( >=net-dns/avahi-0.6.12[dbus] )
+ >=dev-libs/liboil-0.3.0
+ jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ lirc? ( app-misc/lirc )
+ dbus? ( >=sys-apps/dbus-1.0.0 )
+ gnome? ( >=gnome-base/gconf-2.4.0 )
+ hal? (
+ >=sys-apps/hal-0.5.7
+ >=sys-apps/dbus-1.0.0
+ )
+ app-admin/eselect-esd
+ bluetooth? (
+ || ( >=net-wireless/bluez-4
+ >=net-wireless/bluez-libs-3 )
+ >=sys-apps/dbus-1.0.0
+ )
+ policykit? ( sys-auth/policykit )
+ asyncns? ( net-libs/libasyncns )
+ >=media-libs/audiofile-0.2.6-r1
+ >=media-libs/speex-1.2_beta
+ >=media-libs/libsndfile-1.0.10
+ >=dev-libs/liboil-0.3.6
+ sys-libs/gdbm
+ >=sys-devel/libtool-2.2.4" # it's a valid RDEPEND, libltdl.so is used
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+ dev-libs/libatomic_ops
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+RDEPEND="${RDEPEND}
+ gnome-extra/gnome-audio"
+
+pkg_setup() {
+ enewgroup audio 18 # Just make sure it exists
+ enewgroup realtime
+ enewgroup pulse-access
+ enewgroup pulse
+ enewuser pulse -1 -1 /var/run/pulse pulse,audio
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-bsd.patch"
+ elibtoolize
+}
+
+src_configure() {
+ # To properly fix CVE-2008-0008
+ append-flags -UNDEBUG
+
+ append-ldflags -Wl,--no-as-needed
+
+ econf \
+ --enable-largefile \
+ $(use_enable glib glib2) \
+ --disable-solaris \
+ $(use_enable asyncns) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable lirc) \
+ $(use_enable tcpd tcpwrap) \
+ $(use_enable jack) \
+ $(use_enable lirc) \
+ $(use_enable avahi) \
+ $(use_enable hal) \
+ $(use_enable dbus) \
+ $(use_enable gnome gconf) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable bluetooth bluez) \
+ $(use_enable policykit polkit) \
+ $(use_enable X x11) \
+ $(use_enable test default-build-tests) \
+ $(use_with caps) \
+ --localstatedir=/var \
+ --with-realtime-group=realtime \
+ --disable-per-user-esound-socket \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ use avahi && sed -i -e '/module-zeroconf-publish/s:^#::' "${D}/etc/pulse/default.pa"
+
+ dohtml -r doc
+ dodoc README
+
+ # Create the state directory
+ diropts -o pulse -g pulse -m0755
+ keepdir /var/run/pulse
+
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ elog "If you want to make use of realtime capabilities of PulseAudio"
+ elog "you should follow the realtime guide to create and set up a realtime"
+ elog "user group: http://www.gentoo.org/proj/en/desktop/sound/realtime.xml"
+ elog "Make sure you also have baselayout installed with pam USE flag"
+ elog "enabled, if you're using the rlimit method."
+ if use bluetooth; then
+ elog
+ elog "The BlueTooth proximity module is not enabled in the default"
+ elog "configuration file. If you do enable it, you'll have to have"
+ elog "your BlueTooth controller enabled and inserted at bootup or"
+ elog "PulseAudio will refuse to start."
+ elog
+ elog "Please note that the BlueTooth proximity module seems itself"
+ elog "still experimental, so please report to upstream if you have"
+ elog "problems with it."
+ fi
+ if use alsa; then
+ local pkg="media-plugins/alsa-plugins"
+ if has_version ${pkg} && ! built_with_use --missing false ${pkg} pulseaudio; then
+ elog
+ elog "You have alsa support enabled so you probably want to install"
+ elog "${pkg} with pulseaudio support to have"
+ elog "alsa using applications route their sound through pulseaudio"
+ fi
+ fi
+
+ eselect esd update --if-unset
+}
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.15.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.15-r50.ebuild
index aa53426863d1..91cc867b4da0 100644
--- a/media-sound/pulseaudio/pulseaudio-0.9.15.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-0.9.15-r50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.15.ebuild,v 1.7 2009/06/19 20:33:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.15-r50.ebuild,v 1.1 2009/06/22 10:52:39 flameeyes Exp $
EAPI=2