summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-30 13:45:08 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-30 13:45:08 +0000
commite22c74cdc24cb195e6da706b917310b4b130cc3b (patch)
tree997daaa66dd0fa7bc6d78ba30cfecc537628674c /media-sound
parentStable on alpha + ia64. (diff)
downloadgentoo-2-e22c74cdc24cb195e6da706b917310b4b130cc3b.tar.gz
gentoo-2-e22c74cdc24cb195e6da706b917310b4b130cc3b.tar.bz2
gentoo-2-e22c74cdc24cb195e6da706b917310b4b130cc3b.zip
Add patch from upstream to fix using capabilities.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio/ChangeLog8
-rw-r--r--media-sound/pulseaudio/files/digest-pulseaudio-0.9.4-r13
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-0.9.4-r1170.patch22
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.4-r1.ebuild113
4 files changed, 145 insertions, 1 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index ae7f502b6ed2..91a7446aba11 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.19 2006/07/29 15:34:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.20 2006/07/30 13:45:08 flameeyes Exp $
+
+*pulseaudio-0.9.4-r1 (30 Jul 2006)
+
+ 30 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pulseaudio-0.9.4-r1170.patch, +pulseaudio-0.9.4-r1.ebuild:
+ Add patch from upstream to fix using capabilities.
29 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
files/pulseaudio.init.d-2, files/pulseaudio.conf.d,
diff --git a/media-sound/pulseaudio/files/digest-pulseaudio-0.9.4-r1 b/media-sound/pulseaudio/files/digest-pulseaudio-0.9.4-r1
new file mode 100644
index 000000000000..2a357881d328
--- /dev/null
+++ b/media-sound/pulseaudio/files/digest-pulseaudio-0.9.4-r1
@@ -0,0 +1,3 @@
+MD5 aadbbc68306653f9052872c11e0cc707 pulseaudio-0.9.4.tar.gz 1111744
+RMD160 5a5f270ed9e2ec5ebc89e9592eb19cc6d8450e8b pulseaudio-0.9.4.tar.gz 1111744
+SHA256 2e3f7e7d7177a6383acbe624bdb29d110459ac3c9d4a5ef07531836507a519fd pulseaudio-0.9.4.tar.gz 1111744
diff --git a/media-sound/pulseaudio/files/pulseaudio-0.9.4-r1170.patch b/media-sound/pulseaudio/files/pulseaudio-0.9.4-r1170.patch
new file mode 100644
index 000000000000..03f7fac3fa72
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-0.9.4-r1170.patch
@@ -0,0 +1,22 @@
+Index: src/daemon/caps.c
+===================================================================
+--- src/daemon/caps.c (revision 1169)
++++ src/daemon/caps.c (revision 1170)
+@@ -82,7 +82,7 @@
+ cap_value_t nice_cap = CAP_SYS_NICE;
+
+ /* Only drop caps when called SUID */
+- if (getuid() != 0)
++ if (getuid() == 0)
+ return 0;
+
+ caps = cap_init();
+@@ -112,7 +112,7 @@
+ int r = -1;
+
+ /* Only drop caps when called SUID */
+- if (getuid() != 0)
++ if (getuid() == 0)
+ return 0;
+
+ caps = cap_init();
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.4-r1.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..0e6a083bb7aa
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-0.9.4-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.4-r1.ebuild,v 1.1 2006/07/30 13:45:08 flameeyes Exp $
+
+inherit eutils libtool # autotools
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="http://0pointer.de/lennart/projects/pulseaudio/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86-fbsd ~x86"
+
+IUSE="alsa avahi caps jack lirc oss tcpd X"
+
+RDEPEND="X? ( || ( x11-libs/libX11 <virtual/x11-7 ) )
+ caps? ( sys-libs/libcap )
+ >=media-libs/audiofile-0.2.6-r1
+ >=media-libs/libsamplerate-0.1.1-r1
+ >=media-libs/libsndfile-1.0.10
+ >=dev-libs/liboil-0.3.6
+ alsa? ( >=media-libs/alsa-lib-1.0.10 )
+ >=dev-libs/glib-2.4.0
+ avahi? ( >=net-dns/avahi-0.6.12 )
+ >=dev-libs/liboil-0.3.0
+ jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ lirc? ( app-misc/lirc )
+ app-admin/eselect-esd"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use avahi && ! built_with_use net-dns/avahi dbus ; then
+ echo
+ eerror "In order to compile pulseaudio with avahi support, you need to have"
+ eerror "net-dns/avahi emerged with 'dbus' in your USE flag. Please add that"
+ eerror "flag, re-emerge avahi, and then emerge pulseaudio again."
+ die "net-dns/avahi is missing the D-Bus bindings."
+ fi
+
+ enewgroup audio 18 # Just make sure it exists
+ enewgroup pulse-access
+ enewgroup pulse
+ enewuser pulse -1 -1 /var/run/pulse pulse,audio
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.9.2-esdcompat.patch"
+ # Fix working with caps
+ epatch "${FILESDIR}/${P}-r1170.patch"
+
+ # eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --enable-largefile \
+ --enable-glib2 \
+ --disable-solaris \
+ --disable-asyncns \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable lirc) \
+ $(use_enable tcpd tcpwrap) \
+ $(use_enable jack) \
+ $(use_enable lirc) \
+ $(use_enable avahi) \
+ $(use_with caps) \
+ $(use_with X x) \
+ --disable-ltdl-install \
+ --localstatedir=/var \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ newconfd "${FILESDIR}/pulseaudio.conf.d" pulseaudio
+
+ local extradepend
+ use alsa && extradepend="$extradepend alsasound"
+ use avahi && extradepend="$extradepend avahi"
+ sed -e "s/@extradepend@/$extradepend/" "${FILESDIR}/pulseaudio.init.d-2" > "${T}/pulseaudio"
+ doinitd "${T}/pulseaudio"
+
+ dohtml -r doc
+ dodoc README
+
+ # Create the state directory
+ diropts -o pulse -g pulse -m0755
+ keepdir /var/run/pulse
+}
+
+pkg_postinst() {
+ elog "PulseAudio in Gentoo can use a system-wide pulseaudio daemon."
+ elog "This support is enabled by starting the pulsedaemon init.d ."
+ elog "To be able to access that you need to be in the group pulse-access."
+ elog "For more information about system-wide support, please refer to"
+ elog " http://pulseaudio.org/wiki/SystemWideInstance"
+
+ elog "To use the ESounD wrapper while using a system-wide daemon, you also"
+ elog "need to enable auth-anonymous for the esound-unix module, or to copy"
+ elog "/var/run/pulse/.esd_auth into each home directory."
+
+ eselect esd update --if-unset
+}