summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-02-16 19:34:57 +0000
committerJeroen Roovers <jer@gentoo.org>2015-02-16 19:34:57 +0000
commitcf6bfc23ab4e09e7c9d1f41221f2ab051ea66c52 (patch)
tree5e0504fc223fd3e97fc339dc5fc63cedc6d2e8cf /media-sound
parentbup (diff)
downloadgentoo-2-cf6bfc23ab4e09e7c9d1f41221f2ab051ea66c52.tar.gz
gentoo-2-cf6bfc23ab4e09e7c9d1f41221f2ab051ea66c52.tar.bz2
gentoo-2-cf6bfc23ab4e09e7c9d1f41221f2ab051ea66c52.zip
Remove the real real big bad hack (possibly bug #540304).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fmdrv/ChangeLog8
-rw-r--r--media-sound/fmdrv/files/fmdrv-1.0.7-ioperm.patch20
-rw-r--r--media-sound/fmdrv/fmdrv-1.0.7.ebuild16
3 files changed, 37 insertions, 7 deletions
diff --git a/media-sound/fmdrv/ChangeLog b/media-sound/fmdrv/ChangeLog
index d5fe77bf2a5e..e38211da7e2c 100644
--- a/media-sound/fmdrv/ChangeLog
+++ b/media-sound/fmdrv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/fmdrv
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fmdrv/ChangeLog,v 1.10 2013/02/02 18:52:06 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fmdrv/ChangeLog,v 1.11 2015/02/16 19:34:57 jer Exp $
+
+ 16 Feb 2015; Jeroen Roovers <jer@gentoo.org> fmdrv-1.0.7.ebuild,
+ +files/fmdrv-1.0.7-ioperm.patch:
+ Remove the real real big bad hack (possibly bug #540304).
02 Feb 2013; Ulrich Müller <ulm@gentoo.org> fmdrv-1.0.7.ebuild:
Fix LICENSE, see README.html, bug 453184.
diff --git a/media-sound/fmdrv/files/fmdrv-1.0.7-ioperm.patch b/media-sound/fmdrv/files/fmdrv-1.0.7-ioperm.patch
new file mode 100644
index 000000000000..ef719a4ac546
--- /dev/null
+++ b/media-sound/fmdrv/files/fmdrv-1.0.7-ioperm.patch
@@ -0,0 +1,20 @@
+--- a/sysdeps.c
++++ b/sysdeps.c
+@@ -1,17 +1,7 @@
+ #include "sysdeps.h"
+
+ #ifdef linux
+-/* A real real big bad hack. *
+- * Never try this at home! */
+-# define extern static
+-# if 0 /* This is required on older Linux versions, not anymore */
+-# include <asm/io.h>
+-# undef extern
+ # include <sys/io.h>
+-# else
+-# include <sys/io.h>
+-# undef extern
+-# endif
+ # define inportb(x) inb(x)
+ # define outportb(p,x) outb(x,p)
+ #endif
diff --git a/media-sound/fmdrv/fmdrv-1.0.7.ebuild b/media-sound/fmdrv/fmdrv-1.0.7.ebuild
index b507f5d31ddc..375b5d7a6c94 100644
--- a/media-sound/fmdrv/fmdrv-1.0.7.ebuild
+++ b/media-sound/fmdrv/fmdrv-1.0.7.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fmdrv/fmdrv-1.0.7.ebuild,v 1.9 2013/02/02 18:52:06 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fmdrv/fmdrv-1.0.7.ebuild,v 1.10 2015/02/16 19:34:57 jer Exp $
-inherit toolchain-funcs
+EAPI=5
+inherit eutils toolchain-funcs
DESCRIPTION="Console mode MIDI player with builtin userland OPL2 driver"
HOMEPAGE="http://bisqwit.iki.fi/source/fmdrv.html"
@@ -11,13 +12,18 @@ SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
LICENSE="fmdrv GPL-2" # GPL-2 only
SLOT="0"
KEYWORDS="x86 amd64"
-IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ioperm.patch
+}
+
+src_configure() { :; } # it is a fake
src_compile() {
emake fmdrv \
CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}" || die
+ LDFLAGS="${LDFLAGS}"
}
src_install() {