summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-02 09:43:20 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-02 09:43:20 +0000
commitc623c7abca7e46c8431c7bda3fa2040605656433 (patch)
treebb65dd7d144afab185a8480185b5a48c0d85f385 /media-sound
parentRemove the /var/run/sphinx directory since it is not actually used and now pr... (diff)
downloadgentoo-2-c623c7abca7e46c8431c7bda3fa2040605656433.tar.gz
gentoo-2-c623c7abca7e46c8431c7bda3fa2040605656433.tar.bz2
gentoo-2-c623c7abca7e46c8431c7bda3fa2040605656433.zip
Version bump.
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/giada/ChangeLog7
-rw-r--r--media-sound/giada/giada-0.6.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/media-sound/giada/ChangeLog b/media-sound/giada/ChangeLog
index 310a2af1d3a8..0a8ba5c87585 100644
--- a/media-sound/giada/ChangeLog
+++ b/media-sound/giada/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/giada
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/ChangeLog,v 1.4 2013/02/07 05:08:51 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/ChangeLog,v 1.5 2013/03/02 09:43:20 radhermit Exp $
+
+*giada-0.6.0 (02 Mar 2013)
+
+ 02 Mar 2013; Tim Harder <radhermit@gentoo.org> +giada-0.6.0.ebuild:
+ Version bump.
*giada-0.5.8 (07 Feb 2013)
diff --git a/media-sound/giada/giada-0.6.0.ebuild b/media-sound/giada/giada-0.6.0.ebuild
new file mode 100644
index 000000000000..6526194763d3
--- /dev/null
+++ b/media-sound/giada/giada-0.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/giada/giada-0.6.0.ebuild,v 1.1 2013/03/02 09:43:20 radhermit Exp $
+
+EAPI=5
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="A free, minimal, hardcore audio tool for djs and live performers"
+HOMEPAGE="http://www.giadamusic.com/"
+SRC_URI="http://www.giadamusic.com/download-action.php?os=source&version=${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack pulseaudio"
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+RDEPEND="media-libs/libsndfile
+ media-libs/libsamplerate
+ media-libs/rtaudio[alsa?,jack?,pulseaudio?]
+ x11-libs/fltk:1
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.4-flags.patch
+ epatch "${FILESDIR}"/${PN}-0.5.8-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -I/usr/include/fltk-1
+ append-ldflags -L/usr/$(get_libdir)/fltk-1
+
+ econf \
+ --target=linux \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable pulseaudio pulse)
+}