summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2014-12-13 06:43:36 +0000
committerBen de Groot <yngwin@gentoo.org>2014-12-13 06:43:36 +0000
commit8445b385fe6380cfbcd938e722f45495d1a5cb3a (patch)
tree281bc679561fe1f7c0fca71977c77f6415392f86 /media-sound
parentmigrate the live ebuild to git instead of mercurial to follow upstream (diff)
downloadgentoo-2-8445b385fe6380cfbcd938e722f45495d1a5cb3a.tar.gz
gentoo-2-8445b385fe6380cfbcd938e722f45495d1a5cb3a.tar.bz2
gentoo-2-8445b385fe6380cfbcd938e722f45495d1a5cb3a.zip
lazy version bump (still needs distutils-r1 conversion and fix for bug #403629)
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x0F9C590B7FF324F6!)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/picard/ChangeLog10
-rw-r--r--media-sound/picard/picard-1.3.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/media-sound/picard/ChangeLog b/media-sound/picard/ChangeLog
index 4a9437074a5c..f0343337fc97 100644
--- a/media-sound/picard/ChangeLog
+++ b/media-sound/picard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/picard
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.46 2013/11/03 09:56:29 yngwin Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.47 2014/12/13 06:43:36 yngwin Exp $
+
+*picard-1.3 (13 Dec 2014)
+
+ 13 Dec 2014; Ben de Groot <yngwin@gentoo.org> +picard-1.3.ebuild:
+ lazy version bump (still needs distutils-r1 conversion and fix for bug
+ #403629)
*picard-1.2-r1 (03 Nov 2013)
diff --git a/media-sound/picard/picard-1.3.ebuild b/media-sound/picard/picard-1.3.ebuild
new file mode 100644
index 000000000000..7d28735794af
--- /dev/null
+++ b/media-sound/picard/picard-1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/picard-1.3.ebuild,v 1.1 2014/12/13 06:43:36 yngwin Exp $
+
+EAPI=5
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.6 3.*"
+inherit eutils distutils
+
+MY_P="${P/_/}"
+DESCRIPTION="An improved rewrite/port of the Picard Tagger using Qt"
+HOMEPAGE="http://musicbrainz.org/doc/PicardQt"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acoustid +cdda nls"
+
+DEPEND="dev-python/PyQt4[X]
+ media-libs/mutagen
+ acoustid? ( >=media-libs/chromaprint-1.0[tools] )
+ cdda? ( >=media-libs/libdiscid-0.1.1 )"
+RDEPEND="${DEPEND}"
+
+# doesn't work with ebuilds
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+DOCS="AUTHORS.txt NEWS.txt"
+
+src_compile() {
+ distutils_src_compile $(use nls || echo "--disable-locales")
+}
+
+src_install() {
+ distutils_src_install --disable-autoupdate --skip-build \
+ $(use nls || echo "--disable-locales")
+
+ doicon picard.ico
+ domenu picard.desktop
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ echo
+ ewarn "If you are upgrading Picard and it does not start"
+ ewarn "try removing Picard's settings:"
+ ewarn " rm ~/.config/MusicBrainz/Picard.conf"
+ elog
+ elog "You should set the environment variable BROWSER to something like"
+ elog "\"firefox '%s' &\" to let python know which browser to use."
+}