summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-06-26 18:24:07 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-06-26 18:24:07 +0000
commit7f5eb9783a990e5854231c2acf12f6f4c93a901d (patch)
treee86ea4aaed2ece972598491e1cd358ba5b10f704 /media-sound
parentRemove non-existing all_fakegem_prepare. Document some unexpected things. Add... (diff)
downloadgentoo-2-7f5eb9783a990e5854231c2acf12f6f4c93a901d.tar.gz
gentoo-2-7f5eb9783a990e5854231c2acf12f6f4c93a901d.tar.bz2
gentoo-2-7f5eb9783a990e5854231c2acf12f6f4c93a901d.zip
Fix compilation with gcc-4.7. Bug #423221
(Portage version: 2.1.11/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lastfmplayer/ChangeLog8
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-gcc47.patch50
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r2.ebuild4
3 files changed, 59 insertions, 3 deletions
diff --git a/media-sound/lastfmplayer/ChangeLog b/media-sound/lastfmplayer/ChangeLog
index f83f02eed14f..d4049242c179 100644
--- a/media-sound/lastfmplayer/ChangeLog
+++ b/media-sound/lastfmplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lastfmplayer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.67 2012/04/25 15:20:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.68 2012/06/26 18:24:07 hwoarang Exp $
+
+ 26 Jun 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/lastfmplayer-1.5.4.27091-gcc47.patch,
+ lastfmplayer-1.5.4.27091-r2.ebuild:
+ Fix compilation with gcc-4.7. Bug #423221
25 Apr 2012; Justin Lecher <jlec@gentoo.org>
lastfmplayer-1.5.4.27091-r2.ebuild,
@@ -344,4 +349,3 @@
02 Apr 2006; Stefan Schweizer <genstef@gentoo.org> +metadata.xml,
+lastfmplayer-1.1.4_p2099.ebuild:
New ebuild thanks to David Li <matrixhax0r@yahoo.com> in bug 102059
-
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-gcc47.patch b/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-gcc47.patch
new file mode 100644
index 000000000000..5a6009b21859
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-gcc47.patch
@@ -0,0 +1,50 @@
+Description: Fix compilation with gcc 4.7
+Author: John Stamp <jstamp@users.sourceforge.net>
+http://bugs.debian.org/667236
+https://bugs.gentoo.org/show_bug.cgi?id=423221
+--- a/src/libUnicorn/UnicornCommon.cpp
++++ b/src/libUnicorn/UnicornCommon.cpp
+@@ -32,6 +32,8 @@
+ #ifdef WIN32
+ #include <windows.h>
+ #include <shlobj.h>
++#else
++ #include <unistd.h>
+ #endif
+
+ using namespace std;
+--- a/src/lastfmapplication.cpp
++++ b/src/lastfmapplication.cpp
+@@ -59,6 +59,8 @@
+
+ #ifdef WIN32
+ #include <windows.h>
++#else
++ #include <unistd.h>
+ #endif
+
+ #ifdef Q_WS_MAC
+--- a/src/libUnicorn/Settings.h
++++ b/src/libUnicorn/Settings.h
+@@ -105,7 +105,7 @@
+ public:
+ MyQSettings( const UserSettings* const s )
+ {
+- beginGroup( s->username() );
++ this->beginGroup( s->username() );
+ }
+ };
+
+--- a/src/playerlistener.cpp
++++ b/src/playerlistener.cpp
+@@ -33,6 +33,10 @@
+ #include <iostream>
+ #include <algorithm>
+
++#ifdef Q_OS_UNIX
++ #include <unistd.h>
++#endif
++
+ using namespace std;
+
+
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r2.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r2.ebuild
index 49ae384b6635..638c3f084720 100644
--- a/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r2.ebuild
+++ b/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r2.ebuild,v 1.2 2012/04/25 15:20:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r2.ebuild,v 1.3 2012/06/26 18:24:07 hwoarang Exp $
EAPI=2
inherit eutils multilib toolchain-funcs qt4-r2
@@ -56,6 +56,8 @@ src_prepare() {
# only glib.h can be included directly in >glib-2.32
epatch "${FILESDIR}"/${P}-glib.h.patch
+ # Gcc 4.7 definitions. Bug #423221
+ epatch "${FILESDIR}"/${P}-gcc47.patch
}
src_configure() {