summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-21 23:35:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-21 23:35:34 +0000
commit76fa26b15a76eb09079dd07f78565633774beb53 (patch)
treefe73909fa70a5d5afc59f674cab78f23c9b3d554 /media-sound
parentStable on amd64. (diff)
downloadgentoo-2-76fa26b15a76eb09079dd07f78565633774beb53.tar.gz
gentoo-2-76fa26b15a76eb09079dd07f78565633774beb53.tar.bz2
gentoo-2-76fa26b15a76eb09079dd07f78565633774beb53.zip
Add patch for kid3 to build with tunepimp 0.4.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/kid3/ChangeLog8
-rw-r--r--media-sound/kid3/files/digest-kid3-0.62
-rw-r--r--media-sound/kid3/files/kid3-0.6-tunepimp04.patch47
-rw-r--r--media-sound/kid3/kid3-0.6.ebuild12
4 files changed, 65 insertions, 4 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index 1d1fd5f4f767..0156492f5a49 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kid3
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.17 2005/11/06 16:53:05 greg_g Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.18 2006/05/21 23:35:34 flameeyes Exp $
+
+ 21 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kid3-0.6-tunepimp04.patch, kid3-0.6.ebuild:
+ Add patch for kid3 to build with tunepimp 0.4.
06 Nov 2005; Gregorio Guidi <greg_g@gentoo.org> kid3-0.6.ebuild:
Forcing KDE support on, as kid3 cannot be configured without having the KDE
diff --git a/media-sound/kid3/files/digest-kid3-0.6 b/media-sound/kid3/files/digest-kid3-0.6
index 1586cab29cc1..d80bd2ff9bcb 100644
--- a/media-sound/kid3/files/digest-kid3-0.6
+++ b/media-sound/kid3/files/digest-kid3-0.6
@@ -1 +1,3 @@
MD5 945992608a29b692284db2c80e1217bd kid3-0.6.tar.gz 863350
+RMD160 8bcec5444a0fe6e6e0009836bfc0e6b90cf5c38a kid3-0.6.tar.gz 863350
+SHA256 b8d1b928f55444ad1f587a8afcf2566feefd52737acebeb91dee00fd39587265 kid3-0.6.tar.gz 863350
diff --git a/media-sound/kid3/files/kid3-0.6-tunepimp04.patch b/media-sound/kid3/files/kid3-0.6-tunepimp04.patch
new file mode 100644
index 000000000000..4a3f4b2bf4bf
--- /dev/null
+++ b/media-sound/kid3/files/kid3-0.6-tunepimp04.patch
@@ -0,0 +1,47 @@
+Index: kid3-0.6/kid3/musicbrainzclient.cpp
+===================================================================
+--- kid3-0.6.orig/kid3/musicbrainzclient.cpp
++++ kid3-0.6/kid3/musicbrainzclient.cpp
+@@ -30,7 +30,7 @@ MusicBrainzClient::MusicBrainzClient(Imp
+ m_trackDataVector(trackDataList), m_tp(0), m_ids(0), m_numFiles(0)
+ {
+ m_tp = tp_New("kid3", "0.6");
+- tp_SetUseUTF8(m_tp, 1);
++ tp_SetID3Encoding(m_tp, eUTF8);
+ tp_SetAutoFileLookup(m_tp, 1);
+ tp_SetRenameFiles(m_tp, 0);
+ tp_SetMoveFiles(m_tp, 0);
+@@ -123,8 +123,9 @@ static const char* getFileStatusText(TPF
+ void MusicBrainzClient::pollStatus()
+ {
+ TPCallbackEnum type;
++ TPFileStatus status;
+ int id;
+- while (tp_GetNotification(m_tp, &type, &id)) {
++ while (tp_GetNotification(m_tp, &type, &id, &status)) {
+ QString fn = getFilename(id);
+ int index = getIndexOfId(id);
+ switch (type) {
+@@ -211,7 +212,7 @@ void MusicBrainzClient::addFiles()
+ it = m_trackDataVector.begin();
+ it != m_trackDataVector.end();
+ ++it) {
+- m_ids[i++] = tp_AddFile(m_tp, QFile::encodeName((*it).getAbsFilename()));
++ m_ids[i++] = tp_AddFile(m_tp, QFile::encodeName((*it).getAbsFilename()), 1);
+ }
+ }
+
+@@ -290,10 +291,10 @@ bool MusicBrainzClient::getResults(int i
+ albumtrackresult_t* res = *albumTrackResults++;
+ ImportTrackData trackData;
+ trackData.title = QString::fromUtf8(res->name);
+- trackData.artist = QString::fromUtf8(res->artist->name);
+- trackData.album = QString::fromUtf8(res->album->name);
++ trackData.artist = QString::fromUtf8(res->artist.name);
++ trackData.album = QString::fromUtf8(res->album.name);
+ trackData.track = res->trackNum;
+- trackData.year = res->album->releaseYear;
++ trackData.year = res->album.releaseYear;
+ // year does not seem to work, so at least we should not
+ // overwrite it with 0
+ if (trackData.year == 0) {
diff --git a/media-sound/kid3/kid3-0.6.ebuild b/media-sound/kid3/kid3-0.6.ebuild
index 5eca255c8c79..27173f6f07f8 100644
--- a/media-sound/kid3/kid3-0.6.ebuild
+++ b/media-sound/kid3/kid3-0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.2 2005/11/06 16:53:05 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.3 2006/05/21 23:35:34 flameeyes Exp $
inherit kde
@@ -24,6 +24,14 @@ need-kde 3
# but the configure step that detects them
# cannot be avoided. So KDE support is forced on.
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ has_version '>=media-libs/tunepimp-0.4.0' && \
+ epatch "${FILESDIR}/${P}-tunepimp04.patch"
+}
+
src_compile() {
local myconf="--with-kde
$(use_with vorbis)