summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-11-24 14:09:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-11-24 14:09:05 +0000
commit756fd05fa3fd1185301ad6a541bbcb0a46ca5c4c (patch)
treeaa538bab8fe6f0dfe83228e77eb3f95dc746f5a0 /media-sound
parentVersion bumped. (diff)
downloadgentoo-2-756fd05fa3fd1185301ad6a541bbcb0a46ca5c4c.tar.gz
gentoo-2-756fd05fa3fd1185301ad6a541bbcb0a46ca5c4c.tar.bz2
gentoo-2-756fd05fa3fd1185301ad6a541bbcb0a46ca5c4c.zip
Add patch by Marco Leogrande to build with --as-needed (bug #286662), remove old automagic version (bug #280816), remove ao USE flag, as upstream does not seem to make it optional (bug #292743), add missing taglib dependency.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/shell-fm/ChangeLog10
-rw-r--r--media-sound/shell-fm/files/shell-fm-0.7-asneeded.patch39
-rw-r--r--media-sound/shell-fm/shell-fm-0.6.ebuild39
-rw-r--r--media-sound/shell-fm/shell-fm-0.7.ebuild16
4 files changed, 57 insertions, 47 deletions
diff --git a/media-sound/shell-fm/ChangeLog b/media-sound/shell-fm/ChangeLog
index 211647eb0443..6e0ecf7b159e 100644
--- a/media-sound/shell-fm/ChangeLog
+++ b/media-sound/shell-fm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/shell-fm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.11 2009/09/22 17:44:09 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.12 2009/11/24 14:09:05 flameeyes Exp $
+
+ 24 Nov 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ -shell-fm-0.6.ebuild, shell-fm-0.7.ebuild,
+ +files/shell-fm-0.7-asneeded.patch:
+ Add patch by Marco Leogrande to build with --as-needed (bug #286662),
+ remove old automagic version (bug #280816), remove ao USE flag, as
+ upstream does not seem to make it optional (bug #292743), add missing
+ taglib dependency.
*shell-fm-0.7 (22 Sep 2009)
diff --git a/media-sound/shell-fm/files/shell-fm-0.7-asneeded.patch b/media-sound/shell-fm/files/shell-fm-0.7-asneeded.patch
new file mode 100644
index 000000000000..fd0de6dbe040
--- /dev/null
+++ b/media-sound/shell-fm/files/shell-fm-0.7-asneeded.patch
@@ -0,0 +1,39 @@
+--- a/source/Makefile
++++ b/source/Makefile
+@@ -6,10 +6,10 @@ LIB := libshellfm.so
+ STATIC := libshellfm.a
+
+ ifeq ($(shell uname -s), OpenBSD)
+- LDFLAGS += -lossaudio
++ LDLIBS += -lossaudio
+ endif
+ ifeq ($(shell uname -s), NetBSD)
+- LDFLAGS += -lossaudio
++ LDLIBS += -lossaudio
+ endif
+ ifeq ($(shell uname -s), Darwin)
+ CFLAGS += -D__darwin__
+@@ -18,12 +18,12 @@ endif
+ CFLAGS += -Os -Wall -W -I./include/ -DLIBAO \
+ $(shell pkg-config --cflags mad) \
+ $(shell pkg-config --cflags ao)
+-LDFLAGS += $(shell pkg-config --libs mad) \
++LDLIBS += $(shell pkg-config --libs mad) \
+ $(shell pkg-config --libs ao)
+
+ ifeq ($(shell pkg-config --exists taglib_c && echo 1), 1)
+ CFLAGS += $(shell pkg-config --cflags taglib_c) -DTAGLIB
+- LDFLAGS += $(shell pkg-config --libs taglib_c)
++ LDLIBS += $(shell pkg-config --libs taglib_c)
+ endif
+
+ .PHONY: clean tags cscope
+@@ -40,7 +40,7 @@ $(STATIC) : $(OBJECT)
+ $(AR) -cvq $(STATIC) $(OBJECT)
+
+ $(BINARY) : $(STATIC)
+- $(CC) -o $(BINARY) $(CFLAGS) $(MAIN) $(LDFLAGS) $(STATIC)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(MAIN) $(STATIC) $(LDLIBS) -o $(BINARY)
+
+ clean :
+ rm -f $(OBJECT) $(BINARY) $(LIB) $(STATIC)
diff --git a/media-sound/shell-fm/shell-fm-0.6.ebuild b/media-sound/shell-fm/shell-fm-0.6.ebuild
deleted file mode 100644
index f0d69b120d87..000000000000
--- a/media-sound/shell-fm/shell-fm-0.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.6.ebuild,v 1.3 2009/06/20 18:36:30 ssuominen Exp $
-
-EAPI=2
-inherit toolchain-funcs
-
-DESCRIPTION="A lightweight console based player for Last.FM radio streams"
-HOMEPAGE="http://nex.scrapping.cc/shell-fm/"
-# I couldn't get constant tarball from github so I've tarballed this myself.
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="ao"
-
-RDEPEND="media-libs/libmad
- ao? ( media-libs/libao )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- sys-apps/sed"
-
-src_prepare() {
- sed -i -e "s:-Os:${CFLAGS}:g" source/Makefile || die "sed failed"
- use ao || sed -i -e "s:\$(LIBAO)::g" source/Makefile || die "sed failed"
-}
-
-src_compile() {
- tc-export CC
- emake || die "emake failed"
-}
-
-src_install() {
- dobin source/${PN} || die "dobin failed"
- doman manual/${PN}.1
- exeinto /usr/share/${PN}/scripts
- doexe scripts/{*.sh,*.pl,zcontrol} || die "doexe failed"
-}
diff --git a/media-sound/shell-fm/shell-fm-0.7.ebuild b/media-sound/shell-fm/shell-fm-0.7.ebuild
index d688a79dc1b6..051e3638cbc6 100644
--- a/media-sound/shell-fm/shell-fm-0.7.ebuild
+++ b/media-sound/shell-fm/shell-fm-0.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.7.ebuild,v 1.1 2009/09/22 17:44:09 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.7.ebuild,v 1.2 2009/11/24 14:09:05 flameeyes Exp $
EAPI=2
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="A lightweight console based player for Last.FM radio streams"
HOMEPAGE="http://nex.scrapping.cc/shell-fm/"
@@ -13,17 +13,19 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="ao"
+IUSE=""
RDEPEND="media-libs/libmad
- ao? ( media-libs/libao )"
+ media-libs/libao
+ media-libs/taglib"
DEPEND="${RDEPEND}
dev-util/pkgconfig
sys-apps/sed"
src_prepare() {
- sed -i -e "s:-Os:${CFLAGS}:g" source/Makefile || die "sed failed"
- use ao || sed -i -e "s:\$(LIBAO)::g" source/Makefile || die "sed failed"
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+
+ sed -i -e "s:-Os::" source/Makefile || die "sed failed"
}
src_compile() {
@@ -33,7 +35,7 @@ src_compile() {
src_install() {
dobin source/${PN} || die "dobin failed"
- doman manual/${PN}.1
+ doman manual/${PN}.1 || die
exeinto /usr/share/${PN}/scripts
doexe scripts/{*.sh,*.pl,zcontrol} || die "doexe failed"
}