summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-10-27 11:52:42 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-10-27 11:52:42 +0000
commit62c4f4936b2d657930f6909af449d33f96e559c1 (patch)
tree54088c25d2c8b26fc94e4be99e280f30f0f40a93 /media-sound
parentUse python_need_rebuild. (diff)
downloadgentoo-2-62c4f4936b2d657930f6909af449d33f96e559c1.tar.gz
gentoo-2-62c4f4936b2d657930f6909af449d33f96e559c1.tar.bz2
gentoo-2-62c4f4936b2d657930f6909af449d33f96e559c1.zip
Add kid3-1.1. Now it supports kde4 if installed.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/kid3/ChangeLog11
-rw-r--r--media-sound/kid3/kid3-1.1.ebuild60
2 files changed, 70 insertions, 1 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index a964f6c5a39e..ce4af98f1cbf 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/kid3
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.30 2008/06/11 20:03:08 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.31 2008/10/27 11:52:42 scarabeus Exp $
+
+*kid3-1.1 (27 Oct 2008)
+
+ 27 Oct 2008; Tomas Chvatal (scarabeus) <scarabeus@gentoo.org>
+ +kid3-1.1.ebuild:
+ Add kid3-1.1. Enables kde4/qt4 interface based on installed kde version.
+ Currently preffers kde4 over kde3. If someone wants only nonkde interface
+ for QT4 will not work due to forcing dep in Cmake and for QT3 configure
+ violates sandbox.
*kid3-1.0 (11 Jun 2008)
diff --git a/media-sound/kid3/kid3-1.1.ebuild b/media-sound/kid3/kid3-1.1.ebuild
new file mode 100644
index 000000000000..38ed335493d3
--- /dev/null
+++ b/media-sound/kid3/kid3-1.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-1.1.ebuild,v 1.1 2008/10/27 11:52:42 scarabeus Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A simple ID3 tag editor for QT/KDE."
+HOMEPAGE="http://kid3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kid3/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+flac +musicbrainz"
+
+# Kde cannot be disabled configure violates
+# sandbox and i aint fixing it.
+# Currently we preffer kde4 over kde3.
+DEPEND=">=media-libs/id3lib-3.8.3
+ >=media-libs/taglib-1.4-r1
+ media-libs/libmp4v2
+ media-libs/libvorbis
+ flac? ( media-libs/flac[cxx] )
+ || (
+ >=kde-base/kdelibs-3.9
+ kde-base/kdelibs:3.5
+ )
+ musicbrainz? (
+ media-libs/musicbrainz:3
+ media-libs/tunepimp
+ )"
+
+src_configure() {
+ if has_version ">=kde-base/kdelibs-3.9"; then
+ # we shall use kde4
+ # there is option WITH_KDE but kde is needed anyway
+ # so forcing
+ mycmakeargs="${mycmakeargs}
+ -DWITH_KDE=ON
+ -DWITH_TAGLIB=ON
+ -DWITH_VORBIS=ON
+ $(cmake-utils_use_with flac FLAC)
+ $(cmake-utils_use_with musicbrainz TUNEPIMP)
+ "
+ cmake-utils_src_configure
+ else
+ # we shall use kde3
+ # Compile fails without taglib, forced on.
+ # Ditto for vorbis, so there you go.
+ econf \
+ --with-kde \
+ --with-taglib \
+ --without-arts \
+ --with-vorbis \
+ $(use_with flac)
+ $(use_with musicbrainz)
+ fi
+}